]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- initial auto/th/opencv-1_1-0_pre1_1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 18 Mar 2009 21:26:16 +0000 (21:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    opencv.spec -> 1.1

opencv.spec [new file with mode: 0644]

diff --git a/opencv.spec b/opencv.spec
new file mode 100644 (file)
index 0000000..0bd0d83
--- /dev/null
@@ -0,0 +1,119 @@
+%bcond_with    xine
+%define        snap    pre1
+Summary:       A library of programming functions mainly aimed at real time computer vision
+Name:          opencv
+Version:       1.1
+Release:       0.%{snap}.1
+Epoch:         1
+License:       BSD
+Group:         Libraries
+Source0:       http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
+# Source0-md5: b147b7cd3c059831c415c5a2bcecdf95
+URL:           http://opencv.willowgarage.com
+BuildRequires: autoconf >= 2.53
+BuildRequires: automake
+BuildRequires: ffmpeg-devel
+BuildRequires: jasper-devel
+BuildRequires: libdc1394-devel
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libraw1394-devel
+BuildRequires: libtiff-devel
+BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
+BuildRequires: zlib-devel
+%pyrequires_eq python-libs
+%{?with_xine:BuildRequires:    xine-lib-devel}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+OpenCV (Open Source Computer Vision) is a library of programming
+functions mainly aimed at real time computer vision.
+
+Example applications of the OpenCV library are Human-Computer
+Interaction (HCI); Object Identification, Segmentation and
+Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
+Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
+and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
+
+%package devel
+Summary:       Header files and develpment documentation for opencv
+Group:         Development/Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description devel
+Header files and opencv documentation.
+
+%package static
+Summary:       Static opencv library
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+
+%description static
+This package contains the static library used for development.
+
+%package -n python-opencv
+Summary:       OpenCV Python bindings
+Group:         Development/Languages/Python
+%pyrequires_eq  python
+Requires:      %{name} = %{version}-%{release}
+
+%description -n python-opencv
+OpenCV Python bindings.
+
+%prep
+%setup -q -n %{name}-%{version}.0
+
+%build
+%configure \
+%ifarch i686 pentium4 athlon %{x8664}
+       --enable-sse2 \
+%else
+       --disable-sse2 \
+%endif
+       --with-python \
+       --with%{!?with_xine:-out}-xine \
+       --with-ffmpeg \
+       --with-1394libs \
+       --with-v4l \
+       --with-gtk \
+       --without-gstreamer \
+       --without-quicktime
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS COPYING ChangeLog THANKS TODO
+%doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/lib*so.*.*
+%attr(755,root,root) %ghost %{_libdir}/lib*.so.2
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/lib*.la
+%{_includedir}/opencv
+%{_pkgconfigdir}/*.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
+
+%files -n python-opencv
+%defattr(644,root,root,755)
+%dir %{py_sitedir}/opencv
+%attr(755,root,root) %{py_sitedir}/opencv/*.so
+%{py_sitedir}/opencv/*.py[co]
This page took 0.047821 seconds and 4 git commands to generate.