]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- rel 5; build fixed
[packages/opencv.git] / opencv.spec
CommitLineData
901927d3
AM
1%bcond_with xine
2%define snap pre1
3Summary: A library of programming functions mainly aimed at real time computer vision
4Name: opencv
5Version: 1.1
29d82ddf 6Release: 0.%{snap}.5
901927d3
AM
7Epoch: 1
8License: BSD
9Group: Libraries
10Source0: http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
11# Source0-md5: b147b7cd3c059831c415c5a2bcecdf95
148338c5 12Patch0: %{name}-ffmpeg.patch
4b75cbf1 13Patch1: %{name}-am.patch
29d82ddf 14Patch2: %{name}-build.patch
901927d3
AM
15URL: http://opencv.willowgarage.com
16BuildRequires: autoconf >= 2.53
17BuildRequires: automake
18BuildRequires: ffmpeg-devel
19BuildRequires: jasper-devel
20BuildRequires: libdc1394-devel
21BuildRequires: libjpeg-devel
22BuildRequires: libpng-devel
23BuildRequires: libraw1394-devel
24BuildRequires: libtiff-devel
148338c5 25BuildRequires: libtool
901927d3
AM
26BuildRequires: python-devel
27BuildRequires: rpm-pythonprov
996927aa 28BuildRequires: swig-python
901927d3
AM
29BuildRequires: zlib-devel
30%pyrequires_eq python-libs
31%{?with_xine:BuildRequires: xine-lib-devel}
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35OpenCV (Open Source Computer Vision) is a library of programming
36functions mainly aimed at real time computer vision.
37
38Example applications of the OpenCV library are Human-Computer
39Interaction (HCI); Object Identification, Segmentation and
40Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
41Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
42and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
43
44%package devel
45Summary: Header files and develpment documentation for opencv
46Group: Development/Libraries
47Requires: %{name} = %{epoch}:%{version}-%{release}
48
49%description devel
50Header files and opencv documentation.
51
52%package static
53Summary: Static opencv library
54Group: Development/Libraries
55Requires: %{name}-devel = %{epoch}:%{version}-%{release}
56
57%description static
58This package contains the static library used for development.
59
60%package -n python-opencv
61Summary: OpenCV Python bindings
62Group: Development/Languages/Python
63%pyrequires_eq python
cd1f0136 64Requires: %{name} = %{epoch}:%{version}-%{release}
901927d3
AM
65
66%description -n python-opencv
67OpenCV Python bindings.
68
69%prep
70%setup -q -n %{name}-%{version}.0
148338c5 71%patch0 -p0
4b75cbf1 72%patch1 -p1
29d82ddf 73%patch2 -p1
148338c5
AM
74
75sed -i -e 's#ACLOCAL_AMFLAGS.*##g' Makefile.am
76sed -i -e 's#pkgpython#pkgpyexec#g' interfaces/swig/python/Makefile.am
77sed -i -e 's#-L$(SWIG_PYTHON_LIBS)#$(NOTING_NOT_EMPTY_LINE)#g' interfaces/swig/python/Makefile.am
901927d3
AM
78
79%build
148338c5
AM
80%{__libtoolize}
81%{__aclocal} -I autotools/aclocal
82%{__autoconf}
83%{__automake}
901927d3
AM
84%configure \
85%ifarch i686 pentium4 athlon %{x8664}
86 --enable-sse2 \
87%else
88 --disable-sse2 \
89%endif
90 --with-python \
148338c5 91 --with%{!?with_xine:out}-xine \
901927d3
AM
92 --with-ffmpeg \
93 --with-1394libs \
94 --with-v4l \
95 --with-gtk \
96 --without-gstreamer \
97 --without-quicktime
98%{__make}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110%postun -p /sbin/ldconfig
111
112%files
113%defattr(644,root,root,755)
114%doc AUTHORS COPYING ChangeLog THANKS TODO
115%doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
116%attr(755,root,root) %{_bindir}/*
117%attr(755,root,root) %{_libdir}/lib*so.*.*
118%attr(755,root,root) %ghost %{_libdir}/lib*.so.2
119
120%files devel
121%defattr(644,root,root,755)
122%attr(755,root,root) %{_libdir}/lib*.so
123%{_libdir}/lib*.la
124%{_includedir}/opencv
125%{_pkgconfigdir}/*.pc
126
127%files static
128%defattr(644,root,root,755)
129%{_libdir}/lib*.a
130
131%files -n python-opencv
132%defattr(644,root,root,755)
133%dir %{py_sitedir}/opencv
134%attr(755,root,root) %{py_sitedir}/opencv/*.so
135%{py_sitedir}/opencv/*.py[co]
This page took 0.047641 seconds and 4 git commands to generate.