]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
- rel 3
[packages/opal.git] / opal.spec
1 # TODO:
2 #       fix static libname (libopal_s.a)
3 #       IPv6 support requires IPv6 support in ptlib
4 #       x264+ffmpeg detection sucks - it doesn't work with --as-needed
5 #       SpanDSP FAX support requires t38_indicator symbol
6 #       MPEG4 rate control correction requires libavcodec sources
7 #       CAPI support
8 #
9 # Conditional build:
10 %bcond_with     sip_fax_only    # Minimal build for t38modem + SIP
11 #
12 # Don't touch this! strip removes all symbols from library
13 %define         no_install_post_strip           1
14 #
15 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
16 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
17 Name:           opal
18 Version:        3.6.6
19 Release:        3
20 License:        MPL
21 Group:          Libraries
22 Source0:        http://ftp.gnome.org/pub/gnome/sources/opal/3.6/%{name}-%{version}.tar.bz2
23 # Source0-md5:  43b363c860780e7f1a0361cfee8f9f4a
24 #Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
25 Patch0:         %{name}-libname.patch
26 Patch1:         %{name}-mak_files.patch
27 Patch2:         %{name}-ac.patch
28 Patch3:         %{name}-build.patch
29 URL:            http://www.openh323.org/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  expat-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  ptlib-devel >= 2.4.2-3
36 BuildRequires:  sed >= 4.0
37 %if %{without sip_fax_only}
38 BuildRequires:  SDL-devel
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  libgsm-devel
41 BuildRequires:  libtheora-devel
42 BuildRequires:  libx264-devel
43 BuildRequires:  openssl-devel
44 BuildRequires:  speex-devel >= 1:1.1.5
45 BuildRequires:  unixODBC-devel
46 %endif
47 %requires_eq    ptlib
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         filterout_ld    -Wl,--as-needed
51
52 %description
53 The OPAL project aims to create a full featured, interoperable,
54 Open Source implementation of the ITU H.323 teleconferencing protocol
55 that can be used by personal developers and commercial users without
56 charge.
57
58 %description -l pl.UTF-8
59 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
60 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
61 który może być używany przez użytkowników prywatnych i komercyjnych
62 bez opłat.
63
64 %package devel
65 Summary:        Opal development files
66 Summary(pl.UTF-8):      Pliki dla developerów Opal
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       libstdc++-devel
70 Requires:       ptlib-devel
71
72 %description devel
73 Header files and libraries for developing applications that use
74 OPAL.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
78 używających OPAL.
79
80 %package static
81 Summary:        OPAL static libraries
82 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 OPAL static libraries.
88
89 %description static -l pl.UTF-8
90 Biblioteki statyczne OPAL.
91
92 %prep
93 %setup -q
94 #patch0 -p1
95 #patch1 -p1
96 #%patch2 -p1
97 %patch3 -p1
98
99 %build
100 PWLIBDIR=%{_prefix}; export PWLIBDIR
101 OPALDIR=`pwd`; export OPALDIR
102 OPAL_BUILD="yes"; export OPAL_BUILD
103 %{__aclocal}
104 %{__autoconf}
105 # Run  grep '^OPAL_.*=' configure.ac|grep 'yes\|no'  to check current defaults
106 %configure \
107 %if %{with sip_fax_only}
108         --enable-sip \
109         --enable-t38 \
110         --enable-fax \
111         --enable-statistics \
112         --disable-java \
113         --disable-video \
114         --disable-h323 \
115         --disable-iax \
116         --disable-h224 \
117         --disable-h281 \
118         --disable-sipim \
119         --disable-rfc4103 \
120         --disable-h450 \
121         --disable-h460 \
122         --disable-h501 \
123         --disable-lid \
124         --disable-ivr \
125         --disable-rfc4175 \
126         --disable-aec \
127         --disable-g711plc \
128         --disable-plugins
129 %else
130         --enable-ixj
131 %endif
132
133
134 %{__make} %{?debug:debug}%{!?debug:opt} \
135         CC="%{__cc}" \
136         CPLUS="%{__cxx}" \
137         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
138
139 %{__cp} -a */libopal* .
140 %if %{without sip_fax_only}
141 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
142         CC="%{__cc}" \
143         CPLUS=%{__cxx} \
144         CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
145         LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
146 %endif
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT%{_bindir}
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{!?with_sip_fax_only:install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}}
156
157 install opal_{inc,defs}.mak $RPM_BUILD_ROOT%{_includedir}/opal
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/lib*.so.*.*
168 %if %{without sip_fax_only}
169 %attr(755,root,root) %{_bindir}/*
170 %dir %{_libdir}/opal-%{version}
171 %dir %{_libdir}/opal-%{version}/codecs
172 %dir %{_libdir}/opal-%{version}/codecs/audio
173 %dir %{_libdir}/opal-%{version}/codecs/video
174 %dir %{_libdir}/opal-%{version}/lid
175 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_audio_pwplugin.so
176 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_audio_pwplugin.so
177 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_audio_pwplugin.so
178 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_pwplugin.so
179 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ilbc_audio_pwplugin.so
180 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_audio_pwplugin.so
181 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_audio_pwplugin.so
182 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_audio_pwplugin.so
183 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261-vic_video_pwplugin.so
184 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-1998_video_pwplugin.so
185 #%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-ffmpeg_video_pwplugin.so
186 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
187 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin.so
188 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4-ffmpeg_video_pwplugin.so
189 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_video_pwplugin.so
190 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
191 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
192 %endif
193
194 %files devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/*.so
197 %{_includedir}/opal
198 %{_pkgconfigdir}/opal.pc
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/*.a
This page took 0.154423 seconds and 4 git commands to generate.