]> git.pld-linux.org Git - packages/opal.git/blame - opal.spec
- rel 3
[packages/opal.git] / opal.spec
CommitLineData
4811172d 1# TODO:
c0a25d84 2# fix static libname (libopal_s.a)
7d38eb5a
SS
3# IPv6 support requires IPv6 support in ptlib
4# x264+ffmpeg detection sucks - it doesn't work with --as-needed
5# SpanDSP FAX support requires t38_indicator symbol
6# MPEG4 rate control correction requires libavcodec sources
7# CAPI support
5683c404 8#
12913987
MM
9# Conditional build:
10%bcond_with sip_fax_only # Minimal build for t38modem + SIP
11#
5683c404
JR
12# Don't touch this! strip removes all symbols from library
13%define no_install_post_strip 1
14#
aaf12cf0 15Summary: Open Phone Abstraction Library (aka OpenH323 v2)
075bc36b 16Summary(pl.UTF-8): Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
aaf12cf0 17Name: opal
bc09e567 18Version: 3.6.6
12913987 19Release: 3
aaf12cf0
PG
20License: MPL
21Group: Libraries
0dd5a601 22Source0: http://ftp.gnome.org/pub/gnome/sources/opal/3.6/%{name}-%{version}.tar.bz2
bc09e567 23# Source0-md5: 43b363c860780e7f1a0361cfee8f9f4a
a7fa741b 24#Source0: http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
0a847dbc 25Patch0: %{name}-libname.patch
c1724659 26Patch1: %{name}-mak_files.patch
323ecc81 27Patch2: %{name}-ac.patch
c0a25d84 28Patch3: %{name}-build.patch
a1d65832 29URL: http://www.openh323.org/
323ecc81 30BuildRequires: autoconf
105bdcf7 31BuildRequires: automake
32BuildRequires: expat-devel
12913987
MM
33BuildRequires: libstdc++-devel
34BuildRequires: pkgconfig
35BuildRequires: ptlib-devel >= 2.4.2-3
36BuildRequires: sed >= 4.0
37%if %{without sip_fax_only}
38BuildRequires: SDL-devel
7d38eb5a
SS
39BuildRequires: ffmpeg-devel
40BuildRequires: libgsm-devel
7d38eb5a
SS
41BuildRequires: libtheora-devel
42BuildRequires: libx264-devel
fda4b81c 43BuildRequires: openssl-devel
0b6b8659 44BuildRequires: speex-devel >= 1:1.1.5
105bdcf7 45BuildRequires: unixODBC-devel
12913987 46%endif
d2161d53 47%requires_eq ptlib
aaf12cf0
PG
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
7d38eb5a
SS
50%define filterout_ld -Wl,--as-needed
51
aaf12cf0 52%description
296d779e 53The OPAL project aims to create a full featured, interoperable,
aaf12cf0
PG
54Open Source implementation of the ITU H.323 teleconferencing protocol
55that can be used by personal developers and commercial users without
56charge.
57
a2a27970
JR
58%description -l pl.UTF-8
59Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
60wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
61który może być używany przez użytkowników prywatnych i komercyjnych
62bez opłat.
aaf12cf0
PG
63
64%package devel
65Summary: Opal development files
075bc36b 66Summary(pl.UTF-8): Pliki dla developerów Opal
aaf12cf0 67Group: Development/Libraries
5e9f9381 68Requires: %{name} = %{version}-%{release}
aaf12cf0 69Requires: libstdc++-devel
514c2bd8 70Requires: ptlib-devel
aaf12cf0
PG
71
72%description devel
73Header files and libraries for developing applications that use
296d779e 74OPAL.
aaf12cf0 75
a2a27970
JR
76%description devel -l pl.UTF-8
77Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
78używających OPAL.
aaf12cf0 79
0a847dbc 80%package static
296d779e 81Summary: OPAL static libraries
075bc36b 82Summary(pl.UTF-8): Biblioteki statyczne OPAL
0a847dbc 83Group: Development/Libraries
5e9f9381 84Requires: %{name}-devel = %{version}-%{release}
aaf12cf0 85
0a847dbc 86%description static
296d779e 87OPAL static libraries.
aaf12cf0 88
a2a27970 89%description static -l pl.UTF-8
296d779e 90Biblioteki statyczne OPAL.
aaf12cf0
PG
91
92%prep
8db2f0fb 93%setup -q
fda4b81c
SS
94#patch0 -p1
95#patch1 -p1
0dd5a601 96#%patch2 -p1
c0a25d84 97%patch3 -p1
aaf12cf0
PG
98
99%build
b0b5ec3f 100PWLIBDIR=%{_prefix}; export PWLIBDIR
296d779e 101OPALDIR=`pwd`; export OPALDIR
c1724659 102OPAL_BUILD="yes"; export OPAL_BUILD
323ecc81
SS
103%{__aclocal}
104%{__autoconf}
12913987 105# Run grep '^OPAL_.*=' configure.ac|grep 'yes\|no' to check current defaults
7d38eb5a 106%configure \
12913987
MM
107%if %{with sip_fax_only}
108 --enable-sip \
109 --enable-t38 \
110 --enable-fax \
111 --enable-statistics \
112 --disable-java \
113 --disable-video \
114 --disable-h323 \
115 --disable-iax \
116 --disable-h224 \
117 --disable-h281 \
118 --disable-sipim \
119 --disable-rfc4103 \
120 --disable-h450 \
121 --disable-h460 \
122 --disable-h501 \
123 --disable-lid \
124 --disable-ivr \
125 --disable-rfc4175 \
126 --disable-aec \
127 --disable-g711plc \
128 --disable-plugins
129%else
7d38eb5a 130 --enable-ixj
12913987
MM
131%endif
132
b0b5ec3f 133
c1724659 134%{__make} %{?debug:debug}%{!?debug:opt} \
296d779e
JR
135 CC="%{__cc}" \
136 CPLUS="%{__cxx}" \
137 OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
b0b5ec3f 138
c0a25d84 139%{__cp} -a */libopal* .
12913987 140%if %{without sip_fax_only}
c1724659 141%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
296d779e
JR
142 CC="%{__cc}" \
143 CPLUS=%{__cxx} \
c0a25d84
SS
144 CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
145 LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
12913987 146%endif
aaf12cf0
PG
147
148%install
149rm -rf $RPM_BUILD_ROOT
4733c726 150install -d $RPM_BUILD_ROOT%{_bindir}
b0b5ec3f 151
152%{__make} install \
153 DESTDIR=$RPM_BUILD_ROOT
aaf12cf0 154
12913987
MM
155%{!?with_sip_fax_only:install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}}
156
157install opal_{inc,defs}.mak $RPM_BUILD_ROOT%{_includedir}/opal
aaf12cf0
PG
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%post -p /sbin/ldconfig
163%postun -p /sbin/ldconfig
164
165%files
166%defattr(644,root,root,755)
b0b5ec3f 167%attr(755,root,root) %{_libdir}/lib*.so.*.*
12913987
MM
168%if %{without sip_fax_only}
169%attr(755,root,root) %{_bindir}/*
0dd5a601 170%dir %{_libdir}/opal-%{version}
171%dir %{_libdir}/opal-%{version}/codecs
172%dir %{_libdir}/opal-%{version}/codecs/audio
173%dir %{_libdir}/opal-%{version}/codecs/video
174%dir %{_libdir}/opal-%{version}/lid
bc09e567 175%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_audio_pwplugin.so
0dd5a601 176%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_audio_pwplugin.so
177%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_audio_pwplugin.so
178%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_pwplugin.so
179%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ilbc_audio_pwplugin.so
180%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_audio_pwplugin.so
181%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_audio_pwplugin.so
182%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_audio_pwplugin.so
183%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261-vic_video_pwplugin.so
bc09e567 184%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-1998_video_pwplugin.so
0dd5a601 185#%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-ffmpeg_video_pwplugin.so
bc09e567
AM
186%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
187%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin.so
188%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4-ffmpeg_video_pwplugin.so
0dd5a601 189%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_video_pwplugin.so
190%attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
191%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
12913987 192%endif
aaf12cf0
PG
193
194%files devel
195%defattr(644,root,root,755)
aaf12cf0 196%attr(755,root,root) %{_libdir}/*.so
4733c726
SS
197%{_includedir}/opal
198%{_pkgconfigdir}/opal.pc
aaf12cf0 199
296d779e
JR
200%files static
201%defattr(644,root,root,755)
202%{_libdir}/*.a
This page took 0.095535 seconds and 4 git commands to generate.