]> git.pld-linux.org Git - packages/opal.git/blame - opal.spec
- now devel requires ptlib-devel
[packages/opal.git] / opal.spec
CommitLineData
4811172d 1# TODO:
c0a25d84 2# fix static libname (libopal_s.a)
4811172d
SS
3# check why:
4# checking PTLIB has expat... no
5# checking PTLIB has vxml... no
6# checking PTLIB has ipv6... no
7# checking PTLIB has ldap... no
8# ... and check plugin configuration:
9# GSM : yes (internal)
10# H.263+ :
11# H.264 : no
12# THEORA : no
13# MPEG4 Part 2 : no
14# SpanDSP FAX : no
15# CAPI : no
16# Quicknet xJACK support : no
5683c404
JR
17#
18# Don't touch this! strip removes all symbols from library
19%define no_install_post_strip 1
20#
aaf12cf0 21Summary: Open Phone Abstraction Library (aka OpenH323 v2)
075bc36b 22Summary(pl.UTF-8): Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
aaf12cf0 23Name: opal
4f0130ae 24Version: 3.4.2
514c2bd8 25Release: 0.2
aaf12cf0
PG
26License: MPL
27Group: Libraries
4f0130ae
SS
28Source0: http://ftp.gnome.org/pub/gnome/sources/opal/3.4/%{name}-%{version}.tar.bz2
29# Source0-md5: a1d11099fa00d77a79dcfe513872e8dc
a7fa741b 30#Source0: http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
0a847dbc 31Patch0: %{name}-libname.patch
c1724659 32Patch1: %{name}-mak_files.patch
323ecc81 33Patch2: %{name}-ac.patch
c0a25d84 34Patch3: %{name}-build.patch
a1d65832 35URL: http://www.openh323.org/
fda4b81c 36BuildRequires: SDL-devel
323ecc81
SS
37BuildRequires: automake
38BuildRequires: autoconf
aaf12cf0 39BuildRequires: libstdc++-devel
fda4b81c
SS
40BuildRequires: openssl-devel
41BuildRequires: pkgconfig
42BuildRequires: ptlib-devel
3ba5c27c 43BuildRequires: sed >= 4.0
0b6b8659 44BuildRequires: speex-devel >= 1:1.1.5
aaf12cf0 45%requires_eq pwlib
aaf12cf0
PG
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
296d779e 49The OPAL project aims to create a full featured, interoperable,
aaf12cf0
PG
50Open Source implementation of the ITU H.323 teleconferencing protocol
51that can be used by personal developers and commercial users without
52charge.
53
a2a27970
JR
54%description -l pl.UTF-8
55Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
56wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
57który może być używany przez użytkowników prywatnych i komercyjnych
58bez opłat.
aaf12cf0
PG
59
60%package devel
61Summary: Opal development files
075bc36b 62Summary(pl.UTF-8): Pliki dla developerów Opal
aaf12cf0 63Group: Development/Libraries
5e9f9381 64Requires: %{name} = %{version}-%{release}
aaf12cf0 65Requires: libstdc++-devel
514c2bd8 66Requires: ptlib-devel
aaf12cf0
PG
67
68%description devel
69Header files and libraries for developing applications that use
296d779e 70OPAL.
aaf12cf0 71
a2a27970
JR
72%description devel -l pl.UTF-8
73Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
74używających OPAL.
aaf12cf0 75
0a847dbc 76%package static
296d779e 77Summary: OPAL static libraries
075bc36b 78Summary(pl.UTF-8): Biblioteki statyczne OPAL
0a847dbc 79Group: Development/Libraries
5e9f9381 80Requires: %{name}-devel = %{version}-%{release}
aaf12cf0 81
0a847dbc 82%description static
296d779e 83OPAL static libraries.
aaf12cf0 84
a2a27970 85%description static -l pl.UTF-8
296d779e 86Biblioteki statyczne OPAL.
aaf12cf0
PG
87
88%prep
8db2f0fb 89%setup -q
fda4b81c
SS
90#patch0 -p1
91#patch1 -p1
323ecc81 92%patch2 -p1
c0a25d84 93%patch3 -p1
aaf12cf0
PG
94
95%build
b0b5ec3f 96PWLIBDIR=%{_prefix}; export PWLIBDIR
296d779e 97OPALDIR=`pwd`; export OPALDIR
c1724659 98OPAL_BUILD="yes"; export OPAL_BUILD
323ecc81
SS
99%{__aclocal}
100%{__autoconf}
101%configure
b0b5ec3f 102
c1724659 103%{__make} %{?debug:debug}%{!?debug:opt} \
296d779e
JR
104 CC="%{__cc}" \
105 CPLUS="%{__cxx}" \
106 OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
b0b5ec3f 107
c0a25d84 108%{__cp} -a */libopal* .
c1724659 109%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
296d779e
JR
110 CC="%{__cc}" \
111 CPLUS=%{__cxx} \
c0a25d84
SS
112 CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
113 LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
aaf12cf0
PG
114
115%install
116rm -rf $RPM_BUILD_ROOT
4733c726 117install -d $RPM_BUILD_ROOT%{_bindir}
b0b5ec3f 118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
aaf12cf0 121
4733c726 122install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
aaf12cf0
PG
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files
131%defattr(644,root,root,755)
296d779e 132%attr(755,root,root) %{_bindir}/*
b0b5ec3f 133%attr(755,root,root) %{_libdir}/lib*.so.*.*
4733c726
SS
134%dir %{_libdir}/opal-3.4.2
135%dir %{_libdir}/opal-3.4.2/codecs
136%dir %{_libdir}/opal-3.4.2/codecs/audio
137%dir %{_libdir}/opal-3.4.2/codecs/video
138%dir %{_libdir}/opal-3.4.2/lid
139%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/g726_audio_pwplugin.so
140%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsm0610_audio_pwplugin.so
141%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsmamrcodec_pwplugin.so
142%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ilbc_audio_pwplugin.so
143%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ima_adpcm_audio_pwplugin.so
144%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/lpc10_audio_pwplugin.so
145%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/speex_audio_pwplugin.so
146%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h261-vic_video_pwplugin.so
147%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h263-ffmpeg_video_pwplugin.so
148%attr(755,root,root) %{_libdir}/opal-3.4.2/lid/vpb_lid_pwplugin.so
aaf12cf0
PG
149
150%files devel
151%defattr(644,root,root,755)
aaf12cf0 152%attr(755,root,root) %{_libdir}/*.so
4733c726
SS
153%{_includedir}/opal
154%{_pkgconfigdir}/opal.pc
aaf12cf0 155
296d779e
JR
156%files static
157%defattr(644,root,root,755)
158%{_libdir}/*.a
This page took 0.125391 seconds and 4 git commands to generate.