]> git.pld-linux.org Git - packages/opal.git/blame - opal.spec
- release 3 (by relup.sh)
[packages/opal.git] / opal.spec
CommitLineData
4811172d 1# TODO:
c0a25d84 2# fix static libname (libopal_s.a)
7d38eb5a
SS
3# IPv6 support requires IPv6 support in ptlib
4# x264+ffmpeg detection sucks - it doesn't work with --as-needed
5# SpanDSP FAX support requires t38_indicator symbol
6# MPEG4 rate control correction requires libavcodec sources
7# CAPI support
5683c404 8#
383877b6
JK
9# WARNING: opal version should match Ekiga and ptlib versions
10# Recommendations: http://wiki.ekiga.org/index.php/Download_Ekiga_sources
11#
12913987
MM
12# Conditional build:
13%bcond_with sip_fax_only # Minimal build for t38modem + SIP
7f398677 14%bcond_without celt # Build with CELT codec support
12913987 15#
5683c404
JR
16# Don't touch this! strip removes all symbols from library
17%define no_install_post_strip 1
18#
aaf12cf0 19Summary: Open Phone Abstraction Library (aka OpenH323 v2)
075bc36b 20Summary(pl.UTF-8): Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
aaf12cf0 21Name: opal
317246e4 22Version: 3.10.8
27956a0e 23Release: 3
aaf12cf0
PG
24License: MPL
25Group: Libraries
f7ddb932
CM
26URL: http://www.opalvoip.org
27Source0: http://downloads.sourceforge.net/opalvoip/%{name}-%{version}.tar.bz2
317246e4 28# Source0-md5: b4907073e00889a9e7c6c49d41e4e2d4
e377535f 29Patch0: %{name}-build.patch
79955eae
JR
30Patch1: %{name}-3.10.8-svn-revision.patch
31Patch2: %{name}-ffmpeg10.patch
323ecc81 32BuildRequires: autoconf
105bdcf7 33BuildRequires: automake
24ae7846 34%{?with_celt:BuildRequires: celt-devel}
105bdcf7 35BuildRequires: expat-devel
12913987
MM
36BuildRequires: libstdc++-devel
37BuildRequires: pkgconfig
24ae7846 38BuildRequires: ptlib-devel >= 1:2.10.8
12913987 39BuildRequires: sed >= 4.0
24ae7846 40%{?with_celt:Requires: celt}
12913987
MM
41%if %{without sip_fax_only}
42BuildRequires: SDL-devel
7d38eb5a
SS
43BuildRequires: ffmpeg-devel
44BuildRequires: libgsm-devel
7d38eb5a
SS
45BuildRequires: libtheora-devel
46BuildRequires: libx264-devel
b4fd80b4 47BuildRequires: webrtc-libilbc-devel
fda4b81c 48BuildRequires: openssl-devel
0b6b8659 49BuildRequires: speex-devel >= 1:1.1.5
105bdcf7 50BuildRequires: unixODBC-devel
12913987 51%endif
d2161d53 52%requires_eq ptlib
aaf12cf0
PG
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
7d38eb5a
SS
55%define filterout_ld -Wl,--as-needed
56
aaf12cf0 57%description
0a401c5c
CM
58The OPAL project aims to create a full featured, interoperable, Open
59Source implementation of the ITU H.323 teleconferencing protocol that
60can be used by personal developers and commercial users without
aaf12cf0
PG
61charge.
62
a2a27970
JR
63%description -l pl.UTF-8
64Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
65wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
66który może być używany przez użytkowników prywatnych i komercyjnych
67bez opłat.
aaf12cf0
PG
68
69%package devel
70Summary: Opal development files
075bc36b 71Summary(pl.UTF-8): Pliki dla developerów Opal
aaf12cf0 72Group: Development/Libraries
5e9f9381 73Requires: %{name} = %{version}-%{release}
aaf12cf0 74Requires: libstdc++-devel
59be64a4 75Requires: ptlib-devel
aaf12cf0
PG
76
77%description devel
0a401c5c 78Header files and libraries for developing applications that use OPAL.
aaf12cf0 79
a2a27970
JR
80%description devel -l pl.UTF-8
81Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
82używających OPAL.
aaf12cf0 83
0a847dbc 84%package static
296d779e 85Summary: OPAL static libraries
075bc36b 86Summary(pl.UTF-8): Biblioteki statyczne OPAL
0a847dbc 87Group: Development/Libraries
5e9f9381 88Requires: %{name}-devel = %{version}-%{release}
aaf12cf0 89
0a847dbc 90%description static
296d779e 91OPAL static libraries.
aaf12cf0 92
a2a27970 93%description static -l pl.UTF-8
296d779e 94Biblioteki statyczne OPAL.
aaf12cf0
PG
95
96%prep
8db2f0fb 97%setup -q
e377535f
JR
98%patch0 -p1
99%patch1 -p1
79955eae 100%patch2 -p1
aaf12cf0
PG
101
102%build
b0b5ec3f 103PWLIBDIR=%{_prefix}; export PWLIBDIR
296d779e 104OPALDIR=`pwd`; export OPALDIR
c1724659 105OPAL_BUILD="yes"; export OPAL_BUILD
323ecc81
SS
106%{__aclocal}
107%{__autoconf}
b8ea5cae 108cd plugins
0a401c5c 109%{__aclocal}
b8ea5cae
AM
110%{__autoconf}
111cd ..
12913987 112# Run grep '^OPAL_.*=' configure.ac|grep 'yes\|no' to check current defaults
7d38eb5a 113%configure \
12913987
MM
114%if %{with sip_fax_only}
115 --enable-sip \
116 --enable-t38 \
117 --enable-fax \
118 --enable-statistics \
119 --disable-java \
120 --disable-video \
121 --disable-h323 \
122 --disable-iax \
123 --disable-h224 \
124 --disable-h281 \
125 --disable-sipim \
126 --disable-rfc4103 \
127 --disable-h450 \
128 --disable-h460 \
129 --disable-h501 \
130 --disable-lid \
131 --disable-ivr \
132 --disable-rfc4175 \
133 --disable-aec \
134 --disable-g711plc \
135 --disable-plugins
136%else
7f398677 137%{!?with_celt:--disable-celt} \
7d38eb5a 138 --enable-ixj
12913987
MM
139%endif
140
c1724659 141%{__make} %{?debug:debug}%{!?debug:opt} \
296d779e
JR
142 CC="%{__cc}" \
143 CPLUS="%{__cxx}" \
144 OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
b0b5ec3f 145
c0a25d84 146%{__cp} -a */libopal* .
12913987 147%if %{without sip_fax_only}
c1724659 148%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
296d779e 149 CC="%{__cc}" \
5ce6a9aa 150 CPLUS="%{__cxx}" \
c0a25d84
SS
151 CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
152 LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
12913987 153%endif
aaf12cf0
PG
154
155%install
156rm -rf $RPM_BUILD_ROOT
4733c726 157install -d $RPM_BUILD_ROOT%{_bindir}
b0b5ec3f 158
159%{__make} install \
160 DESTDIR=$RPM_BUILD_ROOT
aaf12cf0 161
12913987
MM
162%{!?with_sip_fax_only:install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}}
163
4a7dfbfa
MM
164# This needs to be done after 'make install'
165sed -i -e \
166's,^OPALDIR.*=.*$,OPALDIR\t\t\t\t= %{_libdir}/opal-%{version},;'\
167's,^OPAL_SRCDIR.*=.*$,OPAL_SRCDIR\t\t\t= %{_usrsrc}/debug/opal-%{version},;'\
168's,^OPAL_INCDIR.*=.*$,OPAL_INCDIR\t\t\t= %{_includedir}/opal,;'\
169's,^OPAL_LIBDIR.*=.*$,OPAL_LIBDIR\t\t\t= %{_libdir},;' \
170opal_defs.mak
171
12913987 172install opal_{inc,defs}.mak $RPM_BUILD_ROOT%{_includedir}/opal
aaf12cf0
PG
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -p /sbin/ldconfig
178%postun -p /sbin/ldconfig
179
180%files
181%defattr(644,root,root,755)
b0b5ec3f 182%attr(755,root,root) %{_libdir}/lib*.so.*.*
12913987
MM
183%if %{without sip_fax_only}
184%attr(755,root,root) %{_bindir}/*
0dd5a601 185%dir %{_libdir}/opal-%{version}
186%dir %{_libdir}/opal-%{version}/codecs
187%dir %{_libdir}/opal-%{version}/codecs/audio
188%dir %{_libdir}/opal-%{version}/codecs/video
189%dir %{_libdir}/opal-%{version}/lid
24ae7846
JR
190%{?with_celt:%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/celt_ptplugin.so}
191%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_ptplugin.so
192%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7221_ptplugin.so
193%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7222_ptplugin.so
194%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_ptplugin.so
195%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_ptplugin.so
196%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_ptplugin.so
197%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/iLBC_ptplugin.so
198%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_ptplugin.so
199%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_ptplugin.so
200%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/silk_ptplugin.so
201%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_ptplugin.so
202%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261_vic_ptplugin.so
203%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263_ffmpeg_ptplugin.so
bc09e567 204%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
24ae7846
JR
205%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_x264_ptplugin.so
206%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4_ffmpeg_ptplugin.so
207%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_ptplugin.so
0dd5a601 208%attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
24ae7846 209#%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
12913987 210%endif
aaf12cf0
PG
211
212%files devel
213%defattr(644,root,root,755)
aaf12cf0 214%attr(755,root,root) %{_libdir}/*.so
4733c726
SS
215%{_includedir}/opal
216%{_pkgconfigdir}/opal.pc
aaf12cf0 217
296d779e
JR
218%files static
219%defattr(644,root,root,755)
220%{_libdir}/*.a
This page took 0.295111 seconds and 4 git commands to generate.