]> git.pld-linux.org Git - packages/opal.git/blame - opal.spec
- up to 3.10.8
[packages/opal.git] / opal.spec
CommitLineData
4811172d 1# TODO:
c0a25d84 2# fix static libname (libopal_s.a)
7d38eb5a
SS
3# IPv6 support requires IPv6 support in ptlib
4# x264+ffmpeg detection sucks - it doesn't work with --as-needed
5# SpanDSP FAX support requires t38_indicator symbol
6# MPEG4 rate control correction requires libavcodec sources
7# CAPI support
5683c404 8#
383877b6
JK
9# WARNING: opal version should match Ekiga and ptlib versions
10# Recommendations: http://wiki.ekiga.org/index.php/Download_Ekiga_sources
11#
12913987
MM
12# Conditional build:
13%bcond_with sip_fax_only # Minimal build for t38modem + SIP
7f398677 14%bcond_without celt # Build with CELT codec support
12913987 15#
5683c404
JR
16# Don't touch this! strip removes all symbols from library
17%define no_install_post_strip 1
18#
aaf12cf0 19Summary: Open Phone Abstraction Library (aka OpenH323 v2)
075bc36b 20Summary(pl.UTF-8): Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
aaf12cf0 21Name: opal
317246e4 22Version: 3.10.8
f7ddb932 23Release: 0.1
aaf12cf0
PG
24License: MPL
25Group: Libraries
f7ddb932
CM
26URL: http://www.opalvoip.org
27Source0: http://downloads.sourceforge.net/opalvoip/%{name}-%{version}.tar.bz2
317246e4 28# Source0-md5: b4907073e00889a9e7c6c49d41e4e2d4
0a847dbc 29Patch0: %{name}-libname.patch
c1724659 30Patch1: %{name}-mak_files.patch
323ecc81 31Patch2: %{name}-ac.patch
c0a25d84 32Patch3: %{name}-build.patch
323ecc81 33BuildRequires: autoconf
105bdcf7 34BuildRequires: automake
7f398677 35%{?with_celt:BuildRequires: celt-devel <= 0.8.1}
105bdcf7 36BuildRequires: expat-devel
12913987
MM
37BuildRequires: libstdc++-devel
38BuildRequires: pkgconfig
383877b6 39BuildRequires: ptlib-devel >= 1:2.8.3
12913987 40BuildRequires: sed >= 4.0
7f398677 41%{?with_celt:Requires: celt <= 0.8.1}
12913987
MM
42%if %{without sip_fax_only}
43BuildRequires: SDL-devel
7d38eb5a
SS
44BuildRequires: ffmpeg-devel
45BuildRequires: libgsm-devel
7d38eb5a
SS
46BuildRequires: libtheora-devel
47BuildRequires: libx264-devel
fda4b81c 48BuildRequires: openssl-devel
0b6b8659 49BuildRequires: speex-devel >= 1:1.1.5
105bdcf7 50BuildRequires: unixODBC-devel
12913987 51%endif
d2161d53 52%requires_eq ptlib
aaf12cf0
PG
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
7d38eb5a
SS
55%define filterout_ld -Wl,--as-needed
56
aaf12cf0 57%description
0a401c5c
CM
58The OPAL project aims to create a full featured, interoperable, Open
59Source implementation of the ITU H.323 teleconferencing protocol that
60can be used by personal developers and commercial users without
aaf12cf0
PG
61charge.
62
a2a27970
JR
63%description -l pl.UTF-8
64Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
65wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
66który może być używany przez użytkowników prywatnych i komercyjnych
67bez opłat.
aaf12cf0
PG
68
69%package devel
70Summary: Opal development files
075bc36b 71Summary(pl.UTF-8): Pliki dla developerów Opal
aaf12cf0 72Group: Development/Libraries
5e9f9381 73Requires: %{name} = %{version}-%{release}
aaf12cf0 74Requires: libstdc++-devel
59be64a4 75Requires: ptlib-devel
aaf12cf0
PG
76
77%description devel
0a401c5c 78Header files and libraries for developing applications that use OPAL.
aaf12cf0 79
a2a27970
JR
80%description devel -l pl.UTF-8
81Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
82używających OPAL.
aaf12cf0 83
0a847dbc 84%package static
296d779e 85Summary: OPAL static libraries
075bc36b 86Summary(pl.UTF-8): Biblioteki statyczne OPAL
0a847dbc 87Group: Development/Libraries
5e9f9381 88Requires: %{name}-devel = %{version}-%{release}
aaf12cf0 89
0a847dbc 90%description static
296d779e 91OPAL static libraries.
aaf12cf0 92
a2a27970 93%description static -l pl.UTF-8
296d779e 94Biblioteki statyczne OPAL.
aaf12cf0
PG
95
96%prep
8db2f0fb 97%setup -q
fda4b81c
SS
98#patch0 -p1
99#patch1 -p1
317246e4 100#patch2 -p1
c0a25d84 101%patch3 -p1
aaf12cf0
PG
102
103%build
b0b5ec3f 104PWLIBDIR=%{_prefix}; export PWLIBDIR
296d779e 105OPALDIR=`pwd`; export OPALDIR
c1724659 106OPAL_BUILD="yes"; export OPAL_BUILD
323ecc81
SS
107%{__aclocal}
108%{__autoconf}
b8ea5cae 109cd plugins
0a401c5c 110%{__aclocal}
b8ea5cae
AM
111%{__autoconf}
112cd ..
12913987 113# Run grep '^OPAL_.*=' configure.ac|grep 'yes\|no' to check current defaults
7d38eb5a 114%configure \
12913987
MM
115%if %{with sip_fax_only}
116 --enable-sip \
117 --enable-t38 \
118 --enable-fax \
119 --enable-statistics \
120 --disable-java \
121 --disable-video \
122 --disable-h323 \
123 --disable-iax \
124 --disable-h224 \
125 --disable-h281 \
126 --disable-sipim \
127 --disable-rfc4103 \
128 --disable-h450 \
129 --disable-h460 \
130 --disable-h501 \
131 --disable-lid \
132 --disable-ivr \
133 --disable-rfc4175 \
134 --disable-aec \
135 --disable-g711plc \
136 --disable-plugins
137%else
7f398677 138%{!?with_celt:--disable-celt} \
7d38eb5a 139 --enable-ixj
12913987
MM
140%endif
141
b0b5ec3f 142
c1724659 143%{__make} %{?debug:debug}%{!?debug:opt} \
296d779e
JR
144 CC="%{__cc}" \
145 CPLUS="%{__cxx}" \
146 OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
b0b5ec3f 147
c0a25d84 148%{__cp} -a */libopal* .
12913987 149%if %{without sip_fax_only}
c1724659 150%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
296d779e 151 CC="%{__cc}" \
5ce6a9aa 152 CPLUS="%{__cxx}" \
c0a25d84
SS
153 CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
154 LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
12913987 155%endif
aaf12cf0
PG
156
157%install
158rm -rf $RPM_BUILD_ROOT
4733c726 159install -d $RPM_BUILD_ROOT%{_bindir}
b0b5ec3f 160
161%{__make} install \
162 DESTDIR=$RPM_BUILD_ROOT
aaf12cf0 163
12913987
MM
164%{!?with_sip_fax_only:install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}}
165
4a7dfbfa
MM
166# This needs to be done after 'make install'
167sed -i -e \
168's,^OPALDIR.*=.*$,OPALDIR\t\t\t\t= %{_libdir}/opal-%{version},;'\
169's,^OPAL_SRCDIR.*=.*$,OPAL_SRCDIR\t\t\t= %{_usrsrc}/debug/opal-%{version},;'\
170's,^OPAL_INCDIR.*=.*$,OPAL_INCDIR\t\t\t= %{_includedir}/opal,;'\
171's,^OPAL_LIBDIR.*=.*$,OPAL_LIBDIR\t\t\t= %{_libdir},;' \
172opal_defs.mak
173
12913987 174install opal_{inc,defs}.mak $RPM_BUILD_ROOT%{_includedir}/opal
aaf12cf0
PG
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post -p /sbin/ldconfig
180%postun -p /sbin/ldconfig
181
182%files
183%defattr(644,root,root,755)
b0b5ec3f 184%attr(755,root,root) %{_libdir}/lib*.so.*.*
12913987
MM
185%if %{without sip_fax_only}
186%attr(755,root,root) %{_bindir}/*
0dd5a601 187%dir %{_libdir}/opal-%{version}
188%dir %{_libdir}/opal-%{version}/codecs
189%dir %{_libdir}/opal-%{version}/codecs/audio
190%dir %{_libdir}/opal-%{version}/codecs/video
191%dir %{_libdir}/opal-%{version}/lid
7f398677 192%{?with_celt:%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/celtcodec_pwplugin.so}
bc09e567 193%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_audio_pwplugin.so
0dd5a601 194%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_audio_pwplugin.so
195%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_audio_pwplugin.so
196%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_pwplugin.so
197%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ilbc_audio_pwplugin.so
198%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_audio_pwplugin.so
199%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_audio_pwplugin.so
200%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_audio_pwplugin.so
201%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261-vic_video_pwplugin.so
bc09e567 202%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-1998_video_pwplugin.so
0dd5a601 203#%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-ffmpeg_video_pwplugin.so
bc09e567
AM
204%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
205%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin.so
206%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4-ffmpeg_video_pwplugin.so
0dd5a601 207%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_video_pwplugin.so
208%attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
209%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
12913987 210%endif
aaf12cf0
PG
211
212%files devel
213%defattr(644,root,root,755)
aaf12cf0 214%attr(755,root,root) %{_libdir}/*.so
4733c726
SS
215%{_includedir}/opal
216%{_pkgconfigdir}/opal.pc
aaf12cf0 217
296d779e
JR
218%files static
219%defattr(644,root,root,755)
220%{_libdir}/*.a
This page took 0.182148 seconds and 4 git commands to generate.