]> git.pld-linux.org Git - packages/ogdi.git/blame - ogdi.spec
rebuild with tirpc; rel 2
[packages/ogdi.git] / ogdi.spec
CommitLineData
fae9fa5b 1# TODO: separate gltpd to -server package, add init script (requires portmap)
42a3233f 2#
32f089d1 3# Conditional build:
6532bb18 4%bcond_without tcl # disable gui and nviz
32f089d1 5%bcond_without odbc # disable unixODBC support
6#
fae9fa5b 7Summary: Open Geographic Datastore Interface
5a2968b5 8Summary(pl.UTF-8): OGDI - otwarty interfejs do danych geograficznych
fae9fa5b 9Name: ogdi
69a59151 10Version: 4.0.0
19c56b57 11Release: 2
fae9fa5b 12License: BSD-like
08482132 13Group: Applications/Databases
6532bb18 14#Source0Download: https://github.com/libogdi/ogdi/releases/
69a59151
JR
15Source0: https://github.com/libogdi/ogdi/archive/ogdi_4_0_0/%{name}-%{version}.tar.gz
16# Source0-md5: d1d91f71b4748313d3f60c8f301e03da
fae9fa5b 17Source1: http://ogdi.sourceforge.net/ogdi.pdf
c7b9d0a5 18# Source1-md5: 029a8cdcd36bee73df92196ee769040e
6532bb18 19Patch1: %{name}-format.patch
fae9fa5b
JB
20URL: http://ogdi.sourceforge.net/
21BuildRequires: autoconf
22BuildRequires: expat-devel
19c56b57 23BuildRequires: libtirpc-devel
08447712 24BuildRequires: rpmbuild(macros) >= 1.446
4c1f6d28 25%{?with_tcl:BuildRequires: tcl-devel}
32f089d1 26%{?with_odbc:BuildRequires: unixODBC-devel}
fae9fa5b
JB
27BuildRequires: zlib-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31OGDI is the Open Geographic Datastore Interface. OGDI is an
32application programming interface (API) that uses a standardized
33access methods to work in conjunction with GIS software packages (the
34application) and various geospatial data products. OGDI uses a
35client/server architecture to facilitate the dissemination of
36geospatial data products over any TCP/IP network, and a
37driver-oriented approach to facilitate access to several geospatial
38data products/formats.
ef94e4a2 39
d6c47a2e 40%description -l pl.UTF-8
fae9fa5b 41OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
d6c47a2e
JR
42do danych geograficznych. OGDI to API używające ustandaryzowanych
43metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
44geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
45dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
46sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
fae9fa5b
JB
47geograficznych.
48
49%package devel
50Summary: OGDI header files and documentation
5a2968b5 51Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja OGDI
fae9fa5b 52Group: Development/Libraries
c7196e26 53Requires: %{name} = %{version}-%{release}
19c56b57 54Requires: libtirpc-devel
fae9fa5b
JB
55
56%description devel
57OGDI header files and developer's documentation.
58
d6c47a2e
JR
59%description devel -l pl.UTF-8
60Pliki nagłówkowe i dokumentacja programisty do OGDI.
fae9fa5b
JB
61
62%package odbc
63Summary: ODBC driver for OGDI
5a2968b5 64Summary(pl.UTF-8): Sterownik ODBC do OGDI
fae9fa5b 65Group: Libraries
c7196e26 66Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
67
68%description odbc
69ODBC driver for OGDI.
70
d6c47a2e 71%description odbc -l pl.UTF-8
fae9fa5b
JB
72Sterownik ODBC do OGDI.
73
74%package -n tcl-ogdi
05c5e26d 75Summary: Tcl wrapper for OGDI
5a2968b5 76Summary(pl.UTF-8): Interfejs Tcl do OGDI
fae9fa5b 77Group: Libraries
c7196e26 78Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
79
80%description -n tcl-ogdi
05c5e26d 81Tcl wrapper for OGDI.
fae9fa5b 82
d6c47a2e 83%description -n tcl-ogdi -l pl.UTF-8
05c5e26d 84Interfejs Tcl do OGDI.
fae9fa5b
JB
85
86%prep
69a59151 87%setup -q -n ogdi-ogdi_4_0_0
08482132 88%patch1 -p1
fae9fa5b
JB
89
90cp -f %{SOURCE1} .
91
92%build
fae9fa5b
JB
93TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
94%configure \
95 --with-expat \
fae9fa5b
JB
96 --with-zlib
97
2c460ea2 98# bash because of pushd/popd used in makefiles
3775d26d 99%{__make} -j 1 \
2c460ea2
JB
100 SHELL=/bin/bash \
101 INST_LIB=%{_libdir} \
fae9fa5b
JB
102 OPTIMIZATION="%{rpmcflags}"
103
32f089d1 104%if %{with tcl}
3775d26d 105%{__make} -j 1 -C ogdi/tcl_interface \
fae9fa5b
JB
106 OPTIMIZATION="%{rpmcflags}" \
107 TCL_LINKLIB="-ltcl"
32f089d1 108%endif
3775d26d 109%{__make} -j 1 -C contrib/gdal \
fae9fa5b 110 OPTIMIZATION="%{rpmcflags}"
32f089d1 111%if %{with odbc}
3775d26d 112%{__make} -j 1 -C ogdi/attr_driver/odbc \
2c460ea2 113 OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
fae9fa5b 114 ODBC_LINKLIB="-lodbc"
32f089d1 115%endif
fae9fa5b
JB
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
121
3775d26d 122%{__make} -j 1 install \
2c460ea2 123 SHELL=/bin/bash \
fae9fa5b 124 INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
2c460ea2 125 INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
fae9fa5b
JB
126 INST_BIN=$RPM_BUILD_ROOT%{_bindir}
127
08447712
JB
128# omitted from make install
129install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
130cp -p ogdi.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
131install ogdi-config $RPM_BUILD_ROOT%{_bindir}
132
32f089d1 133%if %{with tcl}
3775d26d 134%{__make} -j 1 install -C ogdi/tcl_interface \
fae9fa5b 135 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 136%endif
3775d26d 137%{__make} -j 1 install -C contrib/gdal \
2c460ea2 138 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 139%if %{with odbc}
3775d26d 140%{__make} -j 1 install -C ogdi/attr_driver/odbc \
2c460ea2 141 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 142%endif
fae9fa5b 143
6532bb18
JB
144%{__rm} $RPM_BUILD_ROOT%{_bindir}/example?
145
fae9fa5b
JB
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
151
152%files
153%defattr(644,root,root,755)
154%doc LICENSE NEWS
155%attr(755,root,root) %{_bindir}/gltpd
156%attr(755,root,root) %{_bindir}/ogdi_*
2c460ea2 157%attr(755,root,root) %{_libdir}/libogdi.so.*.*
69a59151 158%attr(755,root,root) %ghost %{_libdir}/libogdi.so.4
fae9fa5b 159%dir %{_libdir}/ogdi
08482132 160%attr(755,root,root) %{_libdir}/ogdi/libadrg.so
08482132 161%attr(755,root,root) %{_libdir}/ogdi/libdted.so
08482132
JB
162%attr(755,root,root) %{_libdir}/ogdi/libgdal.so
163%attr(755,root,root) %{_libdir}/ogdi/libremote.so
164%attr(755,root,root) %{_libdir}/ogdi/librpf.so
165%attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
166%attr(755,root,root) %{_libdir}/ogdi/libvrf.so
fae9fa5b
JB
167
168%files devel
169%defattr(644,root,root,755)
170%doc ogdi.pdf
08447712 171%attr(755,root,root) %{_bindir}/ogdi-config
2c460ea2 172%attr(755,root,root) %{_libdir}/libogdi.so
08482132
JB
173%{_includedir}/ecs.h
174%{_includedir}/ecs_util.h
08447712 175%{_pkgconfigdir}/ogdi.pc
fae9fa5b 176
32f089d1 177%if %{with odbc}
fae9fa5b
JB
178%files odbc
179%defattr(644,root,root,755)
180%attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
32f089d1 181%endif
fae9fa5b 182
32f089d1 183%if %{with tcl}
fae9fa5b
JB
184%files -n tcl-ogdi
185%defattr(644,root,root,755)
2c460ea2 186%attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
32f089d1 187%endif
This page took 0.173494 seconds and 4 git commands to generate.