]> git.pld-linux.org Git - packages/ogdi.git/blame - ogdi.spec
- updated for 3.1.6
[packages/ogdi.git] / ogdi.spec
CommitLineData
fae9fa5b 1# TODO: separate gltpd to -server package, add init script (requires portmap)
42a3233f 2#
32f089d1 3# Conditional build:
4%bcond_without tcl # disable gui and nviz
5%bcond_without odbc # disable unixODBC support
6#
fae9fa5b 7Summary: Open Geographic Datastore Interface
5a2968b5 8Summary(pl.UTF-8): OGDI - otwarty interfejs do danych geograficznych
fae9fa5b 9Name: ogdi
0feb59b1 10Version: 3.1.5
32f089d1 11Release: 2
fae9fa5b
JB
12License: BSD-like
13Group: Applications
d5bc17e1 14Source0: http://dl.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
0feb59b1 15# Source0-md5: 9ccf8202b63875a68ded23588bd49544
fae9fa5b 16Source1: http://ogdi.sourceforge.net/ogdi.pdf
c7b9d0a5 17# Source1-md5: 029a8cdcd36bee73df92196ee769040e
fae9fa5b 18Patch0: %{name}-driversdir.patch
78edefe0 19Patch1: %{name}-pic.patch
fae9fa5b
JB
20URL: http://ogdi.sourceforge.net/
21BuildRequires: autoconf
22BuildRequires: expat-devel
23BuildRequires: proj-devel
4c1f6d28 24%{?with_tcl:BuildRequires: tcl-devel}
32f089d1 25%{?with_odbc:BuildRequires: unixODBC-devel}
fae9fa5b
JB
26BuildRequires: zlib-devel
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30OGDI is the Open Geographic Datastore Interface. OGDI is an
31application programming interface (API) that uses a standardized
32access methods to work in conjunction with GIS software packages (the
33application) and various geospatial data products. OGDI uses a
34client/server architecture to facilitate the dissemination of
35geospatial data products over any TCP/IP network, and a
36driver-oriented approach to facilitate access to several geospatial
37data products/formats.
ef94e4a2 38
d6c47a2e 39%description -l pl.UTF-8
fae9fa5b 40OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
d6c47a2e
JR
41do danych geograficznych. OGDI to API używające ustandaryzowanych
42metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
43geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
44dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
45sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
fae9fa5b
JB
46geograficznych.
47
48%package devel
49Summary: OGDI header files and documentation
5a2968b5 50Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja OGDI
fae9fa5b 51Group: Development/Libraries
c7196e26 52Requires: %{name} = %{version}-%{release}
7136c5dd 53Requires: proj-devel
fae9fa5b
JB
54
55%description devel
56OGDI header files and developer's documentation.
57
d6c47a2e
JR
58%description devel -l pl.UTF-8
59Pliki nagłówkowe i dokumentacja programisty do OGDI.
fae9fa5b
JB
60
61%package odbc
62Summary: ODBC driver for OGDI
5a2968b5 63Summary(pl.UTF-8): Sterownik ODBC do OGDI
fae9fa5b 64Group: Libraries
c7196e26 65Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
66
67%description odbc
68ODBC driver for OGDI.
69
d6c47a2e 70%description odbc -l pl.UTF-8
fae9fa5b
JB
71Sterownik ODBC do OGDI.
72
73%package -n tcl-ogdi
05c5e26d 74Summary: Tcl wrapper for OGDI
5a2968b5 75Summary(pl.UTF-8): Interfejs Tcl do OGDI
fae9fa5b 76Group: Libraries
c7196e26 77Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
78
79%description -n tcl-ogdi
05c5e26d 80Tcl wrapper for OGDI.
fae9fa5b 81
d6c47a2e 82%description -n tcl-ogdi -l pl.UTF-8
05c5e26d 83Interfejs Tcl do OGDI.
fae9fa5b
JB
84
85%prep
86%setup -q
78edefe0
JB
87%patch0 -p1
88%patch1 -p1
fae9fa5b
JB
89
90cp -f %{SOURCE1} .
91
92%build
93%{__autoconf}
94TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
95%configure \
96 --with-expat \
97 --with-proj \
98 --with-zlib
99
100%{__make} \
101 OPTIMIZATION="%{rpmcflags}"
102
32f089d1 103%if %{with tcl}
fae9fa5b
JB
104%{__make} -C ogdi/tcl_interface \
105 OPTIMIZATION="%{rpmcflags}" \
106 TCL_LINKLIB="-ltcl"
32f089d1 107%endif
fae9fa5b
JB
108%{__make} -C contrib/gdal \
109 OPTIMIZATION="%{rpmcflags}"
32f089d1 110%if %{with odbc}
fae9fa5b
JB
111%{__make} -C ogdi/attr_driver/odbc \
112 OPTIMIZATION="%{rpmcflags}" \
113 ODBC_LINKLIB="-lodbc"
32f089d1 114%endif
fae9fa5b
JB
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
120
121%{__make} install \
122 INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
123 INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi \
124 INST_BIN=$RPM_BUILD_ROOT%{_bindir}
125
32f089d1 126%if %{with tcl}
fae9fa5b
JB
127%{__make} install -C ogdi/tcl_interface \
128 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 129%endif
fae9fa5b
JB
130%{__make} install -C contrib/gdal \
131 INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
32f089d1 132%if %{with odbc}
fae9fa5b
JB
133%{__make} install -C ogdi/attr_driver/odbc \
134 INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
32f089d1 135%endif
fae9fa5b
JB
136
137# only libogdi* is common library, the rest are dlopened drivers
138mv -f $RPM_BUILD_ROOT%{_libdir}/ogdi/libogdi*.so $RPM_BUILD_ROOT%{_libdir}
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%files
147%defattr(644,root,root,755)
148%doc LICENSE NEWS
149%attr(755,root,root) %{_bindir}/gltpd
150%attr(755,root,root) %{_bindir}/ogdi_*
151%attr(755,root,root) %{_libdir}/libogdi*.so
152%dir %{_libdir}/ogdi
46ab6031 153%attr(755,root,root) %{_libdir}/ogdi/lib[!l]*.so
fae9fa5b
JB
154
155%files devel
156%defattr(644,root,root,755)
157%doc ogdi.pdf
158%{_includedir}/*.h
159
32f089d1 160%if %{with odbc}
fae9fa5b
JB
161%files odbc
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
32f089d1 164%endif
fae9fa5b 165
32f089d1 166%if %{with tcl}
fae9fa5b
JB
167%files -n tcl-ogdi
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_libdir}/libecs_tcl.so
32f089d1 170%endif
This page took 0.09559 seconds and 4 git commands to generate.