]> git.pld-linux.org Git - packages/ogdi.git/blame - ogdi.spec
- release 11 (by relup.sh)
[packages/ogdi.git] / ogdi.spec
CommitLineData
fae9fa5b 1# TODO: separate gltpd to -server package, add init script (requires portmap)
42a3233f 2#
32f089d1 3# Conditional build:
4%bcond_without tcl # disable gui and nviz
5%bcond_without odbc # disable unixODBC support
6#
fae9fa5b 7Summary: Open Geographic Datastore Interface
5a2968b5 8Summary(pl.UTF-8): OGDI - otwarty interfejs do danych geograficznych
fae9fa5b 9Name: ogdi
2c460ea2 10Version: 3.1.6
4e820dd0 11Release: 11
fae9fa5b 12License: BSD-like
08482132
JB
13Group: Applications/Databases
14Source0: http://downloads.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
2c460ea2 15# Source0-md5: 212ad71896aa70528ed139c95bed6511
fae9fa5b 16Source1: http://ogdi.sourceforge.net/ogdi.pdf
c7b9d0a5 17# Source1-md5: 029a8cdcd36bee73df92196ee769040e
2c460ea2 18Patch0: %{name}-pic.patch
08482132 19Patch1: %{name}-proj480.patch
025e9522 20Patch2: %{name}-format.patch
fae9fa5b
JB
21URL: http://ogdi.sourceforge.net/
22BuildRequires: autoconf
23BuildRequires: expat-devel
08482132 24BuildRequires: proj-devel >= 4.8
4c1f6d28 25%{?with_tcl:BuildRequires: tcl-devel}
32f089d1 26%{?with_odbc:BuildRequires: unixODBC-devel}
fae9fa5b
JB
27BuildRequires: zlib-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31OGDI is the Open Geographic Datastore Interface. OGDI is an
32application programming interface (API) that uses a standardized
33access methods to work in conjunction with GIS software packages (the
34application) and various geospatial data products. OGDI uses a
35client/server architecture to facilitate the dissemination of
36geospatial data products over any TCP/IP network, and a
37driver-oriented approach to facilitate access to several geospatial
38data products/formats.
ef94e4a2 39
d6c47a2e 40%description -l pl.UTF-8
fae9fa5b 41OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
d6c47a2e
JR
42do danych geograficznych. OGDI to API używające ustandaryzowanych
43metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
44geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
45dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
46sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
fae9fa5b
JB
47geograficznych.
48
49%package devel
50Summary: OGDI header files and documentation
5a2968b5 51Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja OGDI
fae9fa5b 52Group: Development/Libraries
c7196e26 53Requires: %{name} = %{version}-%{release}
08482132 54Requires: proj-devel >= 4.8
fae9fa5b
JB
55
56%description devel
57OGDI header files and developer's documentation.
58
d6c47a2e
JR
59%description devel -l pl.UTF-8
60Pliki nagłówkowe i dokumentacja programisty do OGDI.
fae9fa5b
JB
61
62%package odbc
63Summary: ODBC driver for OGDI
5a2968b5 64Summary(pl.UTF-8): Sterownik ODBC do OGDI
fae9fa5b 65Group: Libraries
c7196e26 66Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
67
68%description odbc
69ODBC driver for OGDI.
70
d6c47a2e 71%description odbc -l pl.UTF-8
fae9fa5b
JB
72Sterownik ODBC do OGDI.
73
74%package -n tcl-ogdi
05c5e26d 75Summary: Tcl wrapper for OGDI
5a2968b5 76Summary(pl.UTF-8): Interfejs Tcl do OGDI
fae9fa5b 77Group: Libraries
c7196e26 78Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
79
80%description -n tcl-ogdi
05c5e26d 81Tcl wrapper for OGDI.
fae9fa5b 82
d6c47a2e 83%description -n tcl-ogdi -l pl.UTF-8
05c5e26d 84Interfejs Tcl do OGDI.
fae9fa5b
JB
85
86%prep
87%setup -q
78edefe0 88%patch0 -p1
08482132 89%patch1 -p1
025e9522 90%patch2 -p1
fae9fa5b
JB
91
92cp -f %{SOURCE1} .
93
94%build
95%{__autoconf}
96TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
97%configure \
98 --with-expat \
99 --with-proj \
100 --with-zlib
101
2c460ea2 102# bash because of pushd/popd used in makefiles
3775d26d 103%{__make} -j 1 \
2c460ea2
JB
104 SHELL=/bin/bash \
105 INST_LIB=%{_libdir} \
fae9fa5b
JB
106 OPTIMIZATION="%{rpmcflags}"
107
32f089d1 108%if %{with tcl}
3775d26d 109%{__make} -j 1 -C ogdi/tcl_interface \
fae9fa5b
JB
110 OPTIMIZATION="%{rpmcflags}" \
111 TCL_LINKLIB="-ltcl"
32f089d1 112%endif
3775d26d 113%{__make} -j 1 -C contrib/gdal \
fae9fa5b 114 OPTIMIZATION="%{rpmcflags}"
32f089d1 115%if %{with odbc}
3775d26d 116%{__make} -j 1 -C ogdi/attr_driver/odbc \
2c460ea2 117 OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
fae9fa5b 118 ODBC_LINKLIB="-lodbc"
32f089d1 119%endif
fae9fa5b
JB
120
121%install
122rm -rf $RPM_BUILD_ROOT
123
124TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
125
3775d26d 126%{__make} -j 1 install \
2c460ea2 127 SHELL=/bin/bash \
fae9fa5b 128 INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
2c460ea2 129 INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
fae9fa5b
JB
130 INST_BIN=$RPM_BUILD_ROOT%{_bindir}
131
32f089d1 132%if %{with tcl}
3775d26d 133%{__make} -j 1 install -C ogdi/tcl_interface \
fae9fa5b 134 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 135%endif
3775d26d 136%{__make} -j 1 install -C contrib/gdal \
2c460ea2 137 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 138%if %{with odbc}
3775d26d 139%{__make} -j 1 install -C ogdi/attr_driver/odbc \
2c460ea2 140 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 141%endif
fae9fa5b 142
fae9fa5b
JB
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%post -p /sbin/ldconfig
147%postun -p /sbin/ldconfig
148
149%files
150%defattr(644,root,root,755)
151%doc LICENSE NEWS
152%attr(755,root,root) %{_bindir}/gltpd
153%attr(755,root,root) %{_bindir}/ogdi_*
2c460ea2 154%attr(755,root,root) %{_libdir}/libogdi.so.*.*
08482132 155%attr(755,root,root) %ghost %{_libdir}/libogdi.so.3
fae9fa5b 156%dir %{_libdir}/ogdi
08482132
JB
157%attr(755,root,root) %{_libdir}/ogdi/libadrg.so
158%attr(755,root,root) %{_libdir}/ogdi/libdtcanada.so
159%attr(755,root,root) %{_libdir}/ogdi/libdted.so
160%attr(755,root,root) %{_libdir}/ogdi/libdtusa.so
161%attr(755,root,root) %{_libdir}/ogdi/libgdal.so
162%attr(755,root,root) %{_libdir}/ogdi/libremote.so
163%attr(755,root,root) %{_libdir}/ogdi/librpf.so
164%attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
165%attr(755,root,root) %{_libdir}/ogdi/libvrf.so
fae9fa5b
JB
166
167%files devel
168%defattr(644,root,root,755)
169%doc ogdi.pdf
2c460ea2 170%attr(755,root,root) %{_libdir}/libogdi.so
08482132
JB
171%{_includedir}/ecs.h
172%{_includedir}/ecs_util.h
fae9fa5b 173
32f089d1 174%if %{with odbc}
fae9fa5b
JB
175%files odbc
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
32f089d1 178%endif
fae9fa5b 179
32f089d1 180%if %{with tcl}
fae9fa5b
JB
181%files -n tcl-ogdi
182%defattr(644,root,root,755)
2c460ea2 183%attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
32f089d1 184%endif
This page took 0.081126 seconds and 4 git commands to generate.