]> git.pld-linux.org Git - packages/nodejs.git/blob - nodejs.spec
use sed to fixup shebangs, not carry around huge patch for that
[packages/nodejs.git] / nodejs.spec
1 Summary:        Asynchronous JavaScript Engine
2 Name:           nodejs
3 Version:        0.10.3
4 Release:        4
5 License:        BSD and MIT and Apache v2.0 and GPL v3
6 Group:          Development/Languages
7 Source0:        http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
8 # Source0-md5:  4daca92618515708a4631e98a8e8c779
9 Patch1:         %{name}-shared.patch
10 # force node to use /usr/lib/node as the systemwide module directory
11 Patch2:         %{name}-libpath.patch
12 # use /usr/lib64/node as an arch-specific module dir when appropriate
13 Patch3:         %{name}-lib64path.patch
14 Patch5:         uv-fpic.patch
15 URL:            http://www.nodejs.org/
16 BuildRequires:  c-ares-devel
17 BuildRequires:  gcc >= 5:4.0
18 BuildRequires:  http-parser-devel >= 2.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libuv-devel >= %{version}
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python >= 1:2.5.2
24 BuildRequires:  python-jsmin
25 BuildRequires:  rpm >= 4.4.9-56
26 BuildRequires:  rpmbuild(macros) >= 1.219
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  v8-devel >= 3.15.11.10
29 BuildRequires:  zlib-devel
30 BuildConflicts: eio
31 Obsoletes:      nodejs-waf
32 ExclusiveArch:  %{ix86} %{x8664} arm
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Node.js is a platform built on Chrome's JavaScript runtime for easily
37 building fast, scalable network applications. Node.js uses an
38 event-driven, non-blocking I/O model that makes it lightweight and
39 efficient, perfect for data-intensive real-time applications that run
40 across distributed devices.
41
42 %package devel
43 Summary:        Development headers for nodejs
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       c-ares-devel
47 Requires:       gcc
48 Requires:       http-parser-devel
49 Requires:       libstdc++-devel
50 Requires:       libuv-devel
51 Requires:       openssl-devel
52 Requires:       v8-devel
53 Requires:       zlib-devel
54
55 %description devel
56 Development headers for nodejs.
57
58 %package doc
59 Summary:        Evented I/O for V8 JavaScript - documentation
60 Group:          Documentation
61
62 %description doc
63 Node.js is a server-side JavaScript environment that uses an
64 asynchronous event-driven model. Node's goal is to provide an easy way
65 to build scalable network programs.
66
67 This package contains the documentation for nodejs.
68
69 %prep
70 %setup -q -n node-v%{version}
71 %patch1 -p1
72 %if %{_lib} == "lib64"
73 %patch3 -p1
74 %else
75 %patch2 -p1
76 %endif
77 %patch5 -p1
78
79 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
80
81 %build
82 # Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
83 CC=${CC#ccache }
84
85 # add defines from libuv (RHBZ#892601)
86 export CFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
87 export CXXFLAGS="%{rpmcppflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
88
89 # NOT autoconf so don't use macro
90 export PYTHONPATH=tools
91 ./configure \
92         --shared-v8 \
93         --shared-zlib \
94         --shared-openssl \
95         --shared-cares \
96         --shared-libuv \
97         --shared-http-parser \
98         --without-npm \
99         --without-dtrace \
100         --prefix=%{_prefix}
101
102 %{__make} -C out \
103         BUILDTYPE=Release \
104         V=1 \
105         CFLAGS.host="%{rpmcflags} -fPIC" \
106         CXXFLAGS.host="%{rpmcppflags} -fPIC" \
107         LDFLAGS.host="%{rpmcflags}" \
108         CFLAGS.target="%{rpmcflags} -fPIC" \
109         CXXFLAGS.target="%{rpmcppflags} -fPIC" \
110         LDFLAGS.target="%{rpmcflags}" \
111         CC.host="%{__cc}" \
112         CXX.host="%{__cxx}" \
113         CC.target="%{__cc}" \
114         CXX.target="%{__cxx}"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} justinstall \
119         DESTDIR=$RPM_BUILD_ROOT \
120         LIBDIR=%{_lib}
121
122 # no dtrace on linux
123 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/lib/dtrace/node.d
124
125 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*)
126 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
127 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
128
129 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
130
131 install -d $RPM_BUILD_ROOT%{_includedir}/node
132 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
133
134 # install for node-gyp
135 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
136 cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
137 ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
138
139 # for compat of fedora derivered scripts (shebangs)
140 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
141
142 # globally installed node modules (noarch)
143 install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
144
145 # default searchpaths
146 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
147
148 # create pkgconfig
149 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
150 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
151 version=%{version}
152 prefix=%{_prefix}
153 libdir=${prefix}/%{_lib}
154 includedir=${prefix}/include/node
155
156 Name: nodejs
157 Description: Evented I/O for V8 JavaScript.
158 Version: ${version}
159 Cflags: -I${includedir}
160 EOF
161
162 # install documentation
163 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
164 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
165 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
166 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc README.md AUTHORS ChangeLog LICENSE
177 %attr(755,root,root) %{_bindir}/node
178 %attr(755,root,root) %{_bindir}/nodejs
179 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
180 %ghost %{_libdir}/libnode.so.10
181 %if "%{_lib}" != "lib"
182 %dir %{_libdir}/node
183 %endif
184 %dir %{_prefix}/lib/node
185 %dir %{_prefix}/lib/node_modules
186 %{_mandir}/man1/node.1*
187 %{_mandir}/man1/nodejs.1
188
189 %files devel
190 %defattr(644,root,root,755)
191 %{_libdir}/libnode.so
192 %{_includedir}/node
193 %{_pkgconfigdir}/nodejs.pc
194 %{_usrsrc}/%{name}
195
196 %files doc
197 %defattr(644,root,root,755)
198 %doc %{_docdir}/%{name}-doc-%{version}
This page took 0.042502 seconds and 4 git commands to generate.