]> git.pld-linux.org Git - packages/nodejs.git/blob - nodejs.spec
add system_uv bcond
[packages/nodejs.git] / nodejs.spec
1 #
2 # Conditional build:
3 %bcond_without  system_v8       # system v8
4 %bcond_without  system_uv       # system uv
5 %bcond_without  shared  # build libnode.so shared library
6
7 # NOTES:
8 # - https://nodejs.org/en/download/releases/
9
10 Summary:        Asynchronous JavaScript Engine
11 Name:           nodejs
12 Version:        0.10.40
13 Release:        1
14 License:        BSD and MIT and Apache v2.0 and GPL v3
15 Group:          Development/Languages
16 Source0:        https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
17 # Source0-md5:  f6ef20f327ecd6cb1586c41c7184290c
18 Patch1:         %{name}-shared.patch
19 # force node to use /usr/lib/node as the systemwide module directory
20 Patch2:         %{name}-libpath.patch
21 # use /usr/lib64/node as an arch-specific module dir when appropriate
22 Patch3:         %{name}-lib64path.patch
23 Patch4:         %{name}-use-system-certs.patch
24 Patch5:         uv-fpic.patch
25 # The invalid UTF8 fix has been reverted since this breaks v8 API, which cannot
26 # be done in a stable distribution release.  This build of nodejs will behave as
27 # if NODE_INVALID_UTF8 was set.  For more information on the implications, see:
28 # http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
29 Patch6:         %{name}-revert-utf8-v8.patch
30 Patch7:         %{name}-revert-utf8-node.patch
31 URL:            https://nodejs.org/
32 BuildRequires:  c-ares-devel
33 BuildRequires:  gcc >= 5:4.0
34 BuildRequires:  http-parser-devel >= 2.0
35 BuildRequires:  libstdc++-devel
36 %{?with_system_uv:BuildRequires:        libuv-devel >= 0.10}
37 BuildRequires:  openssl-devel
38 BuildRequires:  pkgconfig
39 BuildRequires:  python >= 1:2.5.2
40 BuildRequires:  python-jsmin
41 BuildRequires:  rpm >= 4.4.9-56
42 BuildRequires:  rpmbuild(macros) >= 1.219
43 BuildRequires:  sed >= 4.0
44 %{?with_system_v8:BuildRequires:        v8-devel >= 3.15.11.18-2}
45 BuildRequires:  zlib-devel
46 Requires:       ca-certificates
47 Obsoletes:      nodejs-waf
48 ExclusiveArch:  %{ix86} %{x8664} arm
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         sover   %(echo %{version} | cut -d. -f2)
52
53 %description
54 Node.js is a platform built on Chrome's JavaScript runtime for easily
55 building fast, scalable network applications. Node.js uses an
56 event-driven, non-blocking I/O model that makes it lightweight and
57 efficient, perfect for data-intensive real-time applications that run
58 across distributed devices.
59
60 %package devel
61 Summary:        Development headers for nodejs
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       c-ares-devel
65 Requires:       gcc
66 Requires:       http-parser-devel
67 Requires:       libstdc++-devel
68 %{?with_system_uv:Requires:     libuv-devel}
69 Requires:       openssl-devel
70 %{?with_system_v8:Requires:     v8-devel}
71 Requires:       zlib-devel
72
73 %description devel
74 Development headers for nodejs.
75
76 %package doc
77 Summary:        Evented I/O for V8 JavaScript - documentation
78 Group:          Documentation
79 %if "%{_rpmversion}" >= "5"
80 BuildArch:      noarch
81 %endif
82
83 %description doc
84 Node.js is a server-side JavaScript environment that uses an
85 asynchronous event-driven model. Node's goal is to provide an easy way
86 to build scalable network programs.
87
88 This package contains the documentation for nodejs.
89
90 %prep
91 %setup -q -n node-v%{version}
92 %{?with_shared:%patch1 -p1}
93 %if %{_lib} == "lib64"
94 %patch3 -p1
95 %else
96 %patch2 -p1
97 %endif
98 %patch4 -p1
99 %patch5 -p1
100 %patch6 -p1
101 %patch7 -p1
102
103 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
104
105 rm -r deps/npm
106 rm -r deps/cares
107 rm -r deps/http_parser
108 rm -r deps/openssl
109 %{?with_system_uv:rm -r deps/uv}
110 %{?with_system_v8:rm -r deps/v8}
111 rm -r deps/zlib
112
113 %build
114 # CC used only to detect if CC is clang, not used for compiling
115 CC="%{__cc}" \
116 CXX="%{__cxx}" \
117 GYP_DEFINES="soname_version=%{sover}" \
118 ./configure \
119         %{?with_system_v8:--shared-v8} \
120         --shared-zlib \
121         --shared-openssl \
122         --shared-cares \
123         %{?with_system_uv:--shared-libuv} \
124         --shared-http-parser \
125         --without-npm \
126         --without-dtrace \
127         --prefix=%{_prefix}
128
129 # add LFS defines from libuv (RHBZ#892601)
130 # CXXFLAGS must be exported, as it is needed for make, not gyp
131 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
132 LDFLAGS="%{rpmldflags}" \
133 %{__make} -C out V=1 BUILDTYPE=Release
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 %{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_lib}"
138
139 %if %{with shared}
140 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
141 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
142 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
143 %endif
144
145 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
146
147 install -d $RPM_BUILD_ROOT%{_includedir}/node
148 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
149
150 # install for node-gyp
151 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
152 cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
153 ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
154
155 # for compat of fedora derivered scripts (shebangs)
156 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
157
158 # globally installed node modules (noarch)
159 install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
160
161 # default searchpaths
162 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
163
164 # create pkgconfig
165 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
166 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
167 version=%{version}
168 prefix=%{_prefix}
169 libdir=${prefix}/%{_lib}
170 includedir=${prefix}/include/node
171
172 Name: nodejs
173 Description: Evented I/O for V8 JavaScript.
174 Version: ${version}
175 Cflags: -I${includedir}
176 EOF
177
178 # install documentation
179 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
180 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
181 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
182 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %if %{with shared}
188 %post   -p /sbin/ldconfig
189 %postun -p /sbin/ldconfig
190 %endif
191
192 %files
193 %defattr(644,root,root,755)
194 %doc README.md AUTHORS ChangeLog LICENSE
195 %attr(755,root,root) %{_bindir}/node
196 %attr(755,root,root) %{_bindir}/nodejs
197 %if %{with shared}
198 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
199 %ghost %{_libdir}/libnode.so.10
200 %endif
201 %if "%{_lib}" != "lib"
202 %dir %{_libdir}/node
203 %endif
204 %dir %{_prefix}/lib/node
205 %dir %{_prefix}/lib/node_modules
206 %{_mandir}/man1/node.1*
207 %{_mandir}/man1/nodejs.1
208
209 %files devel
210 %defattr(644,root,root,755)
211 %if %{with shared}
212 %{_libdir}/libnode.so
213 %endif
214 %{_includedir}/node
215 %{_pkgconfigdir}/nodejs.pc
216 %{_usrsrc}/%{name}
217
218 %files doc
219 %defattr(644,root,root,755)
220 %doc %{_docdir}/%{name}-doc-%{version}
This page took 0.071961 seconds and 4 git commands to generate.