]> git.pld-linux.org Git - packages/nodejs.git/blame - nodejs.spec
- updated to 16.20.1
[packages/nodejs.git] / nodejs.spec
CommitLineData
35c24539
JB
1# BUILD NOTE:
2# until we get binutils with https://sourceware.org/bugzilla/show_bug.cgi?id=28138 fixed
3# build requires >1024 available file descriptors (4096 seems sufficient)
4#
cc3de6db
ER
5# TODO
6# - unpackaged files
7# /usr/share/doc/node/gdbinit
cc3de6db 8
29d6d704 9# Conditional build:
ab77d514 10%bcond_without system_brotli # system brotli
4a5eff4b 11%bcond_without system_uv # system uv
ab77d514 12%bcond_with http_parser # system http-parser and llhttp
29d6d704 13
5e8b83c0
JP
14%define _enable_debug_packages 0
15
8611106e
ER
16# NOTES:
17# - https://nodejs.org/en/download/releases/
18
e9b6043f
ER
19# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
20# number of Node.js, used to determine which versions of Node.js compiled C++
21# add-on binaries can be loaded in to without needing to be re-compiled. It
22# used to be stored as hex value in earlier versions, but is now represented as
23# an integer.
2ae41f2b 24%define node_module_version 93
210abff9 25Summary: Asynchronous JavaScript Engine
9a1229ff 26Summary(pl.UTF-8): Asynchroniczny silnik JavaScriptu
210abff9 27Name: nodejs
ebb43873
JB
28# 16.x LTS - https://github.com/nodejs/Release
29# Active start: 2021-10-26
30# Maintenance start: October 2022
31# Maintenance end: September 2023
32Version: 16.20.1
33Release: 1
d5764a43 34License: BSD and MIT and Apache v2.0 and GPL v3
e85103e0 35Group: Development/Languages
ebb43873
JB
36Source0: https://nodejs.org/download/release/latest-v16.x/node-v%{version}.tar.xz
37# Source0-md5: 0eb71fbf3fcf35c9ed479f10c55eedad
4ad24d02 38Patch0: system_cares.patch
a6070ceb
ER
39# force node to use /usr/lib/node as the systemwide module directory
40Patch2: %{name}-libpath.patch
41# use /usr/lib64/node as an arch-specific module dir when appropriate
42Patch3: %{name}-lib64path.patch
c2768f1e 43Patch4: 0001-Disable-running-gyp-on-shared-deps.patch
8611106e 44URL: https://nodejs.org/
4ad24d02 45BuildRequires: c-ares-devel >= 1.17.2
ab907bdb 46BuildRequires: gcc >= 6:6.3
4398233e
JB
47%if %{with http_parser}
48BuildRequires: http-parser-devel >= 2.9.3
ab907bdb 49BuildRequires: llhttp-devel >= 2.1.3
c2768f1e 50%endif
10c99409
JP
51%ifarch mips mipsel mips64 mips64el ppc %{arm}
52BuildRequires: libatomic-devel
53%endif
ab907bdb 54%{?with_system_brotli:BuildRequires: libbrotli-devel >= 1.0.9}
2ae41f2b 55BuildRequires: libicu-devel >= 69.1
8c0b403f 56BuildRequires: libstdc++-devel >= 6:4.8
2ae41f2b 57%{?with_system_uv:BuildRequires: libuv-devel >= 1.42.0}
c3bd1d59 58BuildRequires: nghttp2-devel >= 1.42.0
94f7bd52 59BuildRequires: openssl-devel >= 1.0.1
cd4c73aa 60BuildRequires: pkgconfig
2ae41f2b
JP
61BuildRequires: python3 >= 1:3.6
62BuildRequires: python3-modules >= 1:3.6
12a49d35 63BuildRequires: rpm >= 4.4.9-56
d1db1c48 64BuildRequires: rpm-build >= 4.6
d047ca74 65BuildRequires: rpmbuild(macros) >= 1.752
536f9f5a 66BuildRequires: sed >= 4.0
ab77d514 67BuildRequires: zlib-devel >= 1.2.11
c3bd1d59 68Requires: c-ares >= 1.17.1
ab77d514 69Requires: ca-certificates
4398233e 70%{?with_http_parser:Requires: http-parser >= 2.9.3}
ab907bdb 71%{?with_system_brotli:Requires: libbrotli >= 1.0.9}
2ae41f2b 72%{?with_system_uv:Requires: libuv >= 1.42.0}
c3bd1d59 73Requires: nghttp2-libs >= 1.42.0
ab77d514 74Requires: zlib >= 1.2.11
8d8e2928 75Provides: nodejs(engine) = %{version}
56d9fb33 76Provides: nodejs(module-version) = %{node_module_version}
ebb43873 77Obsoletes: nodejs-waf < 0.9
a7c6ab18 78ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
210abff9 79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
dc60a63b 81%define sover %(echo %{version} | cut -d. -f2)
05e85ef1
ER
82# add macro, so adapter won't replace it back literal
83%define doc_ver %{version}
dc60a63b 84
210abff9 85%description
c3b531ba
ER
86Node.js is a platform built on Chrome's JavaScript runtime for easily
87building fast, scalable network applications. Node.js uses an
88event-driven, non-blocking I/O model that makes it lightweight and
89efficient, perfect for data-intensive real-time applications that run
90across distributed devices.
210abff9 91
9a1229ff
JB
92%description -l pl.UTF-8
93Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
94przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
95aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
96wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
97wydajny, dobrze nadający się do aplikacji przetwarzających duże
98ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
99urządzeniach.
100
210abff9 101%package devel
12a49d35 102Summary: Development headers for nodejs
9a1229ff 103Summary(pl.UTF-8): Pliki nagłówkowe nodejs
210abff9 104Group: Development/Libraries
a8f57a3f 105Requires: %{name} = %{version}-%{release}
d44c8857 106Requires: gcc
4398233e 107%{?with_http_parser:Requires: http-parser-devel >= 2.9.3}
d44c8857 108Requires: libstdc++-devel
2ae41f2b 109%{?with_system_uv:Requires: libuv-devel >= 1.42.0}
96f19ba5 110Requires: openssl-devel
ab77d514 111Requires: zlib-devel >= 1.2.11
210abff9 112
113%description devel
12a49d35 114Development headers for nodejs.
210abff9 115
9a1229ff
JB
116%description devel -l pl.UTF-8
117Pliki nagłówkowe nodejs.
118
a6070ceb 119%package doc
9a1229ff
JB
120Summary: Documentation for Node.js engine
121Summary(pl.UTF-8): Dokumentacja silnika Node.js
a6070ceb 122Group: Documentation
05e85ef1 123URL: https://nodejs.org/dist/v%{doc_ver}/docs/api
0f608c78 124BuildArch: noarch
a6070ceb
ER
125
126%description doc
127Node.js is a server-side JavaScript environment that uses an
128asynchronous event-driven model. Node's goal is to provide an easy way
129to build scalable network programs.
130
9a1229ff
JB
131This package contains the documentation for Node.js.
132
133%description doc -l pl.UTF-8
134Node.js to serwerowe środowisko JavaScriptu wykorzystujące
135asynchroniczny model sterowany zdarzeniami. Celem Node jest
136zapewnienie łatwego sposobu tworzenia skalowalnych programów
137sieciowych.
138
139Ten pakiet zawiera dokumentację Node.js.
a6070ceb 140
8c0b403f
JB
141%package -n systemtap-nodejs
142Summary: systemtap/dtrace probes for Node.js
143Summary(pl.UTF-8): Sondy systemtap/dtrace dla Node.js
144Group: Development/Tools
145Requires: %{name} = %{version}-%{release}
146Requires: systemtap-client
147
148%description -n systemtap-nodejs
149systemtap/dtrace probes for Node.js.
150
151%description -n systemtap-nodejs -l pl.UTF-8
152Sondy systemtap/dtrace dla Node.js.
153
210abff9 154%prep
155%setup -q -n node-v%{version}
4ad24d02 156%patch0 -p1
d23cf2d6 157%if "%{_lib}" == "lib64"
a6070ceb
ER
158%patch3 -p1
159%else
160%patch2 -p1
161%endif
c2768f1e 162%patch4 -p1
c4aa3bb0 163
fbdba246 164grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
536f9f5a 165
a6b4cff8
JP
166%{?with_system_brotli:%{__rm} -r deps/brotli}
167%{__rm} -r deps/cares
168%if %{with http_parser}
169%{__rm} -r deps/http_parser
170%{__rm} -r deps/llhttp
171%endif
172%{__rm} -r deps/icu-small
173%{__rm} -r deps/nghttp2
9a1229ff 174%{__rm} -r deps/npm
9a1229ff
JB
175%{__rm} -r deps/openssl
176%{?with_system_uv:%{__rm} -r deps/uv}
177%{__rm} -r deps/zlib
e3e8568d 178
210abff9 179%build
c8ef6556 180ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
145d5ed0 181test "$ver" = "%{node_module_version}"
56d9fb33 182
a11025a6
ER
183# CC used only to detect if CC is clang, not used for compiling
184CC="%{__cc}" \
185CXX="%{__cxx}" \
dc60a63b 186GYP_DEFINES="soname_version=%{sover}" \
a6070ceb 187./configure \
4398233e
JB
188 --prefix=%{_prefix} \
189 --libdir=%{_lib} \
e2a62df7 190 --openssl-use-def-ca-store \
c2768f1e 191 --shared \
ab77d514 192 %{?with_system_brotli:--shared-brotli} \
c2768f1e 193 --shared-cares \
4398233e 194 %{?with_http_parser:--shared-http-parser} \
8c0b403f 195 %{?with_system_uv:--shared-libuv} \
4398233e
JB
196 --shared-nghttp2 \
197 --shared-openssl \
8c0b403f 198 --shared-zlib \
4398233e 199 --with-intl=system-icu \
47f90cc9 200 --without-corepack \
c1c359b8 201 --without-dtrace \
4398233e 202 --without-npm
210abff9 203
a11025a6
ER
204# add LFS defines from libuv (RHBZ#892601)
205# CXXFLAGS must be exported, as it is needed for make, not gyp
206CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
207LDFLAGS="%{rpmldflags}" \
fbdba246 208PATH="$(pwd)/out/tools/bin:$PATH" \
9a1229ff
JB
209%{__make} -C out \
210 BUILDTYPE=Release \
211 V=1
210abff9 212
213%install
214rm -rf $RPM_BUILD_ROOT
9a1229ff 215
ab907bdb 216%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
4174c079 217
c2768f1e 218ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
a6070ceb 219
c7898157
ER
220echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
221
1ed21df5 222install -d $RPM_BUILD_ROOT%{_includedir}/node
4174c079 223cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
d5764a43
ER
224
225# install for node-gyp
226install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
227cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
228ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
1ed21df5 229
e85103e0 230# for compat of fedora derivered scripts (shebangs)
c3b531ba
ER
231ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
232
e85103e0
ER
233# globally installed node modules (noarch)
234install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
235
236# default searchpaths
237install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
238
a6070ceb
ER
239# create pkgconfig
240install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
241cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
242version=%{version}
c3b531ba 243prefix=%{_prefix}
87c4fdf2 244libdir=${prefix}/%{_lib}
a6070ceb
ER
245includedir=${prefix}/include/node
246
247Name: nodejs
248Description: Evented I/O for V8 JavaScript.
249Version: ${version}
250Cflags: -I${includedir}
251EOF
a752c1c0 252
a6070ceb 253# install documentation
6f7eebb5
ER
254install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
255cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
9a1229ff
JB
256%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
257%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
a6070ceb 258
210abff9 259%clean
260rm -rf $RPM_BUILD_ROOT
261
4174c079 262%post -p /sbin/ldconfig
7372d27d 263%postun -p /sbin/ldconfig
264
210abff9 265%files
266%defattr(644,root,root,755)
4398233e 267%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
210abff9 268%attr(755,root,root) %{_bindir}/node
c3b531ba 269%attr(755,root,root) %{_bindir}/nodejs
c2768f1e 270%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
a600c300 271%if "%{_lib}" != "lib"
8791ea86 272%dir %{_libdir}/node
a600c300
ŁC
273%endif
274%dir %{_prefix}/lib/node
e85103e0 275%dir %{_prefix}/lib/node_modules
210abff9 276%{_mandir}/man1/node.1*
9a1229ff 277%{_mandir}/man1/nodejs.1*
210abff9 278
210abff9 279%files devel
280%defattr(644,root,root,755)
9a1229ff 281%attr(755,root,root) %{_libdir}/libnode.so
58494f0c 282%{_includedir}/node
a6070ceb 283%{_pkgconfigdir}/nodejs.pc
d5764a43 284%{_usrsrc}/%{name}
a6070ceb
ER
285
286%files doc
287%defattr(644,root,root,755)
288%doc %{_docdir}/%{name}-doc-%{version}
8c0b403f
JB
289
290%files -n systemtap-nodejs
291%defattr(644,root,root,755)
292%{_datadir}/systemtap/tapset/node.stp
This page took 0.155047 seconds and 4 git commands to generate.