]> git.pld-linux.org Git - packages/nodejs.git/blame - nodejs.spec
- 0.1.98
[packages/nodejs.git] / nodejs.spec
CommitLineData
12a49d35
ER
1# TODO:
2# - use system waf
210abff9 3
210abff9 4Summary: Asynchronous JavaScript Engine
5Name: nodejs
b52d635c 6Version: 0.1.98
210abff9 7Release: 0
8License: BSD
9Group: Libraries
10URL: http://nodejs.org/
11Source0: http://nodejs.org/dist/node-v%{version}.tar.gz
b52d635c 12# Source0-md5: d8a75cb5c18ce20e0206ced95a8c1544
12a49d35 13BuildRequires: gcc >= 5:4.0
210abff9 14BuildRequires: libeio-devel
15BuildRequires: libev-devel >= 3.90
16BuildRequires: libstdc++-devel
17BuildRequires: python
12a49d35 18BuildRequires: rpm >= 4.4.9-56
210abff9 19BuildRequires: udns-devel
08fd0f57 20BuildRequires: c-ares-devel >= 1.7.1-0.20100523.0
1abe508f 21BuildRequires: v8-devel >= 2.2.12
210abff9 22ExclusiveArch: %{ix86} %{x8664} arm
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Node's goal is to provide an easy way to build scalable network
27programs. In the above example, the two second delay does not prevent
28the server from handling new requests. Node tells the operating system
29(through epoll, kqueue, /dev/poll, or select) that it should be
30notified when the 2 seconds are up or if a new connection is made --
31then it goes to sleep. If someone new connects, then it executes the
32callback, if the timeout expires, it executes the inner callback. Each
33connection is only a small heap allocation.
34
210abff9 35%package devel
12a49d35 36Summary: Development headers for nodejs
210abff9 37Group: Development/Libraries
210abff9 38
39%description devel
12a49d35 40Development headers for nodejs.
210abff9 41
42%prep
43%setup -q -n node-v%{version}
210abff9 44
45%build
46# build library
210abff9 47CFLAGS="%{rpmcflags}"
48CXXFLAGS="%{rpmcxxflags}"
49LDFLAGS="%{rpmcflags}"
50%if "%{pld_release}" == "ac"
51CC=%{__cc}4
52CXX=%{__cxx}4
53%else
54CC=%{__cc}
55CXX=%{__cxx}
56%endif
57export CFLAGS LDFLAGS CXXFLAGS CC CXX
58
59tools/waf-light configure \
b52d635c 60 --shared-v8 \
61 --shared-cares \
62 --shared-libev \
210abff9 63 --prefix=%{_prefix}
64
65tools/waf-light build
66
67%install
68rm -rf $RPM_BUILD_ROOT
c6be74cc 69install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}/node/libraries}
210abff9 70tools/waf-light install \
71 --destdir=$RPM_BUILD_ROOT
72
e550379f 73cp -a lib/*.js $RPM_BUILD_ROOT%{_libdir}/node/libraries
c6be74cc 74
210abff9 75%clean
76rm -rf $RPM_BUILD_ROOT
77
210abff9 78%files
79%defattr(644,root,root,755)
80%doc AUTHORS ChangeLog LICENSE
81%attr(755,root,root) %{_bindir}/node
82%attr(755,root,root) %{_bindir}/node-repl
83%dir %{_libdir}/node
84%dir %{_libdir}/node/libraries
85%{_libdir}/node/libraries/*.js
86%{_mandir}/man1/node.1*
87
210abff9 88%files devel
89%defattr(644,root,root,755)
12a49d35 90%dir %{_includedir}/node
c6be74cc 91%{_includedir}/node/*.h
92%attr(755,root,root) %{_bindir}/node-waf
93%{_libdir}/node/wafadmin/
This page took 0.075311 seconds and 4 git commands to generate.