]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
- updated to 3.4
[packages/netsurf.git] / netsurf.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # GStreamer-based video support
4 %bcond_without  js              # JavaScript support
5 %bcond_with     pdf             # PDF export and GTK+ printing support via libharu [needs update?]
6 %bcond_without  webp            # WebP image support
7 #
8 Summary:        Light WWW browser with CSS support
9 Summary(pl.UTF-8):      Lekka przeglądarka WWW z obsługą CSS
10 Name:           netsurf
11 Version:        3.4
12 Release:        1
13 License:        GPL v2 with OpenSSL exception (code), MIT (artwork)
14 Group:          Applications/Networking
15 Source0:        http://download.netsurf-browser.org/netsurf/releases/source/%{name}-%{version}-src.tar.gz
16 # Source0-md5:  bf08c97f172a3be31690a36d654c61a4
17 Source1:        %{name}.desktop
18 Patch0:         nsfb-ldflags.patch
19 Patch1:         %{name}-link.patch
20 Patch3:         optflags.patch
21 URL:            http://netsurf-browser.org/
22 BuildRequires:  curl-devel
23 BuildRequires:  freetype-devel >= 2
24 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
25 BuildRequires:  gtk+2-devel >= 2.0
26 BuildRequires:  libCSS-devel >= 0.6.0
27 BuildRequires:  libdom-devel >= 0.3.0
28 %{?with_pdf:BuildRequires:      libharu-devel}
29 BuildRequires:  libhubbub-devel >= 0.3.3
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libnsbmp-devel >= 0.1.3
32 BuildRequires:  libnsfb-devel >= 0.1.4
33 BuildRequires:  libnsgif-devel >= 0.1.3
34 BuildRequires:  libnsutils-devel >= 0.0.2
35 BuildRequires:  libparserutils-devel >= 0.2.3
36 BuildRequires:  libpng-devel
37 BuildRequires:  librsvg-devel
38 BuildRequires:  libsvgtiny-devel >= 0.1.4
39 BuildRequires:  libutf8proc-devel >= 1.3.1
40 BuildRequires:  libwapcaplet-devel >= 0.3.0
41 %{?with_webp:BuildRequires:     libwebp-devel}
42 BuildRequires:  openssl-devel
43 BuildRequires:  netsurf-buildsystem >= 1.5
44 BuildRequires:  nsgenbind >= 0.3
45 BuildRequires:  perl-HTML-Parser
46 BuildRequires:  pkgconfig
47 BuildRequires:  sed >= 4.0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 NetSurf is a multi-platform lightweight web browser. Its aim is to
52 provide comprehensive rendering of HTML 5 with CSS 2 in a small
53 resource footprint while remaining fast.
54
55 %description -l pl.UTF-8
56 NetSurf to wieloplatformowa, lekka przeglądarka WWW. Celem jest
57 zapewnienie kompletnego renderowania HTML 5 z CSS 2 przy małym
58 wykorzystanie zasobów, z zachowaniem dużej szybkości.
59
60 %package common
61 Summary:        NetSurf - common files
62 Summary(pl.UTF-8):      NetSurf - pliki wspólne
63 Group:          Applications/Networking
64
65 %description common
66 NetSurf - common files.
67
68 %description common -l pl.UTF-8
69 NetSurf - wspólne pliki.
70
71 %package gtk
72 Summary:        NetSurf web browser - GTK+ version
73 Summary(pl.UTF-8):      Wersja GTK+ przeglądarki WWW NetSurf
74 Group:          Applications/Networking
75 Requires:       %{name}-common = %{version}-%{release}
76 Requires:       libCSS >= 0.6.0
77 Requires:       libdom >= 0.3.0
78 Requires:       libhubbub >= 0.3.3
79 Requires:       libnsbmp >= 0.1.3
80 Requires:       libnsgif >= 0.1.3
81 Requires:       libparserutils >= 0.2.3
82 Requires:       libsvgtiny >= 0.1.4
83 Requires:       libwapcaplet >= 0.3.0
84
85 %description gtk
86 NetSurf is a multi-platform lightweight web browser. Its aim is to
87 provide comprehensive rendering of HTML 5 with CSS 2 in a small
88 resource footprint while remaining fast.
89
90 This package contains GTK+ version.
91
92 %description gtk -l pl.UTF-8
93 NetSurf to wieloplatformowa, lekka przeglądarka WWW. Celem jest
94 zapewnienie kompletnego renderowania HTML 5 z CSS 2 przy małym
95 wykorzystanie zasobów, z zachowaniem dużej szybkości.
96
97 Ten pakiet zawiera wersję GTK+.
98
99 %package sdl
100 Summary:        NetSurf web browser - SDL version
101 Summary(pl.UTF-8):      Wersja SDL przeglądarki WWW NetSurf
102 Group:          Applications/Networking
103 Requires:       %{name}-common = %{version}-%{release}
104 Requires:       libCSS >= 0.6.0
105 Requires:       libdom >= 0.3.0
106 Requires:       libhubbub >= 0.3.3
107 Requires:       libnsbmp >= 0.1.3
108 Requires:       libnsfb >= 0.1.4
109 Requires:       libnsgif >= 0.1.3
110 Requires:       libparserutils >= 0.2.3
111 Requires:       libsvgtiny >= 0.1.4
112 Requires:       libwapcaplet >= 0.3.0
113
114 %description sdl
115 NetSurf is a multi-platform lightweight web browser. Its aim is to
116 provide comprehensive rendering of HTML 5 with CSS 2 in a small
117 resource footprint while remaining fast.
118
119 This package contains SDL version.
120
121 %description sdl -l pl.UTF-8
122 NetSurf to wieloplatformowa, lekka przeglądarka WWW. Celem jest
123 zapewnienie kompletnego renderowania HTML 5 z CSS 2 przy małym
124 wykorzystanie zasobów, z zachowaniem dużej szybkości.
125
126 Ten pakiet zawiera wersję SDL.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132 %patch3 -p1
133
134 cat << EOF > Makefile.config
135 NETSURF_FB_FONTLIB := freetype
136 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
137 NETSURF_USE_NSSVG := YES
138 NETSURF_USE_RSVG := YES
139 %{?with_webp:NETSURF_USE_WEBP := YES}
140 %{?with_gstreamer:NETSURF_USE_VIDEO := YES}
141 %{?with_pdf:NETSURF_USE_HARU_PDF := YES}
142 EOF
143
144 %if %{with gstreamer}
145 # GStreamer 0.10 uses now deprecated glib mutex APIs
146 %{__sed} -i -e '/-DG_DISABLE_DEPRECATED/d' gtk/Makefile.target
147 %endif
148 # gdk-pixbuf 2.31 deprecates GdkPixdata
149 %{__sed} -i -e '/-DGDK_PIXBUF_DISABLE_DEPRECATED/d' gtk/Makefile.target
150
151 %build
152 export CC="%{__cc}"
153 # while cxx not needed, somewhy it helps race condition on carme build
154 export CXX="%{__cxx}"
155 # silence -Werror:
156 #src/surface/vnc.c: In function 'vnc_input':
157 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
158 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE"
159 export CXXFLAGS="%{rpmcxxflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE"
160 export LDFLAGS="%{rpmldflags}"
161
162 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
163
164 %{__make} -j1 \
165         OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
166         OPTLDFLAGS="%{rpmldflags}" \
167         PREFIX=%{_prefix} \
168         Q='' \
169         TARGET=gtk
170
171 %{__make} -j1 \
172         OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
173         OPTLDFLAGS="%{rpmldflags}" \
174         PREFIX=%{_prefix} \
175         Q='' \
176         TARGET=framebuffer
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180 %{__make} install \
181         Q='' \
182         PREFIX=%{_prefix} \
183         TARGET=gtk \
184         DESTDIR=$RPM_BUILD_ROOT
185
186
187 %{__make} install \
188         Q='' \
189         PREFIX=%{_prefix} \
190         TARGET=framebuffer \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 # this is binary from last "make install", we install more specific binary ourself
194 %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/netsurf
195
196 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
197 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
198 install nsfb $RPM_BUILD_ROOT%{_bindir}
199 install nsgtk $RPM_BUILD_ROOT%{_bindir}
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %files common
205 %defattr(644,root,root,755)
206 %doc COPYING README
207 %dir %{_datadir}/%{name}
208 %{_datadir}/%{name}/*
209
210 %files gtk
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/nsgtk
213 %{_desktopdir}/netsurf.desktop
214
215 %files sdl
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.088726 seconds and 3 git commands to generate.