]> git.pld-linux.org Git - packages/netsurf.git/commitdiff
- updated to 3.4
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 27 Feb 2016 16:09:24 +0000 (17:09 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 27 Feb 2016 16:09:24 +0000 (17:09 +0100)
- javascript is "provided" by duktape

netsurf-link.patch
netsurf.spec
nsfb-ldflags.patch

index c54979781401289d9d8304720bd482e341cfd6d5..32d3927cfcf7d73d83037f53b8709d0e2d89380a 100644 (file)
@@ -1,12 +1,13 @@
---- netsurf-3.1/framebuffer/Makefile.target.orig       2014-05-14 15:23:27.497560768 +0200
-+++ netsurf-3.1/framebuffer/Makefile.target    2014-05-14 15:59:34.877515592 +0200
-@@ -11,12 +11,15 @@
+--- netsurf-3.4/framebuffer/Makefile.target.orig       2016-02-27 16:48:23.588244698 +0100
++++ netsurf-3.4/framebuffer/Makefile.target    2016-02-27 16:54:49.101350399 +0100
+@@ -4,13 +4,16 @@
  
  # define additional CFLAGS and LDFLAGS requirements for pkg-configed libs here
  NETSURF_FEATURE_RSVG_CFLAGS := -DWITH_RSVG
 +NETSURF_FEATURE_NSSVG_CFLAGS := -DWITH_NS_SVG
  NETSURF_FEATURE_ROSPRITE_CFLAGS := -DWITH_NSSPRITE
  NETSURF_FEATURE_HUBBUB_CFLAGS := -DWITH_HUBBUB
+ NETSURF_FEATURE_PNG_CFLAGS := -DWITH_PNG
  NETSURF_FEATURE_BMP_CFLAGS := -DWITH_BMP
  NETSURF_FEATURE_GIF_CFLAGS := -DWITH_GIF
 +NETSURF_FEATURE_WEBP_CFLAGS := -DWITH_WEBP
  
  CFLAGS += -Dnsframebuffer 
  
-@@ -39,8 +42,12 @@
+@@ -63,8 +66,12 @@ $(eval $(call pkg_config_find_and_add_en
  $(eval $(call pkg_config_find_and_add_enabled,ROSPRITE,librosprite,Sprite))
  $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
  $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
+-$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
 +$(eval $(call pkg_config_find_and_add_enabled,RSVG,librsvg-2.0,SVG))
 +$(eval $(call pkg_config_find_and_add_enabled,NSSVG,libsvgtiny,SVG))
 +$(eval $(call feature_enabled,WEBP,-DWITH_WEBP,-lwebp,WebP (libwebp)))
--$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
 +$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
  $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
 +$(eval $(call pkg_config_find_and_add_enabled,VIDEO,gstreamer-0.10,Video))
  
- CFLAGS += -std=c99 -g -Dsmall $(WARNFLAGS)    \
-         -D_BSD_SOURCE \
---- netsurf-3.3/gtk/Makefile.target~   2015-08-09 13:38:49.000000000 +0200
-+++ netsurf-3.3/gtk/Makefile.target    2015-08-09 13:39:35.568425768 +0200
-@@ -28,7 +28,7 @@
- $(eval $(call pkg_config_find_and_add_enabled,NSSVG,libsvgtiny,SVG))
- $(eval $(call pkg_config_find_and_add_enabled,ROSPRITE,librosprite,Sprite))
- $(eval $(call feature_enabled,WEBP,-DWITH_WEBP,-lwebp,WebP (libwebp)))
+ # ----------------------------------------------------------------------------
+--- netsurf-3.4/monkey/Makefile.target.orig    2016-02-16 14:30:38.000000000 +0100
++++ netsurf-3.4/monkey/Makefile.target 2016-02-27 16:55:46.374649928 +0100
+@@ -40,7 +40,7 @@ $(eval $(call pkg_config_find_and_add_en
+ $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
+ $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
+ $(eval $(call pkg_config_find_and_add_enabled,PNG,libpng,PNG  ))
 -$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
 +$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
  $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
- $(eval $(call pkg_config_find_and_add_enabled,VIDEO,gstreamer-0.10,Video))
  
---- netsurf-3.3/monkey/Makefile.target~        2015-08-09 13:38:49.000000000 +0200
-+++ netsurf-3.3/monkey/Makefile.target 2015-08-09 13:40:00.840359667 +0200
-@@ -27,7 +27,7 @@
+ # ---------------------------------------------------------------------------
+--- netsurf-3.4/riscos/Makefile.target.orig    2016-02-16 14:30:38.000000000 +0100
++++ netsurf-3.4/riscos/Makefile.target 2016-02-27 16:56:44.121296264 +0100
+@@ -28,7 +28,7 @@ NETSURF_FEATURE_MOZJS_CFLAGS := -DWITH_M
  $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
  $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
  $(eval $(call pkg_config_find_and_add_enabled,PNG,libpng,PNG  ))
 +$(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
  $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
  
- # no pkg-config for this library
---- netsurf-3.3/riscos/Makefile.target~        2015-03-10 15:37:37.000000000 +0100
-+++ netsurf-3.3/riscos/Makefile.target 2015-08-09 13:40:14.674721493 +0200
-@@ -33,7 +33,7 @@
-   $(eval $(call pkg_config_find_and_add_enabled,BMP,libnsbmp,BMP))
-   $(eval $(call pkg_config_find_and_add_enabled,GIF,libnsgif,GIF))
-   $(eval $(call pkg_config_find_and_add_enabled,PNG,libpng,PNG  ))
--  $(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs185,JavaScript))
-+  $(eval $(call pkg_config_find_and_add_enabled,MOZJS,mozjs187,JavaScript))
-   $(eval $(call pkg_config_find_and_add_enabled,JS,mozilla-js,JavaScript))
- endif
  
index 6d2bb1236cc09fad4530c82733b3542edaaed676..6bd1952f1791d6a929761d994cd2f42d93197ff7 100644 (file)
@@ -8,43 +8,40 @@
 Summary:       Light WWW browser with CSS support
 Summary(pl.UTF-8):     Lekka przeglądarka WWW z obsługą CSS
 Name:          netsurf
-Version:       3.3
-Release:       2
+Version:       3.4
+Release:       1
 License:       GPL v2 with OpenSSL exception (code), MIT (artwork)
 Group:         Applications/Networking
 Source0:       http://download.netsurf-browser.org/netsurf/releases/source/%{name}-%{version}-src.tar.gz
-# Source0-md5: 81a2838d8816ea435c4471f515a397d4
+# Source0-md5: bf08c97f172a3be31690a36d654c61a4
 Source1:       %{name}.desktop
 Patch0:                nsfb-ldflags.patch
 Patch1:                %{name}-link.patch
-Patch2:                no-Werror.patch
 Patch3:                optflags.patch
-Patch4:                jsapi_h.patch
 URL:           http://netsurf-browser.org/
 BuildRequires: curl-devel
 BuildRequires: freetype-devel >= 2
 %{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
 BuildRequires: gtk+2-devel >= 2.0
-%{?with_js:BuildRequires:      js187-devel}
-BuildRequires: libCSS-devel >= 0.5.0
-BuildRequires: libdom-devel >= 0.1.2
+BuildRequires: libCSS-devel >= 0.6.0
+BuildRequires: libdom-devel >= 0.3.0
 %{?with_pdf:BuildRequires:     libharu-devel}
-BuildRequires: libhubbub-devel >= 0.3.1
+BuildRequires: libhubbub-devel >= 0.3.3
 BuildRequires: libjpeg-devel
-BuildRequires: libnsbmp-devel >= 0.1.2
-BuildRequires: libnsfb-devel >= 0.1.3
-BuildRequires: libnsgif-devel >= 0.1.2
-BuildRequires: libnsutils-devel >= 0.0.1
-BuildRequires: libparserutils-devel >= 0.2.1
+BuildRequires: libnsbmp-devel >= 0.1.3
+BuildRequires: libnsfb-devel >= 0.1.4
+BuildRequires: libnsgif-devel >= 0.1.3
+BuildRequires: libnsutils-devel >= 0.0.2
+BuildRequires: libparserutils-devel >= 0.2.3
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel
-BuildRequires: libsvgtiny-devel >= 0.1.3
-BuildRequires: libutf8proc-devel >= 1.1.6
-BuildRequires: libwapcaplet-devel >= 0.2.2
+BuildRequires: libsvgtiny-devel >= 0.1.4
+BuildRequires: libutf8proc-devel >= 1.3.1
+BuildRequires: libwapcaplet-devel >= 0.3.0
 %{?with_webp:BuildRequires:    libwebp-devel}
 BuildRequires: openssl-devel
-BuildRequires: netsurf-buildsystem >= 1.3
-BuildRequires: nsgenbind >= 0.1.2
+BuildRequires: netsurf-buildsystem >= 1.5
+BuildRequires: nsgenbind >= 0.3
 BuildRequires: perl-HTML-Parser
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -76,14 +73,14 @@ Summary:    NetSurf web browser - GTK+ version
 Summary(pl.UTF-8):     Wersja GTK+ przeglądarki WWW NetSurf
 Group:         Applications/Networking
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      libCSS >= 0.4.0
-Requires:      libdom >= 0.1.1
-Requires:      libhubbub >= 0.3.0
-Requires:      libnsbmp >= 0.1.1
-Requires:      libnsgif >= 0.1.1
-Requires:      libparserutils >= 0.2.0
-Requires:      libsvgtiny >= 0.1.2
-Requires:      libwapcaplet >= 0.2.1
+Requires:      libCSS >= 0.6.0
+Requires:      libdom >= 0.3.0
+Requires:      libhubbub >= 0.3.3
+Requires:      libnsbmp >= 0.1.3
+Requires:      libnsgif >= 0.1.3
+Requires:      libparserutils >= 0.2.3
+Requires:      libsvgtiny >= 0.1.4
+Requires:      libwapcaplet >= 0.3.0
 
 %description gtk
 NetSurf is a multi-platform lightweight web browser. Its aim is to
@@ -104,15 +101,15 @@ Summary:  NetSurf web browser - SDL version
 Summary(pl.UTF-8):     Wersja SDL przeglądarki WWW NetSurf
 Group:         Applications/Networking
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      libCSS >= 0.4.0
-Requires:      libdom >= 0.1.1
-Requires:      libhubbub >= 0.3.0
-Requires:      libnsbmp >= 0.1.1
-Requires:      libnsfb >= 0.1.2
-Requires:      libnsgif >= 0.1.1
-Requires:      libparserutils >= 0.2.0
-Requires:      libsvgtiny >= 0.1.2
-Requires:      libwapcaplet >= 0.2.1
+Requires:      libCSS >= 0.6.0
+Requires:      libdom >= 0.3.0
+Requires:      libhubbub >= 0.3.3
+Requires:      libnsbmp >= 0.1.3
+Requires:      libnsfb >= 0.1.4
+Requires:      libnsgif >= 0.1.3
+Requires:      libparserutils >= 0.2.3
+Requires:      libsvgtiny >= 0.1.4
+Requires:      libwapcaplet >= 0.3.0
 
 %description sdl
 NetSurf is a multi-platform lightweight web browser. Its aim is to
@@ -132,9 +129,7 @@ Ten pakiet zawiera wersję SDL.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 cat << EOF > Makefile.config
 NETSURF_FB_FONTLIB := freetype
@@ -144,14 +139,6 @@ NETSURF_USE_RSVG := YES
 %{?with_webp:NETSURF_USE_WEBP := YES}
 %{?with_gstreamer:NETSURF_USE_VIDEO := YES}
 %{?with_pdf:NETSURF_USE_HARU_PDF := YES}
-# js187
-%if %{with js}
-NETSURF_USE_MOZJS := YES
-%else
-NETSURF_USE_MOZJS := NO
-%endif
-# xulrunner
-NETSURF_USE_JS := NO
 EOF
 
 %if %{with gstreamer}
index ae2a118da197eeeefea6cbabe6a1413d6f99ff36..9b0aefd533118d3629fcef0e1ea8c1d766b7b57c 100644 (file)
@@ -1,11 +1,12 @@
---- netsurf-full-3.0/framebuffer/Makefile.target.fb    2013-09-04 17:56:14.570468347 +0200
-+++ netsurf-full-3.0/framebuffer/Makefile.target       2013-09-04 17:56:45.980954115 +0200
-@@ -51,7 +51,7 @@ CFLAGS += -std=c99 -g -Dsmall $(WARNFLAG
-         $(shell $(PKG_CONFIG) --cflags libnsfb libhubbub libcss openssl) \
-         $(shell xml2-config --cflags)
+--- netsurf-3.4/framebuffer/Makefile.target.orig       2016-02-16 14:30:38.000000000 +0100
++++ netsurf-3.4/framebuffer/Makefile.target    2016-02-27 16:44:59.385032043 +0100
+@@ -39,9 +39,7 @@ CFLAGS += -std=c99 -g -Dsmall \
+ LDFLAGS += -lm
  
--LDFLAGS += -lm -Wl,--whole-archive $(shell $(PKG_CONFIG) --libs libnsfb) -Wl,--no-whole-archive 
-+LDFLAGS += -lm $(shell $(PKG_CONFIG) --libs libnsfb) 
+ # non optional pkg-configed libs
+-LDFLAGS += -Wl,--whole-archive
+ $(eval $(call pkg_config_find_and_add,libnsfb,libnsfb))
+-LDFLAGS += -Wl,--no-whole-archive
+ $(eval $(call pkg_config_find_and_add,openssl,OpenSSL))
  
- ifeq ($(HOST),mint)
-     # freemint does not support pkg-config for libcurl
This page took 0.1797 seconds and 4 git commands to generate.