]> git.pld-linux.org Git - packages/nagios-nrpe.git/commitdiff
up to 3.2.0 (2017-06-27) auto/th/nagios-nrpe-3.2.0-1
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 11 Jul 2017 09:22:57 +0000 (12:22 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Tue, 11 Jul 2017 09:23:23 +0000 (12:23 +0300)
commands.cfg
nagios-nrpe-config.patch
nagios-nrpe.spec

index 4ff6c62bc2e7039b921e348ce6fdb9407c758eab..3aa8fb1df673af53d8530f324f01ee986a32a9a7 100644 (file)
 
 
 # The following examples use hardcoded command arguments...
+# This is by far the most secure method of using NRPE
 
 #command[check_users]=/usr/lib/nagios/check_users -w 5 -c 10
-#command[check_load]=/usr/lib/nagios/check_load -w 15,10,5 -c 30,25,20
+#command[check_load]=/usr/lib/nagios/check_load -r -w .15,.10,.05 -c .30,.25,.20
 #command[check_hda1]=/usr/lib/nagios/check_disk -w 20% -c 10% -p /dev/hda1
 #command[check_zombie_procs]=/usr/lib/nagios/check_procs -w 5 -c 10 -s Z
 #command[check_total_procs]=/usr/lib/nagios/check_procs -w 150 -c 200
 
-
 # The following examples allow user-supplied arguments and can
 # only be used if the NRPE daemon was compiled with support for
 # command arguments *AND* the dont_blame_nrpe directive in this
 # config file is set to '1'.  This poses a potential security risk, so
 # make sure you read the SECURITY file before doing this.
 
-#command[check_users]=/usr/lib/nagios/check_users -w $ARG1$ -c $ARG2$
-#command[check_load]=/usr/lib/nagios/check_load -w $ARG1$ -c $ARG2$
-#command[check_disk]=/usr/lib/nagios/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$
-#command[check_procs]=/usr/lib/nagios/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$
+### MISC SYSTEM METRICS ###
+#command[check_users]=/usr/lib/nagios/check_users $ARG1$
+#command[check_load]=/usr/lib/nagios/check_load $ARG1$
+#command[check_disk]=/usr/lib/nagios/check_disk $ARG1$
+#command[check_swap]=/usr/lib/nagios/check_swap $ARG1$
+#command[check_cpu_stats]=/usr/lib/nagios/check_cpu_stats.sh $ARG1$
+#command[check_mem]=/usr/lib/nagios/custom_check_mem -n $ARG1$
+
+### GENERIC SERVICES ###
+#command[check_init_service]=sudo /usr/lib/nagios/check_init_service $ARG1$
+#command[check_services]=/usr/lib/nagios/check_services -p $ARG1$
+
+### SYSTEM UPDATES ###
+#command[check_yum]=/usr/lib/nagios/check_yum
+#command[check_apt]=/usr/lib/nagios/check_apt
+
+### PROCESSES ###
+#command[check_all_procs]=/usr/lib/nagios/custom_check_procs
+#command[check_procs]=/usr/lib/nagios/check_procs $ARG1$
+
+### OPEN FILES ###
+#command[check_open_files]=/usr/lib/nagios/check_open_files.pl $ARG1$
+
+### NETWORK CONNECTIONS ###
+#command[check_netstat]=/usr/lib/nagios/check_netstat.pl -p $ARG1$ $ARG2$
+
+### ASTERISK ###
+#command[check_asterisk]=/usr/lib/nagios/check_asterisk.pl $ARG1$
+#command[check_sip]=/usr/lib/nagios/check_sip $ARG1$
+#command[check_asterisk_sip_peers]=sudo /usr/lib/nagios/check_asterisk_sip_peers.sh $ARG1$
+#command[check_asterisk_version]=/usr/lib/nagios/nagisk.pl -c version
+#command[check_asterisk_peers]=/usr/lib/nagios/nagisk.pl -c peers
+#command[check_asterisk_channels]=/usr/lib/nagios/nagisk.pl -c channels 
+#command[check_asterisk_zaptel]=/usr/lib/nagios/nagisk.pl -c zaptel 
+#command[check_asterisk_span]=/usr/lib/nagios/nagisk.pl -c span -s 1
index 7cd8cd8862c3370a8e8d6cab18c6479159418add..e94813ecb937363dcd83daee5e30b9f364c1d570 100644 (file)
@@ -1,14 +1,14 @@
---- nrpe-3.0.orig/sample-config/nrpe.cfg.in    2016-07-12 23:24:40.000000000 +0300
-+++ nrpe-3.0/sample-config/nrpe.cfg.in 2016-09-07 15:46:35.913180521 +0300
-@@ -257,47 +257,8 @@
+--- nrpe-3.2.0/sample-config/nrpe.cfg.in~      2017-06-28 00:13:20.000000000 +0300
++++ nrpe-3.2.0/sample-config/nrpe.cfg.in       2017-07-11 12:15:01.541380203 +0300
+@@ -281,80 +281,4 @@
+ # INCLUDE CONFIG DIRECTORY
  # This directive allows you to include definitions from config files (with a
  # .cfg extension) in one or more directories (with recursion).
+-
 -#include_dir=<somedirectory>
 -#include_dir=<someotherdirectory>
-+include_dir=/etc/nagios/nrpe.d
+-
+-
 -
 -# COMMAND DEFINITIONS
 -# Command definitions that this daemon will run.  Definitions
 -
 -
 -# The following examples use hardcoded command arguments...
+-# This is by far the most secure method of using NRPE
 -
 -command[check_users]=@pluginsdir@/check_users -w 5 -c 10
--command[check_load]=@pluginsdir@/check_load -w 15,10,5 -c 30,25,20
+-command[check_load]=@pluginsdir@/check_load -r -w .15,.10,.05 -c .30,.25,.20
 -command[check_hda1]=@pluginsdir@/check_disk -w 20% -c 10% -p /dev/hda1
 -command[check_zombie_procs]=@pluginsdir@/check_procs -w 5 -c 10 -s Z
 -command[check_total_procs]=@pluginsdir@/check_procs -w 150 -c 200
 -# config file is set to '1'.  This poses a potential security risk, so
 -# make sure you read the SECURITY file before doing this.
 -
--#command[check_users]=@pluginsdir@/check_users -w $ARG1$ -c $ARG2$
--#command[check_load]=@pluginsdir@/check_load -w $ARG1$ -c $ARG2$
--#command[check_disk]=@pluginsdir@/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$
--#command[check_procs]=@pluginsdir@/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$
-+# NOTE:
-+# In PLD Linux, command definitions are in file /etc/nagios/nrpe.d/commands.cfg
+-### MISC SYSTEM METRICS ###
+-#command[check_users]=@pluginsdir@/check_users $ARG1$
+-#command[check_load]=@pluginsdir@/check_load $ARG1$
+-#command[check_disk]=@pluginsdir@/check_disk $ARG1$
+-#command[check_swap]=@pluginsdir@/check_swap $ARG1$
+-#command[check_cpu_stats]=@pluginsdir@/check_cpu_stats.sh $ARG1$
+-#command[check_mem]=@pluginsdir@/custom_check_mem -n $ARG1$
+-
+-### GENERIC SERVICES ###
+-#command[check_init_service]=sudo @pluginsdir@/check_init_service $ARG1$
+-#command[check_services]=@pluginsdir@/check_services -p $ARG1$
+-
+-### SYSTEM UPDATES ###
+-#command[check_yum]=@pluginsdir@/check_yum
+-#command[check_apt]=@pluginsdir@/check_apt
+-
+-### PROCESSES ###
+-#command[check_all_procs]=@pluginsdir@/custom_check_procs
+-#command[check_procs]=@pluginsdir@/check_procs $ARG1$
+-
+-### OPEN FILES ###
+-#command[check_open_files]=@pluginsdir@/check_open_files.pl $ARG1$
+-
+-### NETWORK CONNECTIONS ###
+-#command[check_netstat]=@pluginsdir@/check_netstat.pl -p $ARG1$ $ARG2$
+-
+-### ASTERISK ###
+-#command[check_asterisk]=@pluginsdir@/check_asterisk.pl $ARG1$
+-#command[check_sip]=@pluginsdir@/check_sip $ARG1$
+-#command[check_asterisk_sip_peers]=sudo @pluginsdir@/check_asterisk_sip_peers.sh $ARG1$
+-#command[check_asterisk_version]=@pluginsdir@/nagisk.pl -c version
+-#command[check_asterisk_peers]=@pluginsdir@/nagisk.pl -c peers
+-#command[check_asterisk_channels]=@pluginsdir@/nagisk.pl -c channels 
+-#command[check_asterisk_zaptel]=@pluginsdir@/nagisk.pl -c zaptel 
+-#command[check_asterisk_span]=@pluginsdir@/nagisk.pl -c span -s 1
++include_dir=/etc/nagios/nrpe.d
index 1cd67442fa27c638d89dde07e28b62709c91a2be..0b34add64ce21be1076044c75cbc8b8bbcfff0aa 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       Nagios remote plugin execution service/plugin
 Summary(pl.UTF-8):     Demon i wtyczka zdalnego wywoływania wtyczek Nagios
 Name:          nagios-nrpe
-Version:       3.0.1
+Version:       3.2.0
 Release:       1
 License:       GPL v2
 Group:         Networking
 Source0:       http://downloads.sourceforge.net/nagios/nrpe-%{version}.tar.gz
-# Source0-md5: 8c81f251d9ee0903e5ff0191e99f7981
+# Source0-md5: 5c81355bcd8b9929ca904879075e1ff5
 Source1:       nrpe.init
 Source2:       nrpe-command.cfg
 Source3:       %{name}.tmpfiles
@@ -141,7 +141,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc Changelog LEGAL README* SECURITY.md update-cfg.pl
+%doc CHANGELOG.md LEGAL README* SECURITY.md update-cfg.pl
 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
 %attr(750,root,nagios) %dir %{_sysconfdir}/nrpe.d
 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
This page took 0.055877 seconds and 4 git commands to generate.