]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- fix bashizm in configure
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.14.6
6 Release:        2
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  1b5b91a5d0abb8cefef9f4195738e621
11 URL:            http://www.rasterbar.com/products/libtorrent/
12 Patch0:         bashizm.patch
13 BuildRequires:  GeoIP-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  boost-devel >= 1.35.0
17 BuildRequires:  boost-python-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig >= 1:0.20
22 BuildRequires:  python-devel
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  util-linux-ng
25 BuildRequires:  which
26 BuildRequires:  zlib-devel
27 Obsoletes:      rb_libtorrent
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libtorrent-rasterbar is a C++ library that aims to be a good
32 alternative to all the other BitTorrent implementations around. It is
33 a library and not a full featured client, although it comes with a
34 working example client.
35
36 Its main goals are to be very efficient (in terms of CPU and memory
37 usage) as well as being very easy to use both as a user and developer.
38
39 %description -l hu.UTF-8
40 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
41 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
42 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
43 működő példa-klienst.
44
45 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
46 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
47
48 %description -l pl.UTF-8
49 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
50 bycia dobrą alternatywą dla wszystkich innych implementacji
51 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
52 pakiet zawiera działającego przykładowego klienta.
53
54 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
55 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
56 dla użytkownika, jak i programisty.
57
58 %package devel
59 Summary:        Header files for %{name} library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
61 License:        BSD, zlib/libpng License, Boost Software License
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       boost-devel
65 Requires:       openssl-devel
66 Obsoletes:      rb_libtorrent-devel
67
68 %description    devel
69 The libtorrent-rasterbar-devel package contains libraries and header
70 files for developing applications that use libtorrent-rasterbar.
71
72 The various source and header files included in this package are
73 licensed under the revised BSD, zlib/libpng, and Boost Public
74 licenses.
75
76 %description devel -l hu.UTF-8
77 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
78 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
79 alkalmazásokat fejleszthetsz.
80
81 %description devel -l pl.UTF-8
82 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
83 rozwijania aplikacji używających libtorrent-rasterbar.
84
85 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
86 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
87 License.
88
89 %package static
90 Summary:        Static %{name} library
91 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Obsoletes:      rb_libtorrent-static
95
96 %description static
97 Static libtorrent-rasterbar library.
98
99 %description static -l hu.UTF-8
100 Statikus libtorrent-rasterbar könyvtár.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka libtorrent-rasterbar.
104
105 %package -n python-libtorrent-rasterbar
106 Summary:        Python bindings for libtorrent-rasterbar
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109
110 %description -n python-libtorrent-rasterbar
111 Python bindings for libtorrent-rasterbar.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
117
118 ## Some of the sources and docs are executable, which makes rpmlint against
119 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
120 find src docs -type f | xargs chmod a-x
121 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
122 ## The RST files are the sources used to create the final HTML files; and are
123 ## not needed.
124 rm -f docs/*.rst
125
126 %build
127 %{__libtoolize}
128 %{__aclocal} -I m4
129 %{__autoconf}
130 %{__automake}
131 %configure \
132         --enable-python-binding \
133         --with-boost-system=boost_system \
134         --with-boost-filesystem=boost_filesystem \
135         --with-boost-thread=boost_thread \
136         --with-boost-regex=boost_regex \
137         --with-boost-program-options=boost_program_options \
138         --with-asio=system \
139         --with-zlib=system \
140         --with-libgeoip=system \
141         --with-ssl
142
143 %{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 ## Ensure that we preserve our timestamps properly.
148 #export CPPROG="%{__cp} -p"
149 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
154 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog COPYING README
165 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
166
167 %files devel
168 %defattr(644,root,root,755)
169 %doc docs/
170 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
171 %{_libdir}/libtorrent-rasterbar.la
172 %{_pkgconfigdir}/libtorrent-rasterbar.pc
173 %{_includedir}/libtorrent
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libtorrent-rasterbar.a
178
179 %files -n python-libtorrent-rasterbar
180 %{py_sitedir}/libtorrent.so
181 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.261557 seconds and 4 git commands to generate.