]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
up to 2.0.10 (new soname)
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        2.0.10
6 Release:        1
7 Epoch:          2
8 License:        BSD
9 Group:          Libraries
10 #Source0Download: https://github.com/arvidn/libtorrent/releases
11 Source0:        https://github.com/arvidn/libtorrent/releases/download/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  bfe6fff84add3dc5d51e10547f85e217
13 URL:            http://www.rasterbar.com/products/libtorrent/
14 BuildRequires:  boost-devel >= 1.67
15 BuildRequires:  boost-python3-devel >= 1.67
16 BuildRequires:  cmake >= 3.16.0
17 BuildRequires:  libstdc++-devel >= 6:5
18 BuildRequires:  openssl-devel
19 BuildRequires:  pkgconfig >= 1:0.20
20 BuildRequires:  python3 >= 1:3.6
21 BuildRequires:  python3-devel >= 1:3.6
22 BuildRequires:  python3-modules >= 1:3.6
23 BuildRequires:  python3-setuptools
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  util-linux
28 BuildRequires:  zlib-devel
29 Obsoletes:      rb_libtorrent < 0.13
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         boost_py3ver %(echo %{py3_ver} | tr -d .)
33
34 %description
35 libtorrent-rasterbar is a C++ library that aims to be a good
36 alternative to all the other BitTorrent implementations around. It is
37 a library and not a full featured client, although it comes with a
38 working example client.
39
40 Its main goals are to be very efficient (in terms of CPU and memory
41 usage) as well as being very easy to use both as a user and developer.
42
43 %description -l hu.UTF-8
44 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
45 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
46 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
47 működő példa-klienst.
48
49 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
50 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
51
52 %description -l pl.UTF-8
53 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
54 bycia dobrą alternatywą dla wszystkich innych implementacji
55 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
56 pakiet zawiera działającego przykładowego klienta.
57
58 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
59 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
60 dla użytkownika, jak i programisty.
61
62 %package devel
63 Summary:        Header files for %{name} library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
65 License:        BSD, zlib/libpng License, Boost Software License
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 Requires:       boost-devel >= 1.67
69 Requires:       libstdc++-devel >= 6:5
70 Requires:       openssl-devel
71 Obsoletes:      libtorrent-rasterbar-static < 2:2.0.10
72 Obsoletes:      rb_libtorrent-devel < 0.13
73
74 %description    devel
75 The libtorrent-rasterbar-devel package contains libraries and header
76 files for developing applications that use libtorrent-rasterbar.
77
78 The various source and header files included in this package are
79 licensed under the revised BSD, zlib/libpng, and Boost Public
80 licenses.
81
82 %description devel -l hu.UTF-8
83 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
84 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
85 alkalmazásokat fejleszthetsz.
86
87 %description devel -l pl.UTF-8
88 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
89 rozwijania aplikacji używających libtorrent-rasterbar.
90
91 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
92 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
93 License.
94
95 %package -n python3-libtorrent-rasterbar
96 Summary:        Python 3 bindings for libtorrent-rasterbar
97 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libtorrent-rasterbar
98 Group:          Libraries/Python
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100 Obsoletes:      python-libtorrent-rasterbar < 2:1.2.7-8
101
102 %description -n python3-libtorrent-rasterbar
103 Python 3 bindings for libtorrent-rasterbar.
104
105 %description -n python3-libtorrent-rasterbar -l pl.UTF-8
106 Wiązania Pythona 3 do biblioteki libtorrent-rasterbar.
107
108 %prep
109 %setup -q
110
111 ## Some of the sources and docs are executable, which makes rpmlint against
112 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
113 find src docs -type f | xargs chmod a-x
114 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
115 ## The RST files are the sources used to create the final HTML files; and are
116 ## not needed.
117 %{__rm} docs/*.rst
118
119 %build
120 %cmake -B build \
121         -Dpython-bindings:BOOL=ON \
122         -Dpython-egg-info:BOOL=ON
123
124 %{__make} -C build
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} -C build install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog COPYING
141 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.2.0
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc docs/
147 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
148 %{_includedir}/libtorrent
149 %{_pkgconfigdir}/libtorrent-rasterbar.pc
150 %{_datadir}/cmake/Modules/FindLibtorrentRasterbar.cmake
151 %{_libdir}/cmake/LibtorrentRasterbar
152
153 %files -n python3-libtorrent-rasterbar
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{py3_sitedir}/libtorrent.*.so
156 %{py3_sitedir}/libtorrent.egg-info
This page took 0.342772 seconds and 4 git commands to generate.