]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- removed the overwrite of libtorrent-rasterbar.pc
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.13.1
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  9d6b112fedc5861402647ff72e95dba0
11 Patch0:         %{name}-examples.patch
12 ## fix the build error with newest boost -- it will be fixed in the next libtorrent version
13 Patch1:         %{name}-boost.patch
14 Patch2:         %{name}-condition.patch
15 URL:            http://www.rasterbar.com/products/libtorrent/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  boost-devel >= 1.35.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libtorrent-rasterbar is a C++ library that aims to be a good
26 alternative to all the other BitTorrent implementations around. It is
27 a library and not a full featured client, although it comes with a
28 working example client.
29
30 Its main goals are to be very efficient (in terms of CPU and memory
31 usage) as well as being very easy to use both as a user and developer.
32
33 %description -l hu.UTF-8
34 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
35 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
36 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
37 működő példa-klienst.
38
39 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
40 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
41
42 %description -l pl.UTF-8
43 libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
44 bycia dobrą alternatywą dla wszystkich innych implementacji
45 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
46 pakiet zawiera działającego przykładowego klienta.
47
48 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
49 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
50 dla użytkownika, jak i programisty.
51
52 %package devel
53 Summary:        Header files for %{name} library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
55 License:        BSD, zlib/libpng License, Boost Software License
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       boost-devel
59 Requires:       openssl-devel
60 ## Same pkgconfig file, and unsuffixed shared library symlink.:(
61 Conflicts:      libtorrent-devel
62
63 %description    devel
64 The libtorrent-rasterbar-devel package contains libraries and header
65 files for developing applications that use libtorrent-rasterbar.
66
67 The various source and header files included in this package are
68 licensed under the revised BSD, zlib/libpng, and Boost Public
69 licenses.
70
71 %description devel -l hu.UTF-8
72 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
73 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
74 alkalmazásokat fejleszthetsz.
75
76 %description devel -l pl.UTF-8
77 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
78 rozwijania aplikacji używających libtorrent-rasterbar.
79
80 Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
81 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
82
83 %package static
84 Summary:        Static %{name} library
85 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static libtorrent-rasterbar library.
91
92 %description static -l hu.UTF-8
93 Statikus libtorrent-rasterbar könyvtár.
94
95 %description static -l pl.UTF-8
96 Statyczna biblioteka libtorrent-rasterbar.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 ## Some of the sources and docs are executable, which makes rpmlint against
104 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
105 find src docs -type f | xargs chmod a-x
106 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
107 ## The RST files are the sources used to create the final HTML files; and are
108 ## not needed.
109 rm -f docs/*.rst
110
111 %build
112 %{__aclocal} -I m4
113 %{__libtoolize}
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         --with-boost-system=boost_system\
118         --with-boost-date-time=boost_date_time\
119         --with-boost-filesystem=boost_filesystem\
120         --with-boost-thread=boost_thread\
121         --with-boost-regex=boost_regex\
122         --with-boost-program-options=boost_program_options\
123         --with-{asio,zlib}=system
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 ## Ensure that we preserve our timestamps properly.
130 #export CPPROG="%{__cp} -p"
131 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
136 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog COPYING README
147 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc docs/
152 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
153 %{_libdir}/libtorrent-rasterbar.la
154 %{_pkgconfigdir}/libtorrent-rasterbar.pc
155 %{_includedir}/libtorrent
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libtorrent-rasterbar.a
This page took 0.103024 seconds and 4 git commands to generate.