]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- rel 2
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.14.1
6 Release:        2
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10 # Source0-md5:  6aa0ed4da604b8b160bf12bcd41d5055
11 URL:            http://www.rasterbar.com/products/libtorrent/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  boost-devel >= 1.35.0
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  openssl-devel
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  which
20 BuildRequires:  util-linux-ng
21 BuildRequires:  zlib-devel
22 Obsoletes:      rb_libtorrent
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libtorrent-rasterbar is a C++ library that aims to be a good
27 alternative to all the other BitTorrent implementations around. It is
28 a library and not a full featured client, although it comes with a
29 working example client.
30
31 Its main goals are to be very efficient (in terms of CPU and memory
32 usage) as well as being very easy to use both as a user and developer.
33
34 %description -l hu.UTF-8
35 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
36 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
37 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
38 működő példa-klienst.
39
40 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
41 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
42
43 %description -l pl.UTF-8
44 libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
45 bycia dobrą alternatywą dla wszystkich innych implementacji
46 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
47 pakiet zawiera działającego przykładowego klienta.
48
49 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
50 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
51 dla użytkownika, jak i programisty.
52
53 %package devel
54 Summary:        Header files for %{name} library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
56 License:        BSD, zlib/libpng License, Boost Software License
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       boost-devel
60 Requires:       openssl-devel
61 Obsoletes:      rb_libtorrent-devel
62
63 %description    devel
64 The libtorrent-rasterbar-devel package contains libraries and header
65 files for developing applications that use libtorrent-rasterbar.
66
67 The various source and header files included in this package are
68 licensed under the revised BSD, zlib/libpng, and Boost Public
69 licenses.
70
71 %description devel -l hu.UTF-8
72 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
73 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
74 alkalmazásokat fejleszthetsz.
75
76 %description devel -l pl.UTF-8
77 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
78 rozwijania aplikacji używających libtorrent-rasterbar.
79
80 Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
81 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
82
83 %package static
84 Summary:        Static %{name} library
85 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Obsoletes:      rb_libtorrent-static
89
90 %description static
91 Static libtorrent-rasterbar library.
92
93 %description static -l hu.UTF-8
94 Statikus libtorrent-rasterbar könyvtár.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka libtorrent-rasterbar.
98
99 %prep
100 %setup -q
101
102 ## Some of the sources and docs are executable, which makes rpmlint against
103 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
104 find src docs -type f | xargs chmod a-x
105 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
106 ## The RST files are the sources used to create the final HTML files; and are
107 ## not needed.
108 rm -f docs/*.rst
109
110 %build
111 %{__aclocal} -I m4
112 %{__libtoolize}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --with-boost-system=boost_system \
117         --with-boost-filesystem=boost_filesystem \
118         --with-boost-thread=boost_thread \
119         --with-boost-regex=boost_regex \
120         --with-boost-program-options=boost_program_options \
121         --with-{asio,zlib}=system \
122         --with-ssl
123
124 %{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 ## Ensure that we preserve our timestamps properly.
129 #export CPPROG="%{__cp} -p"
130 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
135 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog COPYING README
146 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %doc docs/
151 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
152 %{_libdir}/libtorrent-rasterbar.la
153 %{_pkgconfigdir}/libtorrent-rasterbar.pc
154 %{_includedir}/libtorrent
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libtorrent-rasterbar.a
This page took 0.089456 seconds and 4 git commands to generate.