]> git.pld-linux.org Git - packages/libprelude.git/commitdiff
- updated to 1.2.6 (note: new sonames)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Feb 2016 20:35:32 +0000 (21:35 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Feb 2016 20:35:42 +0000 (21:35 +0100)
- updated python-install patch
- removed obsolete libtool,ruby,gnutls,gets,python,format-security,gcc5,swig patches
- PreludeEasy bindings are gone
- added python3 binding

format-security.patch [deleted file]
gcc5.patch [deleted file]
libprelude-gets.patch [deleted file]
libprelude-gnutls.patch [deleted file]
libprelude-libtool.patch [deleted file]
libprelude-python.patch [deleted file]
libprelude-ruby.patch [deleted file]
libprelude.spec
python-install.patch
swig.patch [deleted file]

diff --git a/format-security.patch b/format-security.patch
deleted file mode 100644 (file)
index 2cb15af..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- libprelude-1.0.1/bindings/low-level/perl/libprelude_perl.i~        2012-06-01 17:12:00.000000000 +0200
-+++ libprelude-1.0.1/bindings/low-level/perl/libprelude_perl.i 2014-09-14 19:52:09.404011239 +0200
-@@ -29,7 +29,7 @@
-       char buf[1024];
-       snprintf(buf, sizeof(buf), "Prelude error - %s: %s", prelude_strsource(error), prelude_strerror(error));
--      croak(buf);
-+      croak("%s", buf);
- }
diff --git a/gcc5.patch b/gcc5.patch
deleted file mode 100644 (file)
index e301393..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: b/src/libprelude-error/Makefile.am
-===================================================================
---- a/src/libprelude-error/Makefile.am
-+++ b/src/libprelude-error/Makefile.am
-@@ -40,7 +40,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
- mkerrcodes.h: Makefile mkerrcodes.awk
-       LANG="" $(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
--      $(CPP) _$@ | grep PRELUDE_ERROR_ | LANG="" $(AWK) -f $(srcdir)/mkerrcodes.awk >$@
-+      $(CPP) -P _$@ | grep PRELUDE_ERROR_ | LANG="" $(AWK) -f $(srcdir)/mkerrcodes.awk >$@
-       -rm _$@
- # It is correct to use $(CC_FOR_BUILD) here.  We want to run the
diff --git a/libprelude-gets.patch b/libprelude-gets.patch
deleted file mode 100644 (file)
index 74cd58c..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From f5fab01434b096b3bc2b058fec41123392eb3dcb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
-Date: Wed, 8 Aug 2012 14:13:16 +0200
-Subject: [PATCH] Fix building with glibc-2.16.6
-
-Ported to libprelude-1.0.0 from gnulib commit:
-
-From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
-From: Eric Blake <eblake@redhat.com>
-Date: Thu, 29 Mar 2012 13:30:41 -0600
-Subject: [PATCH] stdio: don't assume gets any more
-
-Gnulib intentionally does not have a gets module, and now that C11
-and glibc have dropped it, we should be more proactive about warning
-any user on a platform that still has a declaration of this dangerous
-interface.
----
- libmissing/m4/stdio_h.m4     | 4 ++--
- libmissing/m4/warn-on-use.m4 | 4 ++--
- libmissing/stdio.in.h        | 6 ++++--
- 3 files changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/libmissing/m4/stdio_h.m4 b/libmissing/m4/stdio_h.m4
-index 781fa8d..fc65d37 100644
---- a/libmissing/m4/stdio_h.m4
-+++ b/libmissing/m4/stdio_h.m4
-@@ -34,9 +34,9 @@ AC_DEFUN([gl_STDIO_H],
-   dnl Check for declarations of anything we want to poison if the
-   dnl corresponding gnulib module is not in use, and which is not
--  dnl guaranteed by C89.
-+  dnl guaranteed by both C89 and C11.
-   gl_WARN_ON_USE_PREPARE([[#include <stdio.h>
--    ]], [dprintf fpurge fseeko ftello getdelim getline popen renameat
-+    ]], [dprintf fpurge fseeko ftello getdelim getline gets popen renameat
-     snprintf vdprintf vsnprintf])
- ])
-diff --git a/libmissing/m4/warn-on-use.m4 b/libmissing/m4/warn-on-use.m4
-index ab46422..494e00b 100644
---- a/libmissing/m4/warn-on-use.m4
-+++ b/libmissing/m4/warn-on-use.m4
-@@ -18,8 +18,8 @@ dnl with or without modifications, as long as this notice is preserved.
- # some systems declare functions in the wrong header, then INCLUDES
- # should do likewise.
- #
--# If you assume C89, then it is generally safe to assume declarations
--# for functions declared in that standard (such as gets) without
-+# It is generally safe to assume declarations for functions declared
-+# in the intersection of C89 and C11 (such as printf) without
- # needing gl_WARN_ON_USE_PREPARE.
- AC_DEFUN([gl_WARN_ON_USE_PREPARE],
- [
-diff --git a/libmissing/stdio.in.h b/libmissing/stdio.in.h
-index f5d5d88..6924ef2 100644
---- a/libmissing/stdio.in.h
-+++ b/libmissing/stdio.in.h
-@@ -114,10 +114,12 @@ _GL_WARN_ON_USE (fflush, "fflush is not always POSIX compliant - "
- #endif
- /* It is very rare that the developer ever has full control of stdin,
--   so any use of gets warrants an unconditional warning.  Assume it is
--   always declared, since it is required by C89.  */
-+   so any use of gets warrants an unconditional warning; besides, C11
-+   removed it.  */
- #undef gets
-+#if HAVE_RAW_DECL_GETS
- _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
-+#endif
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
--- 
-1.7.11.2
-
diff --git a/libprelude-gnutls.patch b/libprelude-gnutls.patch
deleted file mode 100644 (file)
index 573c9da..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -ur libprelude-1.0.1.orig//m4/libgnutls-extra.m4 libprelude-1.0.1/m4/libgnutls-extra.m4
---- libprelude-1.0.1.orig//m4/libgnutls-extra.m4       2012-04-02 09:41:15.000000000 +0000
-+++ libprelude-1.0.1/m4/libgnutls-extra.m4     2012-11-08 14:05:46.160509830 +0000
-@@ -48,7 +48,6 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <gnutls/extra.h>
- int
- main ()
-diff -ur libprelude-1.0.1.orig//prelude-admin/prelude-admin.c libprelude-1.0.1/prelude-admin/prelude-admin.c
---- libprelude-1.0.1.orig//prelude-admin/prelude-admin.c       2012-06-01 15:12:22.000000000 +0000
-+++ libprelude-1.0.1/prelude-admin/prelude-admin.c     2012-11-08 14:05:59.160517936 +0000
-@@ -57,7 +57,6 @@
- #include <errno.h>
- #include <gnutls/gnutls.h>
- #include <gnutls/x509.h>
--#include <gnutls/extra.h>
- #include "common.h"
- #include "config-engine.h"
-diff -ur libprelude-1.0.1.orig//prelude-admin/server.c libprelude-1.0.1/prelude-admin/server.c
---- libprelude-1.0.1.orig//prelude-admin/server.c      2012-06-01 15:12:22.000000000 +0000
-+++ libprelude-1.0.1/prelude-admin/server.c    2012-11-08 14:06:04.057509537 +0000
-@@ -39,7 +39,6 @@
- #include <gcrypt.h>
- #include <gnutls/gnutls.h>
--#include <gnutls/extra.h>
- #include "prelude-client.h"
- #include "prelude-error.h"
diff --git a/libprelude-libtool.patch b/libprelude-libtool.patch
deleted file mode 100644 (file)
index eab13fa..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur libprelude-1.0.0/src/include/prelude-plugin.h libprelude-1.0.0.new//src/include/prelude-plugin.h
---- libprelude-1.0.0/src/include/prelude-plugin.h      2010-03-10 13:18:20.000000000 +0100
-+++ libprelude-1.0.0.new//src/include/prelude-plugin.h 2011-08-01 10:45:41.723988238 +0200
-@@ -61,9 +61,9 @@
-  */
- #ifdef PRELUDE_APPLICATION_USE_LIBTOOL2
- # define lt_preloaded_symbols lt__PROGRAM__LTX_preloaded_symbols
--#endif
- extern const void *lt_preloaded_symbols[];
-+#endif
- #define PRELUDE_PLUGIN_SET_PRELOADED_SYMBOLS()         \
-         prelude_plugin_set_preloaded_symbols(lt_preloaded_symbols)
diff --git a/libprelude-python.patch b/libprelude-python.patch
deleted file mode 100644 (file)
index 70a9817..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur libprelude-1.0.1.orig/bindings/libpreludecpp.i libprelude-1.0.1.new/bindings/libpreludecpp.i
---- libprelude-1.0.1.orig/bindings/libpreludecpp.i     2012-06-01 15:12:00.000000000 +0000
-+++ libprelude-1.0.1.new/bindings/libpreludecpp.i      2013-05-17 12:58:32.606635634 +0000
-@@ -22,6 +22,9 @@
- *****/
- %module PreludeEasy
-+%{
-+#include <stddef.h>
-+%}
- %include "std_string.i"
- %include "std_vector.i"
diff --git a/libprelude-ruby.patch b/libprelude-ruby.patch
deleted file mode 100644 (file)
index f7c63a6..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
---- libprelude-1.0.0/m4/am_path_ruby.m4.orig   2010-01-11 12:09:42.000000000 +0100
-+++ libprelude-1.0.0/m4/am_path_ruby.m4        2011-08-07 16:18:31.583033709 +0200
-@@ -100,7 +100,7 @@
-   AC_SUBST([rbexecdir], [$am_cv_ruby_rbexecdir])
-   RUBY_INCLUDES=`$RUBY -r rbconfig -e 'if Config::CONFIG[["archdir"]] then print " -I" + Config::CONFIG[["archdir"]] end
--                                       if Config::CONFIG[["rubyhdrdir"]] then print " -I" + Config::CONFIG[["rubyhdrdir"]] end'`
-+                                       if Config::CONFIG[["rubyhdrdir"]] then print " -I" + Config::CONFIG[["rubyhdrdir"]]; print " -I" + Config::CONFIG[["rubyhdrdir"]] + "/" + Config::CONFIG[["arch"]] end'`
-   AC_SUBST([RUBY_INCLUDES])
-   dnl pkgrbexecdir -- $(rbexecdir)/$(PACKAGE)
---- libprelude-1.0.0/bindings/ruby/libpreludecpp-ruby.i.orig   2011-08-07 21:07:53.936358340 +0200
-+++ libprelude-1.0.0/bindings/ruby/libpreludecpp-ruby.i        2011-08-08 20:26:34.566624741 +0200
-@@ -21,8 +21,9 @@
- %{
- extern "C" {
--#include "rubyio.h"
-+#include "ruby/io.h"
- }
-+#define OpenFile rb_io_t
- %};
-@@ -49,7 +50,7 @@
-         VALUE *io = (VALUE *) prelude_msgbuf_get_data(fd);
-         GetOpenFile(*io, fptr);
--        f = fptr->f;
-+        f = fptr->stdio_file;
-         ret = fwrite((const char *) prelude_msg_get_message_data(msg), 1, prelude_msg_get_len(msg), f);
-         if ( ret != prelude_msg_get_len(msg) )
-@@ -69,7 +70,7 @@
-         VALUE *io = (VALUE *) prelude_io_get_fdptr(fd);
-         GetOpenFile(*io, fptr);
--        f = fptr->f;
-+        f = fptr->stdio_file;
-         ret = fread(buf, 1, size, f);
-         if ( ret < 0 )
-@@ -119,7 +120,7 @@
- VALUE IDMEFValueList_to_SWIG(const Prelude::IDMEFValue &value)
- {
-         VALUE ary;
--        int ret, j = 0;
-+        int ret;
-         std::vector<Prelude::IDMEFValue> result = value;
-         std::vector<Prelude::IDMEFValue>::const_iterator i;
-@@ -132,11 +133,9 @@
-                 if ( ret < 0 )
-                         return Qnil;
--                RARRAY(ary)->ptr[j++] = val;
-+                rb_ary_push(ary, val);
-         }
--        RARRAY(ary)->len = result.size();
--
-         return ary;
- }
- }
-@@ -166,7 +165,7 @@
-         __initial_thread = (gl_thread_t) gl_thread_self();
-         rbargv = rb_const_get(rb_cObject, rb_intern("ARGV"));
--        argc = RARRAY(rbargv)->len + 1;
-+        argc = RARRAY_LEN(rbargv) + 1;
-         if ( argc + 1 < 0 )
-                 throw PreludeError("Invalid argc length");
-@@ -175,11 +174,12 @@
-         if ( ! argv )
-                 throw PreludeError("Allocation failure");
--        argv[0] = STR2CSTR(rb_gv_get("$0"));
-+        VALUE argv0 = rb_gv_get("$0");
-+        argv[0] = StringValuePtr(argv0);
--        ptr = RARRAY(rbargv)->ptr;
--        for ( ptr = RARRAY(rbargv)->ptr, _i = 1; _i < argc; _i++, ptr++ )
--                argv[_i] =  STR2CSTR(*ptr);
-+        ptr = RARRAY_PTR(rbargv);
-+        for ( ptr = RARRAY_PTR(rbargv), _i = 1; _i < argc; _i++, ptr++ )
-+                argv[_i] =  StringValuePtr(*ptr);
-         argv[_i] = NULL;
index dd542e4994e078e02b54491fd6b5ab41647f7f43..f17d4b507402d465bc29f08d7378c40492e4c5e5 100644 (file)
@@ -1,30 +1,24 @@
 #
 # Conditional build:
-%bcond_without lua     # Lua (5.1) bindings
-%bcond_without perl    # Perl bindings
-%bcond_without python  # Python bindings (required by prewikka)
-%bcond_without ruby    # Ruby bindings
+%bcond_without lua             # Lua (5.1) bindings
+%bcond_without perl            # Perl bindings
+%bcond_without python2         # Python 2.x bindings (required by prewikka)
+%bcond_without python3         # Python 3.x bindings
+%bcond_without ruby            # Ruby bindings
+%bcond_without static_libs     # static libraries
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       The Prelude library
 Summary(pl.UTF-8):     Biblioteka Prelude
 Name:          libprelude
-Version:       1.0.1
-Release:       13
+Version:       1.2.6
+Release:       1
 License:       GPL v2 or commercial
 Group:         Libraries
 # https://www.prelude-ids.org/projects/prelude/files
-Source0:       https://www.prelude-ids.org/attachments/download/241/%{name}-%{version}.tar.gz
-# Source0-md5: dce1ea9f82cf436830567894e7ee622f
-Patch0:                %{name}-libtool.patch
-Patch1:                %{name}-ruby.patch
-Patch2:                %{name}-gnutls.patch
-Patch3:                %{name}-gets.patch
-Patch4:                %{name}-python.patch
-Patch5:                format-security.patch
-Patch6:                python-install.patch
-Patch7:                gcc5.patch
-Patch8:                swig.patch
+Source0:       https://www.prelude-ids.org/attachments/download/410/%{name}-%{version}.tar.gz
+# Source0-md5: 6a5aa32864ca6d74e1c7af0cdab7bf40
+Patch0:                python-install.patch
 URL:           http://www.prelude-ids.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -38,7 +32,8 @@ BuildRequires:        libstdc++-devel
 BuildRequires: libtool >= 2:2.0
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 %{?with_perl:BuildRequires:    perl-devel}
-%{?with_python:BuildRequires:  python-devel >= 1:2.5}
+%{?with_python2:BuildRequires: python-devel >= 1:2.5}
+%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
 BuildRequires: rpm-perlprov
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
@@ -165,6 +160,7 @@ Summary:    Prelude Perl module - low-level Perl binding for libprelude
 Summary(pl.UTF-8):     Moduł Perla Prelude - niskopoziomowe wiązanie Perla do libprelude
 Group:         Development/Languages/Perl
 Requires:      %{name}-libs = %{version}-%{release}
+Obsoletes:     perl-PreludeEasy
 
 %description -n perl-libprelude
 Prelude Perl module - low-level Perl binding for libprelude.
@@ -172,41 +168,30 @@ Prelude Perl module - low-level Perl binding for libprelude.
 %description -n perl-libprelude -l pl.UTF-8
 Moduł Perla Prelude - niskopoziomowe wiązanie Perla do libprelude.
 
-%package -n perl-PreludeEasy
-Summary:       PreludeEasy - high-level Perl binding for libprelude
-Summary(pl.UTF-8):     PreludeEasy - wysokopoziomowe wiązanie Perla do libprelude
-Group:         Development/Languages/Perl
-Requires:      %{name}-c++ = %{version}-%{release}
-
-%description -n perl-PreludeEasy
-PreludeEasy - high-level Perl binding for libprelude.
-
-%description -n perl-PreludeEasy -l pl.UTF-8
-PreludeEasy - wysokopoziomowe wiązanie Perla do libprelude.
-
 %package -n python-libprelude
-Summary:       Low-level Python binding for libprelude
-Summary(pl.UTF-8):     Niskopoziomowe wiązanie Pythona do libprelude
+Summary:       Low-level Python 2.x binding for libprelude
+Summary(pl.UTF-8):     Niskopoziomowe wiązanie Pythona 2.x do libprelude
 Group:         Development/Languages/Python
 Requires:      %{name}-libs = %{version}-%{release}
+Obsoletes:     python-PreludeEasy
 
 %description -n python-libprelude
-Low-level Python binding for libprelude.
+Low-level Python 2.x binding for libprelude.
 
 %description -n python-libprelude -l pl.UTF-8
-Niskopoziomowe wiązanie Pythona do libprelude.
+Niskopoziomowe wiązanie Pythona 2.x do libprelude.
 
-%package -n python-PreludeEasy
-Summary:       PreludeEasy - high-level Python binding for libprelude
-Summary(pl.UTF-8):     PreludeEasy - wysokopoziomowe wiązanie Pythona do libprelude
+%package -n python3-libprelude
+Summary:       Low-level Python 3.x binding for libprelude
+Summary(pl.UTF-8):     Niskopoziomowe wiązanie Pythona 3.x do libprelude
 Group:         Development/Languages/Python
-Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n python-PreludeEasy
-PreludeEasy - high-level Python binding for libprelude.
+%description -n python3-libprelude
+Low-level Python 3.x binding for libprelude.
 
-%description -n python-PreludeEasy -l pl.UTF-8
-PreludeEasy - wysokopoziomowe wiązanie Pythona do libprelude.
+%description -n python3-libprelude -l pl.UTF-8
+Niskopoziomowe wiązanie Pythona 3.x do libprelude.
 
 %package -n ruby-prelude
 Summary:       PreludeEasy - libprelude Ruby bindings
@@ -224,29 +209,12 @@ PreludeEasy - dowiązania języka Ruby do libprelude.
 %setup -q
 %patch0 -p1
 
-%if %{with python}
-# regenerate with fresh swig for gcc 4.6+
-%{__rm} bindings/python/{_PreludeEasy.cxx,PreludeEasy.py}
+%if %{with python3}
+# regenerate with fresh swig for python 3.5+
+%{__rm} bindings/python/{_prelude.cxx,prelude.py}
 %endif
-%if %{with ruby}
-# same for ruby 1.9
-%{__rm} bindings/ruby/PreludeEasy.cxx
-%patch1 -p1
-%endif
-%if %{with perl}
-# regenerate with fresh swig for perl 5.20
-%{__rm} bindings/low-level/perl/Prelude.c
-%endif
-
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
 
-sed -i -e 's/lua >= 5.1/lua51 >= 5.1/' configure.in
+%{__sed} -i -e 's/lua >= 5.1/lua51 >= 5.1/;s/lua -e/lua5.1 -e/' configure.in
 
 %build
 %{__libtoolize}
@@ -257,42 +225,51 @@ sed -i -e 's/lua >= 5.1/lua51 >= 5.1/' configure.in
 %configure \
        am_cv_ruby_rbexecdir=%{ruby_vendorarchdir} \
        --enable-gtk-doc \
-       --enable-static \
-       --with%{!?with_lua:out}-lua \
-       --with%{!?with_perl:out}-perl \
-       --with%{!?with_python:out}-python \
+       %{?with_static_libs:--enable-static} \
        --with-html-dir=%{_gtkdocdir}/libprelude \
-       --with-perl-installdirs=vendor
+       --with-lua%{!?with_lua:=no} \
+       --with-perl%{!?with_perl:=no} \
+       --with-perl-installdirs=vendor \
+       --with-python%{!?with_python2:=no} \
+       --with-python3%{!?with_python3:=no} \
+       --with-swig
 
 %{__make}
 
-cd bindings/perl
-%{__make} clean
-%{__perl} Makefile.PL \
-        INSTALLDIRS=vendor \
-%{__make}
+#cd bindings/perl
+#%{__make} clean
+#%{__perl} Makefile.PL \
+#        INSTALLDIRS=vendor \
+#%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       pythondir=%{py_sitescriptdir} \
+       pyexecdir=%{py_sitedir} \
+       python3dir=%{py3_sitescriptdir} \
+       py3execdir=%{py3_sitedir}
 
-%{__make} -C bindings/perl install \
-       DESTDIR=$RPM_BUILD_ROOT
+#%{__make} -C bindings/perl install \
+#      DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with lua}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/PreludeEasy.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lua/5.1/prelude.la \
+       %{?with_static_libs:$RPM_BUILD_ROOT%{_libdir}/lua/5.1/prelude.a}
 %endif
-%if %{with python}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%if %{with python2}
 %py_postclean
 %endif
 %if %{with ruby}
-%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/PreludeEasy.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/Prelude.la \
+       %{?with_static_libs:$RPM_BUILD_ROOT%{ruby_vendorarchdir}/Prelude.a}
 %endif
 
+# not useful in distro? (or -swig?)
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/libprelude/swig
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -319,7 +296,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libprelude.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprelude.so.2
+%attr(755,root,root) %ghost %{_libdir}/libprelude.so.23
 
 %files devel
 %defattr(644,root,root,755)
@@ -332,14 +309,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_gtkdocdir}/libprelude
 %{_pkgconfigdir}/libprelude.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libprelude.a
+%endif
 
 %files c++
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpreludecpp.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpreludecpp.so.0
+%attr(755,root,root) %ghost %{_libdir}/libpreludecpp.so.8
 
 %files c++-devel
 %defattr(644,root,root,755)
@@ -348,14 +327,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libprelude/idmef*.hxx
 %{_includedir}/libprelude/prelude*.hxx
 
+%if %{with static_libs}
 %files c++-static
 %defattr(644,root,root,755)
 %{_libdir}/libpreludecpp.a
+%endif
 
 %if %{with lua}
 %files -n lua-prelude
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/PreludeEasy.so
+%attr(755,root,root) %{_libdir}/lua/5.1/prelude.so
 %endif
 
 %if %{with perl}
@@ -364,30 +345,27 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/Prelude.pm
 %dir %{perl_vendorarch}/auto/Prelude
 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/Prelude.so
-
-%files -n perl-PreludeEasy
-%defattr(644,root,root,755)
-%{perl_vendorarch}/PreludeEasy.pm
-%dir %{perl_vendorarch}/auto/PreludeEasy
-%attr(755,root,root) %{perl_vendorarch}/auto/PreludeEasy/PreludeEasy.so
 %endif
 
-%if %{with python}
+%if %{with python2}
 %files -n python-libprelude
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/_prelude.so
 %{py_sitedir}/prelude.py[co]
 %{py_sitedir}/prelude-%{version}-py*.egg-info
+%endif
 
-%files -n python-PreludeEasy
+%if %{with python3}
+%files -n python3-libprelude
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/_PreludeEasy.so
-%{py_sitedir}/PreludeEasy.py[co]
-%{py_sitedir}/PreludeEasy-%{version}-py*.egg-info
+%attr(755,root,root) %{py3_sitedir}/_prelude.cpython-*.so
+%{py3_sitedir}/prelude.py
+%{py3_sitedir}/__pycache__/prelude.cpython-*.py[co]
+%{py3_sitedir}/prelude-%{version}-py*.egg-info
 %endif
 
 %if %{with ruby}
 %files -n ruby-prelude
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_vendorarchdir}/PreludeEasy.so
+%attr(755,root,root) %{ruby_vendorarchdir}/Prelude.so
 %endif
index 30d04922bc89e153e8ebce964a6a32181b818060..376e8887f462c2896b0511ec98fccf867fb20723 100644 (file)
@@ -1,22 +1,24 @@
---- libprelude-1.0.1/bindings/low-level/python/Makefile.am~    2012-04-02 11:41:15.000000000 +0200
-+++ libprelude-1.0.1/bindings/low-level/python/Makefile.am     2015-12-27 20:54:02.339946498 +0100
-@@ -8,7 +8,7 @@
-       CC="$(BINDINGS_CC)" $(PYTHON) setup.py build
+--- libprelude-1.2.6/bindings/python/Makefile.am.orig  2016-01-31 13:45:31.756628496 +0100
++++ libprelude-1.2.6/bindings/python/Makefile.am       2016-01-31 13:57:00.426599591 +0100
+@@ -10,17 +10,17 @@
  
+ python-build: _prelude.cxx
+ if HAVE_PYTHON2
+-      CC="$(CXX)" $(PYTHON2) setup.py build
++      CC="$(CXX)" $(PYTHON2) setup.py build --build-base=build-2
+ endif
+ if HAVE_PYTHON3
+-      CC="$(CXX)" $(PYTHON3) setup.py build
++      CC="$(CXX)" $(PYTHON3) setup.py build --build-base=build-3
+ endif
  install-exec-hook:
--      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
-+      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --prefix=$(prefix)
- uninstall-hook: 
-       $(PYTHON) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
---- libprelude-1.0.1/bindings/python/Makefile.am~      2012-04-02 11:41:15.000000000 +0200
-+++ libprelude-1.0.1/bindings/python/Makefile.am       2015-12-27 20:53:20.153594859 +0100
-@@ -9,7 +9,7 @@
-       CC="$(CXX)" $(PYTHON) setup.py build
- install-exec-hook:
--      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
-+      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --prefix=$(prefix)
+ if HAVE_PYTHON2
+-      $(PYTHON2) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
++      $(PYTHON2) setup.py build --build-base=build-2 install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --skip-build --prefix=$(prefix) --install-purelib=$(pythondir) --install-platlib=$(pyexecdir) --optimize=2
+ endif
+ if HAVE_PYTHON3
+-      $(PYTHON3) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
++      $(PYTHON3) setup.py build --build-base=build-3 install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --skip-build --prefix=$(prefix) --install-purelib=$(python3dir) --install-platlib=$(py3execdir) --optimize=2
+ endif
  
  uninstall-hook:
-       $(PYTHON) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
diff --git a/swig.patch b/swig.patch
deleted file mode 100644 (file)
index f0ea147..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- libprelude-1.0.1/bindings/lua/libpreludecpp-lua.i~ 2012-06-01 17:12:00.000000000 +0200
-+++ libprelude-1.0.1/bindings/lua/libpreludecpp-lua.i  2015-12-27 21:26:09.568086198 +0100
-@@ -21,12 +21,10 @@
- *
- *****/
--# Exception map
- %typemap(throws) Prelude::PreludeError %{
-         SWIG_exception(SWIG_RuntimeError, $1.what());
- %};
--# Lua overloading fixes
- %ignore IDMEFCriteria(std::string const &);
- %ignore IDMEFValue(int8_t);
- %ignore IDMEFValue(uint8_t);
-@@ -59,7 +57,6 @@
- %ignore Set(char const *, float);
- %ignore Set(char const *, std::string);
--# Conversion not allowed
- %ignore *::operator =;
- %ignore *::operator int() const;
---- libprelude-1.0.1/bindings/perl/libpreludecpp-perl.i~       2012-06-01 17:12:00.000000000 +0200
-+++ libprelude-1.0.1/bindings/perl/libpreludecpp-perl.i        2015-12-27 21:28:22.063879316 +0100
-@@ -21,13 +21,11 @@
- *
- *****/
--# Exception map
- %typemap(throws) Prelude::PreludeError %{
-         SWIG_exception(SWIG_RuntimeError, $1.what());
- %};
--# Conversion not allowed
- %ignore *::operator =;
- %ignore *::operator int() const;
- %ignore *::operator long() const;
This page took 0.092019 seconds and 4 git commands to generate.