]> git.pld-linux.org Git - packages/libprelude.git/commitdiff
- fix building with gcc 5.x auto/th/libprelude-1.0.1-13
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Dec 2015 23:12:07 +0000 (00:12 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Dec 2015 23:12:07 +0000 (00:12 +0100)
- fix swig errors
- fix python ibstall paths
- rel 13

gcc5.patch [new file with mode: 0644]
libprelude.spec
python-install.patch [new file with mode: 0644]
swig.patch [new file with mode: 0644]

diff --git a/gcc5.patch b/gcc5.patch
new file mode 100644 (file)
index 0000000..e301393
--- /dev/null
@@ -0,0 +1,13 @@
+Index: b/src/libprelude-error/Makefile.am
+===================================================================
+--- a/src/libprelude-error/Makefile.am
++++ b/src/libprelude-error/Makefile.am
+@@ -40,7 +40,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
+ mkerrcodes.h: Makefile mkerrcodes.awk
+       LANG="" $(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
+-      $(CPP) _$@ | grep PRELUDE_ERROR_ | LANG="" $(AWK) -f $(srcdir)/mkerrcodes.awk >$@
++      $(CPP) -P _$@ | grep PRELUDE_ERROR_ | LANG="" $(AWK) -f $(srcdir)/mkerrcodes.awk >$@
+       -rm _$@
+ # It is correct to use $(CC_FOR_BUILD) here.  We want to run the
index 2b13886056f30092d514f501b1aeda2bb0cf8b98..dd542e4994e078e02b54491fd6b5ab41647f7f43 100644 (file)
@@ -10,7 +10,7 @@ Summary:      The Prelude library
 Summary(pl.UTF-8):     Biblioteka Prelude
 Name:          libprelude
 Version:       1.0.1
-Release:       12
+Release:       13
 License:       GPL v2 or commercial
 Group:         Libraries
 # https://www.prelude-ids.org/projects/prelude/files
@@ -22,6 +22,9 @@ Patch2:               %{name}-gnutls.patch
 Patch3:                %{name}-gets.patch
 Patch4:                %{name}-python.patch
 Patch5:                format-security.patch
+Patch6:                python-install.patch
+Patch7:                gcc5.patch
+Patch8:                swig.patch
 URL:           http://www.prelude-ids.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -239,6 +242,9 @@ PreludeEasy - dowiązania języka Ruby do libprelude.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 sed -i -e 's/lua >= 5.1/lua51 >= 5.1/' configure.in
 
diff --git a/python-install.patch b/python-install.patch
new file mode 100644 (file)
index 0000000..30d0492
--- /dev/null
@@ -0,0 +1,22 @@
+--- libprelude-1.0.1/bindings/low-level/python/Makefile.am~    2012-04-02 11:41:15.000000000 +0200
++++ libprelude-1.0.1/bindings/low-level/python/Makefile.am     2015-12-27 20:54:02.339946498 +0100
+@@ -8,7 +8,7 @@
+       CC="$(BINDINGS_CC)" $(PYTHON) setup.py build
+ install-exec-hook:
+-      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
++      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --prefix=$(prefix)
+ uninstall-hook: 
+       $(PYTHON) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+--- libprelude-1.0.1/bindings/python/Makefile.am~      2012-04-02 11:41:15.000000000 +0200
++++ libprelude-1.0.1/bindings/python/Makefile.am       2015-12-27 20:53:20.153594859 +0100
+@@ -9,7 +9,7 @@
+       CC="$(CXX)" $(PYTHON) setup.py build
+ install-exec-hook:
+-      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
++      $(PYTHON) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` --prefix=$(prefix)
+ uninstall-hook:
+       $(PYTHON) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
diff --git a/swig.patch b/swig.patch
new file mode 100644 (file)
index 0000000..f0ea147
--- /dev/null
@@ -0,0 +1,39 @@
+--- libprelude-1.0.1/bindings/lua/libpreludecpp-lua.i~ 2012-06-01 17:12:00.000000000 +0200
++++ libprelude-1.0.1/bindings/lua/libpreludecpp-lua.i  2015-12-27 21:26:09.568086198 +0100
+@@ -21,12 +21,10 @@
+ *
+ *****/
+-# Exception map
+ %typemap(throws) Prelude::PreludeError %{
+         SWIG_exception(SWIG_RuntimeError, $1.what());
+ %};
+-# Lua overloading fixes
+ %ignore IDMEFCriteria(std::string const &);
+ %ignore IDMEFValue(int8_t);
+ %ignore IDMEFValue(uint8_t);
+@@ -59,7 +57,6 @@
+ %ignore Set(char const *, float);
+ %ignore Set(char const *, std::string);
+-# Conversion not allowed
+ %ignore *::operator =;
+ %ignore *::operator int() const;
+--- libprelude-1.0.1/bindings/perl/libpreludecpp-perl.i~       2012-06-01 17:12:00.000000000 +0200
++++ libprelude-1.0.1/bindings/perl/libpreludecpp-perl.i        2015-12-27 21:28:22.063879316 +0100
+@@ -21,13 +21,11 @@
+ *
+ *****/
+-# Exception map
+ %typemap(throws) Prelude::PreludeError %{
+         SWIG_exception(SWIG_RuntimeError, $1.what());
+ %};
+-# Conversion not allowed
+ %ignore *::operator =;
+ %ignore *::operator int() const;
+ %ignore *::operator long() const;
This page took 0.03782 seconds and 4 git commands to generate.