]> git.pld-linux.org Git - packages/libnsgif.git/blob - libnsgif.spec
- new
[packages/libnsgif.git] / libnsgif.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Decoding library for the GIF format
6 Name:           libnsgif
7 Version:        0.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  f3d4295be77db30da1f4167b270bb4d9
13 URL:            http://www.netsurf-browser.org/projects/libnsgif/
14 BuildRequires:  netsurf-buildsystem
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Libnsgif is a decoding library for the GIF image file format, written
19 in C. It was developed as part of the NetSurf project and is available
20 for use by other software under the MIT licence.
21
22 %package devel
23 Summary:        libsgif library headers
24 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsgif
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27
28 %description devel
29 This is the libraries, include files and other resources you can use
30 to incorporate libnsgif into applications.
31
32 %description devel -l pl.UTF-8
33 Pliki nagłówkowe pozwalające na używanie biblioteki libnsgif w swoich
34 programach.
35
36 %package static
37 Summary:        libnsgif static libraries
38 Summary(pl.UTF-8):      Statyczne biblioteki libnsgif
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}-%{release}
41
42 %description static
43 This is package with static libnsgif libraries.
44
45 %description static -l pl.UTF-8
46 Statyczna biblioteka libnsgif.
47
48 %prep
49 %setup -q
50
51 %build
52 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared
53 %if %{with static_libs}
54 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT \
62         PREFIX=%{_prefix} \
63         COMPONENT_TYPE=lib-shared
64
65 %if %{with static_libs}
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT \
68         PREFIX=%{_prefix} \
69         COMPONENT_TYPE=lib-static
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %{_includedir}/*.h
86 %{_pkgconfigdir}/*pc
87
88 %if %{with static_libs}
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/lib*.a
92 %endif
This page took 0.0938369999999999 seconds and 3 git commands to generate.