]> git.pld-linux.org Git - packages/libnsgif.git/blob - libnsgif.spec
- updated to 1.0.0
[packages/libnsgif.git] / libnsgif.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Decoding library for the GIF format
6 Summary(pl.UTF-8):      Biblioteka dekodująca pliki w formacie GIF
7 Name:           libnsgif
8 Version:        1.0.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  ec8d24735fdd06d674ff9e4e9482b804
14 URL:            http://www.netsurf-browser.org/projects/libnsgif/
15 BuildRequires:  netsurf-buildsystem >= 1.7
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Libnsgif is a decoding library for the GIF image file format, written
20 in C. It was developed as part of the NetSurf project and is available
21 for use by other software under the MIT licence.
22
23 %description -l pl.UTF-8
24 Libnsgif to napisana w C biblioteka dekodująca pliki obrazów w
25 formacie GIF. Powstała jako część projektu NetSurf i jest dostępna do
26 wykorzystania przez inne programy na licencji MIT.
27
28 %package devel
29 Summary:        libsgif library headers
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsgif
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 This package contains the include files and other resources you can
36 use to incorporate libnsgif into applications.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe pozwalające na używanie biblioteki libnsgif w swoich
40 programach.
41
42 %package static
43 Summary:        libnsgif static library
44 Summary(pl.UTF-8):      Statyczna biblioteka libnsgif
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 This is package with static libnsgif library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka libnsgif.
53
54 %prep
55 %setup -q
56
57 %build
58 export AR="%{__ar}"
59 export CC="%{__cc}"
60 export CFLAGS="%{rpmcflags}"
61 export LDFLAGS="%{rpmldflags}"
62
63 %{__make} \
64         Q= \
65         PREFIX=%{_prefix} \
66         COMPONENT_TYPE=lib-shared
67
68 %if %{with static_libs}
69 %{__make} \
70         Q= \
71         PREFIX=%{_prefix} \
72         COMPONENT_TYPE=lib-static
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 export AR="%{__ar}"
79 export CC="%{__cc}"
80 export CFLAGS="%{rpmcflags}"
81 export LDFLAGS="%{rpmldflags}"
82
83 %{__make} install \
84         PREFIX=%{_prefix} \
85         LIBDIR=%{_lib} \
86         COMPONENT_TYPE=lib-shared \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %if %{with static_libs}
90 %{__make} install \
91         PREFIX=%{_prefix} \
92         LIBDIR=%{_lib} \
93         COMPONENT_TYPE=lib-static \
94         DESTDIR=$RPM_BUILD_ROOT
95 %endif
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc COPYING
106 %attr(755,root,root) %{_libdir}/libnsgif.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libnsgif.so.1
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libnsgif.so
112 %{_includedir}/nsgif.h
113 %{_pkgconfigdir}/libnsgif.pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libnsgif.a
119 %endif
This page took 0.086509 seconds and 4 git commands to generate.