]> git.pld-linux.org Git - packages/kodi.git/commitdiff
- upstream fix for ffmpeg 2.2 auto/th/xbmc-12.3-3
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 25 Mar 2014 12:36:43 +0000 (13:36 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 25 Mar 2014 12:36:43 +0000 (13:36 +0100)
- rel 3

ffmpeg2.2.patch [new file with mode: 0644]
xbmc.spec

diff --git a/ffmpeg2.2.patch b/ffmpeg2.2.patch
new file mode 100644 (file)
index 0000000..d880e17
--- /dev/null
@@ -0,0 +1,31 @@
+From 632475b20822b010cf18255ce41530ac490cd118 Mon Sep 17 00:00:00 2001
+From: Georgi Chorbadzhiyski <gf@unixsol.org>
+Date: Fri, 20 Dec 2013 00:25:34 +0200
+Subject: [PATCH] Fix compilation error related to removed structure field by
+ ffmpeg.
+
+ffmpeg removed reference_dts field in struct AVStream.
+
+Related ffmpeg commit:
+  http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=2ba68dd044ca8fc591139c05563840f546a9c0c0
+---
+ lib/xbmc-dll-symbols/DllAvFormat.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/lib/xbmc-dll-symbols/DllAvFormat.c b/lib/xbmc-dll-symbols/DllAvFormat.c
+index 4b09663..a592a1f 100644
+--- a/lib/xbmc-dll-symbols/DllAvFormat.c
++++ b/lib/xbmc-dll-symbols/DllAvFormat.c
+@@ -112,7 +112,9 @@ void xbmc_read_frame_flush(AVFormatContext *s)
+ #define RELATIVE_TS_BASE (INT64_MAX - (1LL<<48))
+         if(st->first_dts == AV_NOPTS_VALUE) st->cur_dts = RELATIVE_TS_BASE;
+         else                                st->cur_dts = AV_NOPTS_VALUE; /* we set the current DTS to an unspecified origin */
++#if LIBAVFORMAT_VERSION_INT < AV_VERSION_INT(55,0,0)
+         st->reference_dts = AV_NOPTS_VALUE;
++#endif
+         st->probe_packets = MAX_PROBE_PACKETS;
+ #endif
+-- 
+1.8.5.5
+
index d01ae505bb82f30ac0747f61302bdffbef1b5680..eaf53b8fddd0b501dcd2f9b83a22b4f01d001e71 100644 (file)
--- a/xbmc.spec
+++ b/xbmc.spec
@@ -15,7 +15,7 @@
 Summary:       XBMC is a free and open source media-player and entertainment hub
 Name:          xbmc
 Version:       12.3
-Release:       2
+Release:       3
 License:       GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 Source0:       http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
@@ -24,6 +24,7 @@ Patch0:               ffmpeg2.patch
 Patch1:                jpeglib-boolean.patch
 Patch2:                %{name}-vdpau.patch
 Patch3:                smbclient.patch
+Patch4:                ffmpeg2.2.patch
 URL:           http://xbmc.org/
 BuildRequires: Mesa-libGLU-devel
 BuildRequires: OpenGL-devel
@@ -135,6 +136,7 @@ forecast functions, together third-party plugins.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 ./bootstrap
This page took 0.331912 seconds and 4 git commands to generate.