]> git.pld-linux.org Git - packages/kodi.git/blob - xbmc.spec
- upstream fix for ffmpeg 2.2
[packages/kodi.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 %define codename Frodo
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        12.3
18 Release:        3
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  7ae385ebf8e5cfcb917393235e6efbdb
23 Patch0:         ffmpeg2.patch
24 Patch1:         jpeglib-boolean.patch
25 Patch2:         %{name}-vdpau.patch
26 Patch3:         smbclient.patch
27 Patch4:         ffmpeg2.2.patch
28 URL:            http://xbmc.org/
29 BuildRequires:  Mesa-libGLU-devel
30 BuildRequires:  OpenGL-devel
31 BuildRequires:  SDL_image-devel
32 BuildRequires:  SDL_mixer-devel
33 BuildRequires:  alsa-lib-devel
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  avahi-devel
37 BuildRequires:  bluez-libs-devel >= 4.99
38 BuildRequires:  boost-devel
39 BuildRequires:  bzip2-devel
40 BuildRequires:  cmake
41 BuildRequires:  curl-devel
42 BuildRequires:  dbus-devel
43 BuildRequires:  ffmpeg-devel
44 BuildRequires:  flac-devel
45 BuildRequires:  fontconfig-devel
46 BuildRequires:  freetype-devel
47 BuildRequires:  fribidi-devel
48 BuildRequires:  gawk
49 BuildRequires:  gettext-autopoint
50 BuildRequires:  gettext-devel
51 BuildRequires:  glew-devel
52 BuildRequires:  gperf
53 %{?with_hal:BuildRequires:      hal-devel}
54 BuildRequires:  jasper-devel
55 BuildRequires:  jre
56 BuildRequires:  libass-devel
57 BuildRequires:  libbluray-devel >= 0.2.1
58 BuildRequires:  libcap-devel
59 BuildRequires:  libcdio-devel
60 %{?with_cec:BuildRequires:      libcec-devel}
61 %ifarch i686 pentium4 athlon %{x8664}
62 BuildRequires:  libcrystalhd-devel
63 %endif
64 BuildRequires:  libgcrypt-devel
65 BuildRequires:  libjpeg-devel
66 BuildRequires:  libltdl-devel
67 BuildRequires:  libmad-devel
68 BuildRequires:  libmicrohttpd-devel
69 BuildRequires:  libmodplug-devel
70 BuildRequires:  libmpeg2-devel
71 BuildRequires:  libogg-devel
72 BuildRequires:  libplist-devel
73 BuildRequires:  libpng-devel
74 BuildRequires:  librtmp-devel
75 BuildRequires:  libsamplerate-devel
76 BuildRequires:  libsmbclient-devel
77 BuildRequires:  libssh-devel
78 BuildRequires:  libtiff-devel
79 BuildRequires:  libtool
80 BuildRequires:  libva-devel
81 BuildRequires:  libva-glx-devel
82 BuildRequires:  libvdpau-devel
83 BuildRequires:  libvorbis-devel
84 BuildRequires:  lzo-devel
85 BuildRequires:  mysql-devel
86 %ifarch %{ix86}
87 BuildRequires:  nasm
88 %endif
89 BuildRequires:  openssl-devel
90 BuildRequires:  pcre-cxx-devel
91 BuildRequires:  pkgconfig
92 BuildRequires:  pulseaudio-devel
93 BuildRequires:  python-devel >= 2.4
94 BuildRequires:  rpm-pythonprov
95 BuildRequires:  rpmbuild(macros) >= 1.566
96 # used internally
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  sqlite3-devel
99 BuildRequires:  swig
100 BuildRequires:  taglib-devel >= 1.8
101 BuildRequires:  tinyxml-devel
102 BuildRequires:  udev-devel
103 BuildRequires:  unzip
104 BuildRequires:  xorg-lib-libX11-devel
105 BuildRequires:  xorg-lib-libXext-devel
106 BuildRequires:  xorg-lib-libXinerama-devel
107 BuildRequires:  xorg-lib-libXmu-devel
108 BuildRequires:  xorg-lib-libXrandr-devel
109 BuildRequires:  xorg-lib-libXt-devel
110 BuildRequires:  xorg-lib-libXtst-devel
111 BuildRequires:  yajl-devel
112 BuildRequires:  zip
113 BuildRequires:  zlib-devel
114 #https://github.com/sahlberg/libnfs
115 #BuildRequires: libnfs-devel
116 #http://sites.google.com/site/alexthepuffin/home
117 #BuildRequires: afpfs-ng-devel
118 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
119 #https://github.com/albertz/shairport
120 #BuildRequires: libshairport
121 Requires:       /usr/bin/glxinfo
122 Requires:       SDL >= 1.2.14-5
123 Requires:       lsb-release
124 Requires:       xorg-app-xdpyinfo
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %description
128 XBMC media center is a free cross-platform media-player jukebox and
129 entertainment hub. XBMC can play a spectrum of of multimedia formats,
130 and featuring playlist, audio visualizations, slideshow, and weather
131 forecast functions, together third-party plugins.
132
133 %prep
134 %setup -q -n %{name}-%{version}-%{codename}
135 %patch0 -p1
136 %patch1 -p1
137 %patch2 -p1
138 %patch3 -p1
139 %patch4 -p1
140
141 %build
142 ./bootstrap
143 %configure \
144         --disable-debug \
145         --enable-external-libraries \
146         --enable-pulse \
147         --enable-udev \
148         --disable-libusb \
149         --disable-nfs \
150         --disable-afpclient \
151         --disable-airtunes \
152         %{__enable_disable goom} \
153         %{__enable_disable hal} \
154         %{__enable_disable libcec}
155
156 LIBS="-lpthread"
157 %{__make} V=1
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/*
170 %{_datadir}/%{name}
171 %attr(755,root,root) %{_libdir}/%{name}
172 %{_docdir}/%{name}
173 %{_desktopdir}/%{name}.desktop
174 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
175 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
176 %{_datadir}/xsessions/XBMC.desktop
This page took 0.166786 seconds and 3 git commands to generate.