- updated gcc5 patch to cover new issues auto/th/kodi-16.1-2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 11 Dec 2017 19:26:33 +0000 (20:26 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 11 Dec 2017 19:26:33 +0000 (20:26 +0100)
- updated some BRs
- release 2

gcc5.patch
kodi.spec

index 528fc20..07a76a2 100644 (file)
@@ -1,17 +1,38 @@
-diff -ur xbmc-15.0-Isengard.orig/xbmc/visualizations/XBMCProjectM/libprojectM/Common.hpp xbmc-15.0-Isengard/xbmc/visualizations/XBMCProjectM/libprojectM/Common.hpp
---- xbmc-15.0-Isengard.orig/xbmc/visualizations/XBMCProjectM/libprojectM/Common.hpp    2015-07-22 03:41:29.000000000 +0900
-+++ xbmc-15.0-Isengard/xbmc/visualizations/XBMCProjectM/libprojectM/Common.hpp 2016-03-31 21:46:24.945192642 +0900
-@@ -57,11 +57,11 @@
- #endif
-                        
- #ifdef LINUX
--#define projectM_isnan isnan
-+#define projectM_isnan std::isnan
- #endif
+--- xbmc-16.1-Jarvis/xbmc/filesystem/FTPParse.cpp.orig 2016-04-24 08:48:30.000000000 +0200
++++ xbmc-16.1-Jarvis/xbmc/filesystem/FTPParse.cpp      2017-12-11 17:11:03.079955624 +0100
+@@ -34,6 +34,8 @@
+ #include <cmath>
+ #include "FTPParse.h"
  
- #ifdef LINUX
--#define projectM_isnan isnan
-+#define projectM_isnan std::isnan
- #endif
++using std::string;
++
+ CFTPParse::CFTPParse()
+ {
+   m_flagtrycwd = 0;
+--- xbmc-16.1-Jarvis/lib/cximage-6.0/CxImage/ximadsp.cpp.orig  2016-04-24 08:48:30.000000000 +0200
++++ xbmc-16.1-Jarvis/lib/cximage-6.0/CxImage/ximadsp.cpp       2017-12-11 18:34:55.026753161 +0100
+@@ -3,12 +3,14 @@
+  * CxImage version 6.0.0 02/Feb/2008
+  */
  
- #ifdef WIN32
++#if CXIMAGE_SUPPORT_DSP
++// include <queue> before any local headers, as they define min/max as macros
++#include <queue>
++
+ #include "ximage.h"
+ #include "ximaiter.h"
+-#if CXIMAGE_SUPPORT_DSP
+-
+ ////////////////////////////////////////////////////////////////////////////////
+ /**
+  * Converts the image to B&W.
+@@ -3477,7 +3479,6 @@
+ }
+ ////////////////////////////////////////////////////////////////////////////////
+-#include <queue>
+ ////////////////////////////////////////////////////////////////////////////////
+ /**
+  * Flood Fill
index b63a4b8..a0b4a4f 100644 (file)
--- a/kodi.spec
+++ b/kodi.spec
@@ -56,7 +56,7 @@
 Summary:       Kodi is a free and open source media-player and entertainment hub
 Name:          kodi
 Version:       16.1
-Release:       1
+Release:       2
 License:       GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 #Source0:      http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
@@ -68,11 +68,11 @@ Patch2:             dvdread.patch
 Patch3:                ffmpeg3.patch
 Patch4:                gcc5.patch
 URL:           http://kodi.tv/
-BuildRequires: Mesa-libGLU-devel
+BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: SDL2-devel
 BuildRequires: alsa-lib-devel
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: avahi-devel
 BuildRequires: bluez-libs-devel >= 4.99
@@ -84,6 +84,7 @@ BuildRequires:        curl-devel
 BuildRequires: dbus-devel
 BuildRequires: dcadec-devel
 BuildRequires: doxygen
+# libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
 %{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 2.4.4}
 BuildRequires: flac-devel
 BuildRequires: fontconfig-devel
@@ -102,7 +103,8 @@ BuildRequires:      libass-devel
 BuildRequires: libbluray-devel >= 0.7.0
 BuildRequires: libcap-devel
 BuildRequires: libcdio-devel
-%{?with_libcec:BuildRequires:  libcec-devel >= 2.1.0}
+%{?with_libcec:BuildRequires:  libcec-devel >= 3.0.0}
+BuildRequires: libdrm-devel
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel}
 %ifarch i686 pentium4 athlon %{x8664}
 BuildRequires: libcrystalhd-devel
@@ -120,6 +122,7 @@ BuildRequires:      librtmp-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libsmbclient-devel
 BuildRequires: libssh-devel
+BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
 BuildRequires: libuuid-devel
@@ -127,6 +130,7 @@ BuildRequires:      libva-devel
 BuildRequires: libva-x11-devel
 BuildRequires: libvdpau-devel
 BuildRequires: libvorbis-devel
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxslt-devel
 BuildRequires: lzo-devel
 BuildRequires: mysql-devel
@@ -136,21 +140,21 @@ BuildRequires:    nasm
 BuildRequires: openssl-devel
 BuildRequires: pcre-cxx-devel
 BuildRequires: pkgconfig
-BuildRequires: pulseaudio-devel
-BuildRequires: python-devel >= 2.4
+BuildRequires: pulseaudio-devel >= 1.0
+BuildRequires: python-devel >= 1:2.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.566
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel
 BuildRequires: swig
 BuildRequires: taglib-devel >= 1.8
-BuildRequires: tinyxml-devel
+BuildRequires: tinyxml-devel >= 2.6.2
 BuildRequires: udev-devel
 BuildRequires: unzip
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXrandr-devel
-BuildRequires: yajl-devel
+BuildRequires: yajl-devel >= 2
 BuildRequires: zip
 BuildRequires: zlib-devel
 # kodi uses it's own, modified squish
@@ -159,9 +163,7 @@ BuildConflicts:     squish-devel
 BuildRequires: libnfs-devel
 #http://sites.google.com/site/alexthepuffin/home
 #BuildRequires:        afpfs-ng-devel
-#http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
-#https://github.com/albertz/shairport
-#BuildRequires: libshairport
+#BuildRequires:        shairplay-devel
 Requires:      /usr/bin/glxinfo
 Requires:      SDL >= 1.2.14-5
 Requires:      lsb-release
@@ -194,16 +196,16 @@ all common digital media files from local and network storage media.
 %patch1 -p1
 %{?with_system_dvdread:%patch2 -p1}
 %patch3 -p1
-#%patch4 -p1
+%patch4 -p1
 
-rm -r lib/cximage-6.0/zlib
-#rm -r lib/libhdhomerun
-rm -r lib/libmpeg2
-rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
-rm -r lib/libbluray
-rm -r lib/librtmp
-rm -r lib/win32
-%{?with_system_dvdread:rm -r lib/libdvd/libdvdread}
+%{__rm} -r lib/cximage-6.0/zlib
+#%{__rm} -r lib/libhdhomerun
+%{__rm} -r lib/libmpeg2
+%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
+%{__rm} -r lib/libbluray
+%{__rm} -r lib/librtmp
+%{__rm} -r lib/win32
+%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
 
 %if %{without system_ffmpeg}
 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
This page took 0.358702 seconds and 4 git commands to generate.