]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
b63a4b8e9617051ec19d434c7f491823a184855c
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  gl              # OpenGL rendering
17 %bcond_with     gtest           # configure Google Test Framework
18 %bcond_without  joystick        # SDL joystick support
19 %bcond_without  libcap          # libcap support
20 %bcond_with     libcec          # libcec support
21 %bcond_without  libgif          # gif support via libgif
22 %bcond_without  libusb          # libusb support
23 %bcond_with     mdnsembedded    # mDNSEmbedded support
24 %bcond_without  mysql           # MySQL
25 %bcond_without  nfs             # NFS support via libnfs
26 %bcond_without  non_free        # componentents with non-compliant licenses
27 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
28 %bcond_without  optical_drive   # optical drive
29 %bcond_without  projectm        # ProjectM visualisation
30 %bcond_without  pulse           # PulseAudio support
31 %bcond_without  rtmp            # RTMP support via librtmp
32 %bcond_without  samba           # SAMBA support
33 %bcond_without  sdl             # SDL
34 %bcond_without  ssh             # SSH SFTP support
35 %bcond_without  texturepacker   # texturepacker support
36 %bcond_without  udev            # udev support
37 %bcond_without  upnp            # UPnP support
38 %bcond_without  vaapi           # VAAPI decoding
39 %bcond_without  vdpau           # VDPAU decoding
40 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
41 %bcond_without  webserver       # webserver
42 %bcond_without  x11             # x11 'Linux Only'
43 %bcond_without  xrandr          # XRandR support
44 %bcond_with     asap_codec      # ASAP ADPCM support
45 %bcond_with     gles            # OpenGLES rendering
46 %bcond_without  libbluray       # libbluray support
47 %bcond_without  mid             # MID support
48 %bcond_with     profiling       # gprof profiling
49 %bcond_with     tegra           # Tegra2 arm
50 %bcond_with     wayland         # wayland
51 # System libs:
52 %bcond_without  system_ffmpeg   # build with system ffmpeg
53 %bcond_without  system_dvdread  # build with system dvdread
54
55 %define codename Jarvis
56 Summary:        Kodi is a free and open source media-player and entertainment hub
57 Name:           kodi
58 Version:        16.1
59 Release:        1
60 License:        GPL v2+ and GPL v3+
61 Group:          Applications/Multimedia
62 #Source0:       http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
63 Source0:        https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
64 # Source0-md5:  79358ad5f77f42c5498a9412d5a78dd5
65 Patch0:         jpeglib-boolean.patch
66 Patch1:         disable-static.patch
67 Patch2:         dvdread.patch
68 Patch3:         ffmpeg3.patch
69 Patch4:         gcc5.patch
70 URL:            http://kodi.tv/
71 BuildRequires:  Mesa-libGLU-devel
72 BuildRequires:  OpenGL-devel
73 BuildRequires:  SDL2-devel
74 BuildRequires:  alsa-lib-devel
75 BuildRequires:  autoconf
76 BuildRequires:  automake
77 BuildRequires:  avahi-devel
78 BuildRequires:  bluez-libs-devel >= 4.99
79 BuildRequires:  boost-devel
80 BuildRequires:  bzip2-devel
81 BuildRequires:  cmake
82 BuildRequires:  crossguid-devel
83 BuildRequires:  curl-devel
84 BuildRequires:  dbus-devel
85 BuildRequires:  dcadec-devel
86 BuildRequires:  doxygen
87 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
88 BuildRequires:  flac-devel
89 BuildRequires:  fontconfig-devel
90 BuildRequires:  freetype-devel
91 BuildRequires:  fribidi-devel
92 BuildRequires:  gawk
93 BuildRequires:  gettext-autopoint
94 BuildRequires:  gettext-tools
95 BuildRequires:  giflib-devel
96 %{?with_libgif:BuildRequires:   giflib-devel}
97 BuildRequires:  glew-devel
98 BuildRequires:  gperf
99 BuildRequires:  jasper-devel
100 BuildRequires:  jre
101 BuildRequires:  libass-devel
102 BuildRequires:  libbluray-devel >= 0.7.0
103 BuildRequires:  libcap-devel
104 BuildRequires:  libcdio-devel
105 %{?with_libcec:BuildRequires:   libcec-devel >= 2.1.0}
106 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
107 %ifarch i686 pentium4 athlon %{x8664}
108 BuildRequires:  libcrystalhd-devel
109 %endif
110 BuildRequires:  libgcrypt-devel
111 BuildRequires:  libjpeg-devel
112 BuildRequires:  libltdl-devel
113 BuildRequires:  libmicrohttpd-devel
114 BuildRequires:  libmodplug-devel
115 BuildRequires:  libmpeg2-devel
116 BuildRequires:  libogg-devel
117 BuildRequires:  libplist-devel
118 BuildRequires:  libpng-devel
119 BuildRequires:  librtmp-devel
120 BuildRequires:  libsamplerate-devel
121 BuildRequires:  libsmbclient-devel
122 BuildRequires:  libssh-devel
123 BuildRequires:  libtiff-devel
124 BuildRequires:  libtool
125 BuildRequires:  libuuid-devel
126 BuildRequires:  libva-devel
127 BuildRequires:  libva-x11-devel
128 BuildRequires:  libvdpau-devel
129 BuildRequires:  libvorbis-devel
130 BuildRequires:  libxslt-devel
131 BuildRequires:  lzo-devel
132 BuildRequires:  mysql-devel
133 %ifarch %{ix86}
134 BuildRequires:  nasm
135 %endif
136 BuildRequires:  openssl-devel
137 BuildRequires:  pcre-cxx-devel
138 BuildRequires:  pkgconfig
139 BuildRequires:  pulseaudio-devel
140 BuildRequires:  python-devel >= 2.4
141 BuildRequires:  rpm-pythonprov
142 BuildRequires:  rpmbuild(macros) >= 1.566
143 BuildRequires:  sed >= 4.0
144 BuildRequires:  sqlite3-devel
145 BuildRequires:  swig
146 BuildRequires:  taglib-devel >= 1.8
147 BuildRequires:  tinyxml-devel
148 BuildRequires:  udev-devel
149 BuildRequires:  unzip
150 BuildRequires:  xorg-lib-libX11-devel
151 BuildRequires:  xorg-lib-libXext-devel
152 BuildRequires:  xorg-lib-libXrandr-devel
153 BuildRequires:  yajl-devel
154 BuildRequires:  zip
155 BuildRequires:  zlib-devel
156 # kodi uses it's own, modified squish
157 BuildConflicts: squish-devel
158 #https://github.com/sahlberg/libnfs
159 BuildRequires:  libnfs-devel
160 #http://sites.google.com/site/alexthepuffin/home
161 #BuildRequires: afpfs-ng-devel
162 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
163 #https://github.com/albertz/shairport
164 #BuildRequires: libshairport
165 Requires:       /usr/bin/glxinfo
166 Requires:       SDL >= 1.2.14-5
167 Requires:       lsb-release
168 Requires:       xorg-app-xdpyinfo
169 # dlopened libraries:
170 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
171 Requires:       curl-libs
172 Requires:       libass
173 Requires:       libbluray
174 Requires:       libmodplug
175 Requires:       libmpeg2-libs
176 Requires:       libogg
177 Requires:       libplist
178 Requires:       libvorbis
179 Obsoletes:      xbmc < 14.0
180 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
181
182 %description
183 Kodi Entertainment Center (formerly XBMC) is a free and open-source
184 media player software developed by the XBMC Foundation, a non-profit
185 technology consortium. Kodi is available for multiple operating
186 systems and hardware platforms, with a software 10-foot user interface
187 for use with televisions and remote controls. It allows users to play
188 and view most videos, music, such as podcasts from the internet, and
189 all common digital media files from local and network storage media.
190
191 %prep
192 %setup -q -n xbmc-%{version}-%{codename}
193 %patch0 -p1
194 %patch1 -p1
195 %{?with_system_dvdread:%patch2 -p1}
196 %patch3 -p1
197 #%patch4 -p1
198
199 rm -r lib/cximage-6.0/zlib
200 #rm -r lib/libhdhomerun
201 rm -r lib/libmpeg2
202 rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
203 rm -r lib/libbluray
204 rm -r lib/librtmp
205 rm -r lib/win32
206 %{?with_system_dvdread:rm -r lib/libdvd/libdvdread}
207
208 %if %{without system_ffmpeg}
209 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
210 %endif
211
212 %build
213 %{__make} -C tools/depends/native/libsquish-native \
214         CXX="%{__cxx}"
215
216 ./bootstrap
217 %configure \
218         ac_cv_type__Bool=yes \
219         --disable-silent-rules \
220         --disable-debug \
221         --disable-ccache \
222         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
223         %{__enable_disable afpclient} \
224         %{__enable_disable airplay} \
225         %{__enable_disable airtunes} \
226         %{__enable_disable alsa} \
227         %{__enable_disable asap_codec asap-codec} \
228         %{__enable_disable avahi} \
229         %{__enable_disable dbus} \
230         %{__enable_disable dvdcss} \
231         %{__enable_disable gles} \
232         %{__enable_disable gl} \
233         %{__enable_disable gtest} \
234         %{__enable_disable joystick} \
235         %{__enable_disable libbluray} \
236         %{__enable_disable libcap} \
237         %{__enable_disable libcec} \
238         %{__enable_disable libgif} \
239         %{__enable_disable libusb} \
240         %{__enable_disable mdnsembedded} \
241         %{__enable_disable mid} \
242         %{__enable_disable mysql} \
243         %{__enable_disable nfs} \
244         %{__enable_disable non_free non-free} \
245         %{__enable_disable openmax} \
246         %{__enable_disable optical_drive optical-drive} \
247         %{__enable_disable profiling} \
248         %{__enable_disable pulse} \
249         %{__enable_disable rtmp} \
250         %{__enable_disable samba} \
251         %{__enable_disable sdl} \
252         %{__enable_disable ssh} \
253         %{__enable_disable tegra} \
254         %{__enable_disable texturepacker} \
255         %{__enable_disable udev} \
256         %{__enable_disable upnp} \
257         %{__enable_disable vaapi} \
258         %{__enable_disable vdpau} \
259         %{__enable_disable vtbdecoder} \
260         %{__enable_disable wayland} \
261         %{__enable_disable webserver} \
262         %{__enable_disable x11} \
263         %{__enable_disable xrandr} \
264         %{nil}
265
266 %{__make} V=1
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 %{__make} install \
271         DESTDIR=$RPM_BUILD_ROOT
272
273 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
274
275 # no -devel package yet
276 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
277 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
278
279 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
280 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
281 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
282
283 %clean
284 rm -rf $RPM_BUILD_ROOT
285
286 %files
287 %defattr(644,root,root,755)
288 %doc README.md docs/README.linux
289 %attr(755,root,root) %{_bindir}/kodi
290 %attr(755,root,root) %{_bindir}/kodi-standalone
291 %{_datadir}/%{name}
292 %attr(755,root,root) %{_libdir}/%{name}
293 %{_desktopdir}/kodi.desktop
294 %{_iconsdir}/hicolor/*/apps/%{name}.png
295 %{_datadir}/xsessions/kodi.desktop
296
297 # legacy xbmc compatibility links
298 %attr(755,root,root) %{_bindir}/xbmc
299 %attr(755,root,root) %{_bindir}/xbmc-standalone
300 %{_datadir}/xsessions/xbmc.desktop
This page took 0.065663 seconds and 2 git commands to generate.