]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 3; fixed for xfs changes auto/th/kernel-4.19.2-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 21 Nov 2018 10:57:02 +0000 (11:57 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 21 Nov 2018 10:57:02 +0000 (11:57 +0100)
kernel-small_fixes.patch
kernel.spec

index 5ef9dd5e54ea0bd1541d899c41dee2828f50eead..b97c7aafdb86c3ebfb2d414fc39ae3dc41fbbff6 100644 (file)
@@ -13,10 +13,8 @@ Signed-off-by: Shaohua Li <shli@fb.com>
  fs/xfs/xfs_super.c | 1 +
  2 files changed, 3 insertions(+)
 
-diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
-index f18e593..6535054 100644
---- a/fs/xfs/xfs_aops.c
-+++ b/fs/xfs/xfs_aops.c
+--- linux-4.19/fs/xfs/xfs_aops.c.org   2018-11-21 10:31:12.348955352 +0100
++++ linux-4.19/fs/xfs/xfs_aops.c       2018-11-21 10:34:35.241764742 +0100
 @@ -613,8 +613,10 @@ xfs_add_to_ioend(
                        list_add(&wpc->ioend->io_list, iolist);
                wpc->ioend = xfs_alloc_ioend(inode, wpc->io_type, offset,
@@ -24,7 +22,7 @@ index f18e593..6535054 100644
 +              wbc_init_bio(wbc, wpc->ioend->io_bio);
        }
  
-+      wbc_account_io(wbc, bh->b_page, bh->b_size);
++      wbc_account_io(wbc, page, len);
        if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff)) {
                if (iop)
                        atomic_inc(&iop->write_count);
index 2d4113b2e98181791623e8811ce3381352fc6849..e893d186afa336af4f34bdc78044fddc875a1e93 100644 (file)
@@ -67,7 +67,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             3
 %define                basever         4.19
 %define                postver         .2
 
This page took 0.059245 seconds and 4 git commands to generate.