]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 2; add cgroup writeback suport for xfs (not merged by upstream only due to... auto/th/kernel-4.19.2-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 20 Nov 2018 21:26:49 +0000 (22:26 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 20 Nov 2018 21:26:49 +0000 (22:26 +0100)
kernel-small_fixes.patch
kernel.spec

index 092bc2b04126100878530888e6b1b30602dce213..5ef9dd5e54ea0bd1541d899c41dee2828f50eead 100644 (file)
@@ -1 +1,42 @@
-;
+From: Shaohua Li <shli@fb.com>
+
+Basically this is a copy of commit 001e4a8775f6(ext4: implement cgroup
+writeback support). Tested with a fio test, verified writeback is
+throttled against cgroup io.max write bandwidth, also verified moving
+the fio test to another cgroup and the writeback is throttled against
+new cgroup setting.
+
+Cc: Tejun Heo <tj@kernel.org>
+Signed-off-by: Shaohua Li <shli@fb.com>
+---
+ fs/xfs/xfs_aops.c  | 2 ++
+ fs/xfs/xfs_super.c | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
+index f18e593..6535054 100644
+--- a/fs/xfs/xfs_aops.c
++++ b/fs/xfs/xfs_aops.c
+@@ -613,8 +613,10 @@ xfs_add_to_ioend(
+                       list_add(&wpc->ioend->io_list, iolist);
+               wpc->ioend = xfs_alloc_ioend(inode, wpc->io_type, offset,
+                               bdev, sector);
++              wbc_init_bio(wbc, wpc->ioend->io_bio);
+       }
++      wbc_account_io(wbc, bh->b_page, bh->b_size);
+       if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff)) {
+               if (iop)
+                       atomic_inc(&iop->write_count);
+diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
+index 584cf2d..aea3bc2 100644
+--- a/fs/xfs/xfs_super.c
++++ b/fs/xfs/xfs_super.c
+@@ -1634,6 +1634,7 @@ xfs_fs_fill_super(
+       sb->s_max_links = XFS_MAXLINK;
+       sb->s_time_gran = 1;
+       set_posix_acl_flag(sb);
++      sb->s_iflags |= SB_I_CGROUPWB;
+       /* version 5 superblocks support inode version counters. */
+       if (XFS_SB_VERSION_NUM(&mp->m_sb) == XFS_SB_VERSION_5)
index 693ab5130c00aa71650019b816150cfa7312d2a9..2d4113b2e98181791623e8811ce3381352fc6849 100644 (file)
@@ -67,7 +67,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
+%define                rel             2
 %define                basever         4.19
 %define                postver         .2
 
@@ -682,7 +682,7 @@ rm -f localversion-rt
 %endif # vanilla
 
 # Small fixes:
-#%patch2000 -p1
+%patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
 
This page took 0.074054 seconds and 4 git commands to generate.