]> git.pld-linux.org Git - packages/kde4-knetworkmanager.git/blame - kde4-knetworkmanager.spec
- rebuild for g++ ABI changes
[packages/kde4-knetworkmanager.git] / kde4-knetworkmanager.spec
CommitLineData
1083a40b 1#
a085f693 2# Conditional build:
3%bcond_with verbose # verbose build
4
7e7dd977 5%define qtver 4.6.4
a085f693 6%define origname networkmanagement
7
8Summary: Plasma applet that controls network via NetworkManager backend
9Name: kde4-knetworkmanager
c9777165 10Version: 0.9.0.12
69f84ce0 11Release: 2
d2cd6ab5 12Epoch: 1
a085f693 13License: GPL v2
14Group: X11/Applications
6248bc32 15# git clone git://anongit.kde.org/networkmanagement.git
7e7dd977 16# git checkout nm09 (until is merged to master)
c9777165
BZ
17Source0: https://download.kde.org/unstable/networkmanagement/%{version}/src/%{origname}-%{version}.tar.xz
18# Source0-md5: 3a2b0b8f3545727cf0ded82e82a936b8
8acc4eb8
JR
19Patch0: %{origname}-kill_rest_sr.patch
20Patch1: %{name}-solid.patch
21Patch2: openconnect7.patch
a085f693 22URL: http://en.opensuse.org/Projects/KNetworkManager
685f9e94 23BuildRequires: NetworkManager-devel >= 2:0.9.8
a085f693 24BuildRequires: Qt3Support-devel >= %{qtver}
25BuildRequires: QtCore-devel >= %{qtver}
26BuildRequires: QtDBus-devel >= %{qtver}
27BuildRequires: QtGui-devel >= %{qtver}
28BuildRequires: QtNetwork-devel >= %{qtver}
29BuildRequires: QtXml-devel >= %{qtver}
30BuildRequires: automoc4 >= 0.9.88
837ab99b 31BuildRequires: cmake >= 2.8.0
f09d4d3b
JR
32BuildRequires: kde4-kdebase-workspace-devel
33BuildRequires: kde4-kdelibs-devel
e60e58f6 34BuildRequires: mobile-broadband-provider-info-devel
7e7dd977
AM
35BuildRequires: openconnect-devel >= 3.12
36BuildRequires: openssl-devel
a085f693 37BuildRequires: qt4-build >= %{qtver}
38BuildRequires: qt4-qmake >= %{qtver}
39BuildRequires: rpmbuild(macros) >= 1.293
d2cd6ab5 40Requires: NetworkManager >= 2:0.9.0
a085f693 41Obsoletes: kde4-kdeplasma-addons-networkmanager
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Plasma applet that controls network via NetworkManager backend.
46
47%prep
6248bc32 48%setup -q -n %{origname}-%{version}
6a7387ce 49%patch0 -p1
fa70895a 50%patch1 -p1
c9777165 51#%patch2 -p1
a085f693 52
53%build
54install -d build
55cd build
56%cmake \
57 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
58 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
59 %{?with_verbose:-DCMAKE_VERBOSE_MAKEFILE=true} \
60 -DDBUS_SYSTEM_POLICY_DIR=/etc/dbus-1/system.d \
61%if "%{_lib}" != "lib"
62 -DLIB_SUFFIX=64 \
63%endif
64 ../
65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71%{__make} -C build install \
72 DESTDIR=$RPM_BUILD_ROOT
73
5071f8da
BZ
74%find_lang %{name} --all-name
75
a085f693 76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
5071f8da 82%files -f %{name}.lang
a085f693 83%defattr(644,root,root,755)
84%doc DESIGN TODO
5071f8da
BZ
85#%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*.conf
86
a085f693 87%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement.so
a085f693 88%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement_tray.so
89%attr(755,root,root) %{_libdir}/kde4/kded_networkmanagement.so
5071f8da 90%attr(755,root,root) %{_libdir}/kde4/libexec/networkmanagement_configshell
a085f693 91%attr(755,root,root) %{_libdir}/kde4/networkmanagement_novellvpnui.so
7e7dd977 92%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openconnectui.so
5ad360d8 93%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openswanui.so
5071f8da 94%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openvpnui.so
a085f693 95%attr(755,root,root) %{_libdir}/kde4/networkmanagement_pptpui.so
29856f56 96%attr(755,root,root) %{_libdir}/kde4/networkmanagement_strongswanui.so
e60e58f6 97%attr(755,root,root) %{_libdir}/kde4/networkmanagement_vpncui.so
5071f8da
BZ
98%attr(755,root,root) %{_libdir}/kde4/plasma_applet_networkmanagement.so
99%attr(755,root,root) %{_libdir}/kde4/plasma_engine_networkmanagement.so
48023a29 100%attr(755,root,root) %{_libdir}/kde4/solid_modemmanager05.so
7e7dd977 101%attr(755,root,root) %{_libdir}/kde4/solid_networkmanager09.so
5071f8da
BZ
102%attr(755,root,root) %{_libdir}/libknmclient.so
103%attr(755,root,root) %{_libdir}/libknmclient.so.*.*.*
104%attr(755,root,root) %ghost %{_libdir}/libknmclient.so.?
105%attr(755,root,root) %{_libdir}/libknminternals.so
106%attr(755,root,root) %{_libdir}/libknminternals.so.*.*.*
107%attr(755,root,root) %ghost %{_libdir}/libknminternals.so.?
108%attr(755,root,root) %{_libdir}/libknm_nm.so
109%attr(755,root,root) %{_libdir}/libknmservice.so
110%attr(755,root,root) %{_libdir}/libknmservice.so.*.*.*
111%attr(755,root,root) %ghost %{_libdir}/libknmservice.so.?
112%attr(755,root,root) %{_libdir}/libknmui.so
113%attr(755,root,root) %{_libdir}/libknmui.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libknmui.so.?
115%attr(755,root,root) %{_libdir}/libsolidcontrolfuture.so
116%attr(755,root,root) %{_libdir}/libsolidcontrolnm09ifaces.so
117%attr(755,root,root) %{_libdir}/libsolidcontrolnm09ifaces.so.*.*.*
118%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09ifaces.so.?
119%attr(755,root,root) %{_libdir}/libsolidcontrolnm09.so
120%attr(755,root,root) %{_libdir}/libsolidcontrolnm09.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09.so.?
122
123%{_datadir}/apps/desktoptheme/default/icons/network2.svgz
a085f693 124%{_datadir}/apps/networkmanagement
125%{_datadir}/kde4/services/*.desktop
126%{_datadir}/kde4/services/kded/*.desktop
127%{_datadir}/kde4/servicetypes/*.desktop
48023a29 128%{_iconsdir}/oxygen/*x*/apps/networkmanager.png
a085f693 129%{_iconsdir}/oxygen/*x*/devices/network-wireless*.png
130%{_iconsdir}/oxygen/*x*/devices/network-wired-activated.png
29856f56 131%{_iconsdir}/oxygen/*x*/devices/network-defaultroute.png
This page took 0.625062 seconds and 4 git commands to generate.