]> git.pld-linux.org Git - packages/kde4-knetworkmanager.git/blame - kde4-knetworkmanager.spec
- moved from kde4-kdeplasma-addons-networkmanager
[packages/kde4-knetworkmanager.git] / kde4-knetworkmanager.spec
CommitLineData
a085f693 1# Conditional build:
2%bcond_with verbose # verbose build
3
4%define snap 1062147
5%define qtver 4.6.0
6%define origname networkmanagement
7
8Summary: Plasma applet that controls network via NetworkManager backend
9Name: kde4-knetworkmanager
10Version: 4.3.80
11Release: 0.%{snap}.1
12License: GPL v2
13Group: X11/Applications
14# svn co svn://anonsvn.kde.org/home/kde/trunk/kdereview/networkmanagement
15Source0: %{origname}-%{snap}.tar.gz
16# Source0-md5: 437c5733c88dd190e0236bfb9bc84d72
17URL: http://en.opensuse.org/Projects/KNetworkManager
18BuildRequires: NetworkManager-devel >= 0.7.0
19BuildRequires: Qt3Support-devel >= %{qtver}
20BuildRequires: QtCore-devel >= %{qtver}
21BuildRequires: QtDBus-devel >= %{qtver}
22BuildRequires: QtGui-devel >= %{qtver}
23BuildRequires: QtNetwork-devel >= %{qtver}
24BuildRequires: QtXml-devel >= %{qtver}
25BuildRequires: automoc4 >= 0.9.88
26BuildRequires: cmake >= 2.6.2
27BuildRequires: kde4-kdebase-workspace-devel >= %{version}
28BuildRequires: kde4-kdelibs-devel >= %{version}
29BuildRequires: qt4-build >= %{qtver}
30BuildRequires: qt4-qmake >= %{qtver}
31BuildRequires: rpmbuild(macros) >= 1.293
32Obsoletes: kde4-kdeplasma-addons-networkmanager
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Plasma applet that controls network via NetworkManager backend.
37
38%prep
39%setup -q -n %{origname}-%{snap}
40
41%build
42install -d build
43cd build
44%cmake \
45 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
46 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
47 %{?with_verbose:-DCMAKE_VERBOSE_MAKEFILE=true} \
48 -DDBUS_SYSTEM_POLICY_DIR=/etc/dbus-1/system.d \
49%if "%{_lib}" != "lib"
50 -DLIB_SUFFIX=64 \
51%endif
52 ../
53
54%{__make}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59%{__make} -C build install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post -p /sbin/ldconfig
66%postun -p /sbin/ldconfig
67
68%files
69%defattr(644,root,root,755)
70%doc DESIGN TODO
71%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*.conf
72%attr(755,root,root) %{_bindir}/knetworkmanager
73%attr(755,root,root) %ghost %{_libdir}/libknmclient.so.?
74%attr(755,root,root) %{_libdir}/libknmclient.so.*.*.*
75%attr(755,root,root) %ghost %{_libdir}/libknminternals.so.?
76%attr(755,root,root) %{_libdir}/libknminternals.so.*.*.*
77%attr(755,root,root) %ghost %{_libdir}/libknmservice.so.?
78%attr(755,root,root) %{_libdir}/libknmservice.so.*.*.*
79%attr(755,root,root) %ghost %{_libdir}/libknmui.so.?
80%attr(755,root,root) %{_libdir}/libknmui.so.*.*.*
81%attr(755,root,root) %{_libdir}/libknm_nm.so
82%attr(755,root,root) %{_libdir}/libsolidcontrolfuture.so
83%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement.so
84%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openvpnui.so
85%attr(755,root,root) %{_libdir}/kde4/networkmanagement_vpncui.so
86%attr(755,root,root) %{_libdir}/kde4/plasma_applet_networkmanagement.so
87%attr(755,root,root) %{_libdir}/kde4/libexec/networkmanagement_configshell
88%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement_tray.so
89%attr(755,root,root) %{_libdir}/kde4/kded_networkmanagement.so
90%attr(755,root,root) %{_libdir}/kde4/networkmanagement_novellvpnui.so
91%attr(755,root,root) %{_libdir}/kde4/networkmanagement_pptpui.so
92%{_datadir}/apps/networkmanagement
93%{_datadir}/kde4/services/*.desktop
94%{_datadir}/kde4/services/kded/*.desktop
95%{_datadir}/kde4/servicetypes/*.desktop
96%{_datadir}/applications/kde4/knetworkmanager.desktop
97%{_datadir}/autostart/kde4-knetworkmanager-autostart.desktop
98%{_iconsdir}/oxygen/*x*/devices/network-wireless*.png
99%{_iconsdir}/oxygen/*x*/devices/network-wired-activated.png
100%{_iconsdir}/hicolor/32x32/apps/knetworkmanager.png
This page took 0.040159 seconds and 4 git commands to generate.