]> git.pld-linux.org Git - packages/kde4-knetworkmanager.git/blame - kde4-knetworkmanager.spec
- rel 2
[packages/kde4-knetworkmanager.git] / kde4-knetworkmanager.spec
CommitLineData
1083a40b 1#
a085f693 2# Conditional build:
3%bcond_with verbose # verbose build
4
7e7dd977
AM
5%define snap 20110919
6%define qtver 4.6.4
a085f693 7%define origname networkmanagement
8
9Summary: Plasma applet that controls network via NetworkManager backend
10Name: kde4-knetworkmanager
e60e58f6
BZ
11Epoch: 1
12Version: 0.9
b6880a7d 13Release: 0.%{snap}.2
a085f693 14License: GPL v2
15Group: X11/Applications
7e7dd977
AM
16# git clone git://anongit.kde.org/networkmanagement
17# git checkout nm09 (until is merged to master)
a085f693 18Source0: %{origname}-%{snap}.tar.gz
7e7dd977 19# Source0-md5: 48e0d3eb19ff53f472d6c5e7a557ee46
a085f693 20URL: http://en.opensuse.org/Projects/KNetworkManager
ffaa452c 21BuildRequires: NetworkManager-devel >= 2:0.9.0
a085f693 22BuildRequires: Qt3Support-devel >= %{qtver}
23BuildRequires: QtCore-devel >= %{qtver}
24BuildRequires: QtDBus-devel >= %{qtver}
25BuildRequires: QtGui-devel >= %{qtver}
26BuildRequires: QtNetwork-devel >= %{qtver}
27BuildRequires: QtXml-devel >= %{qtver}
28BuildRequires: automoc4 >= 0.9.88
837ab99b 29BuildRequires: cmake >= 2.8.0
a085f693 30BuildRequires: kde4-kdebase-workspace-devel >= %{version}
31BuildRequires: kde4-kdelibs-devel >= %{version}
e60e58f6 32BuildRequires: mobile-broadband-provider-info-devel
7e7dd977
AM
33BuildRequires: openconnect-devel >= 3.12
34BuildRequires: openssl-devel
a085f693 35BuildRequires: qt4-build >= %{qtver}
36BuildRequires: qt4-qmake >= %{qtver}
37BuildRequires: rpmbuild(macros) >= 1.293
38Obsoletes: kde4-kdeplasma-addons-networkmanager
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Plasma applet that controls network via NetworkManager backend.
43
44%prep
e60e58f6 45%setup -q -n %{origname}
a085f693 46
47%build
48install -d build
49cd build
50%cmake \
51 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
52 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
53 %{?with_verbose:-DCMAKE_VERBOSE_MAKEFILE=true} \
54 -DDBUS_SYSTEM_POLICY_DIR=/etc/dbus-1/system.d \
55%if "%{_lib}" != "lib"
56 -DLIB_SUFFIX=64 \
57%endif
58 ../
59
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} -C build install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72%postun -p /sbin/ldconfig
73
74%files
75%defattr(644,root,root,755)
76%doc DESIGN TODO
1083a40b 77%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*.conf
a085f693 78%attr(755,root,root) %ghost %{_libdir}/libknmclient.so.?
79%attr(755,root,root) %{_libdir}/libknmclient.so.*.*.*
80%attr(755,root,root) %ghost %{_libdir}/libknminternals.so.?
81%attr(755,root,root) %{_libdir}/libknminternals.so.*.*.*
82%attr(755,root,root) %ghost %{_libdir}/libknmservice.so.?
83%attr(755,root,root) %{_libdir}/libknmservice.so.*.*.*
84%attr(755,root,root) %ghost %{_libdir}/libknmui.so.?
7e7dd977
AM
85%attr(755,root,root) %ghost %{_libdir}/libknmservice.so.?
86%attr(755,root,root) %{_libdir}/libsolidcontrolnm09.so.*.*.*
87%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09.so.?
88%attr(755,root,root) %{_libdir}/libsolidcontrolnm09ifaces.so.*.*.*
89%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09ifaces.so.?
a085f693 90%attr(755,root,root) %{_libdir}/libknmui.so.*.*.*
91%attr(755,root,root) %{_libdir}/libknm_nm.so
29856f56 92%attr(755,root,root) %{_libdir}/libknmclient.so
93%attr(755,root,root) %{_libdir}/libknminternals.so
94%attr(755,root,root) %{_libdir}/libknmservice.so
95%attr(755,root,root) %{_libdir}/libknmui.so
a085f693 96%attr(755,root,root) %{_libdir}/libsolidcontrolfuture.so
97%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement.so
a085f693 98%attr(755,root,root) %{_libdir}/kde4/plasma_applet_networkmanagement.so
e60e58f6 99%attr(755,root,root) %{_libdir}/kde4/plasma_engine_networkmanagement.so
a085f693 100%attr(755,root,root) %{_libdir}/kde4/libexec/networkmanagement_configshell
101%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement_tray.so
102%attr(755,root,root) %{_libdir}/kde4/kded_networkmanagement.so
103%attr(755,root,root) %{_libdir}/kde4/networkmanagement_novellvpnui.so
e60e58f6 104%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openvpnui.so
7e7dd977 105%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openconnectui.so
a085f693 106%attr(755,root,root) %{_libdir}/kde4/networkmanagement_pptpui.so
29856f56 107%attr(755,root,root) %{_libdir}/kde4/networkmanagement_strongswanui.so
e60e58f6 108%attr(755,root,root) %{_libdir}/kde4/networkmanagement_vpncui.so
7e7dd977 109%attr(755,root,root) %{_libdir}/kde4/solid_networkmanager09.so
a085f693 110%{_datadir}/apps/networkmanagement
111%{_datadir}/kde4/services/*.desktop
112%{_datadir}/kde4/services/kded/*.desktop
113%{_datadir}/kde4/servicetypes/*.desktop
7e7dd977 114%{_datadir}/kde4/services/solidbackends/*.desktop
a085f693 115%{_iconsdir}/oxygen/*x*/devices/network-wireless*.png
116%{_iconsdir}/oxygen/*x*/devices/network-wired-activated.png
29856f56 117%{_iconsdir}/oxygen/*x*/devices/network-defaultroute.png
This page took 0.116653 seconds and 4 git commands to generate.