]> git.pld-linux.org Git - packages/john.git/commitdiff
- added jumbo tarbal and enabled it as default build
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Aug 2015 18:20:29 +0000 (20:20 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Aug 2015 18:20:29 +0000 (20:20 +0200)
- rel 1

john-jumbo-optflags.patch [deleted file]
john.spec
no-inline.patch [deleted file]

diff --git a/john-jumbo-optflags.patch b/john-jumbo-optflags.patch
deleted file mode 100644 (file)
index d31b8ab..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- john-1.7.8/src/Makefile~   2011-07-03 12:05:54.182086313 +0200
-+++ john-1.7.8/src/Makefile    2011-07-03 12:06:36.707718399 +0200
-@@ -32,7 +32,7 @@
- NSS_LDFLAGS = `pkg-config --libs nss`
- endif
-
--CFLAGS = -c -Wall -O2 -fomit-frame-pointer -Wdeclaration-after-statement -I/usr/local/include $(HAVE_NSS) $(OMPFLAGS) $(JOHN_CFLAGS) $(AMDAPP)
-+CFLAGS = -c $(OPTFLAGS) -fomit-frame-pointer -Wdeclaration-after-statement -I/usr/local/include $(HAVE_NSS) $(OMPFLAGS) $(JOHN_CFLAGS) $(AMDAPP)
- # -DHAVE_SKEY
- # CFLAGS for use on the main john.c file only
- CFLAGS_MAIN = $(CFLAGS)
-@@ -41,6 +41,7 @@
- OPT_NORMAL = -funroll-loops
- # Remove the "-Os" if you're using an ancient version of gcc
- OPT_INLINE = -Os -funroll-loops -finline-functions
-+OPTFLAGS = -Wall -O2
- # Works with Solaris make, and GNU make
- PLUGFORMATS_SRCS: sh =echo *_plug.c
index f64174773ee552b4ff7f0b9e6552c0e95dbd9a6e..e6c1b8360aa1840be22bc574c08d46213e770b62 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,9 +1,6 @@
-# TODO
-# no jumbo patch for 1.8.0, try making our own from github?
-# https://github.com/magnumripper/JohnTheRipper/archive/%{version}/%{name}-%{version}-jumbo.tar.gz
 #
 # Conditional build:
-%bcond_with    jumbopatch      # This patch integrates lots of contributed
+%bcond_without jumbo           # Build community-enhanced version with lots of contributed
                                # patches adding support for over 30
                                # of additional hash types, and more.
 %bcond_with    avx             # use x86 AVX instructions
@@ -39,21 +36,18 @@ Summary:    Password cracker
 Summary(pl.UTF-8):     Łamacz haseł
 Name:          john
 Version:       1.8.0
-Release:       0.1
+Release:       1
 License:       GPL v2
 Group:         Applications/System
 Source0:       http://www.openwall.com/john/j/%{name}-%{version}.tar.xz
 # Source0-md5: a4086df68f51778782777e60407f1869
-Source1:       http://www.openwall.com/john/j/%{name}-extra-20130529.tar.xz
-# Source1-md5: bb191828e8cbfd5fe0779dff5d87d5f4
+Source1:       http://www.openwall.com/john/j/%{name}-%{version}-jumbo-1.tar.xz
+# Source1-md5: 1d6b22ec41a12cdcd62ad6eae3e77345
+Source2:       http://www.openwall.com/john/j/%{name}-extra-20130529.tar.xz
 Patch0:                %{name}-mailer.patch
 Patch1:                optflags.patch
-Patch2:                http://www.openwall.com/john/g/%{name}-1.7.9-jumbo-7.diff.gz
-# Patch2-md5:  b953fcb7f743eeeb5f938a28c352b8ef
-Patch3:                %{name}-jumbo-optflags.patch
-Patch4:                no-inline.patch
 URL:           http://www.openwall.com/john/
-%{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
+%{?with_jumbo:BuildRequires: openssl-devel >= 0.9.7}
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
@@ -91,14 +85,9 @@ na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 
 %prep
-%setup -q -a1
+%setup -q -T %{?with_jumbo:-b1 -n %{name}-%{version}-jumbo-1} %{!?with_jumbo:-b0} -a2
 %patch0 -p1
-%{!?with_jumbopatch:%patch1 -p1}
-%{?with_jumbopatch:%patch2 -p1}
-%{?with_jumbopatch:%patch3 -p1}
-%ifarch %{x8664}
-%{?with_jumbopatch:%patch4 -p1}
-%endif
+%{!?with_jumbo:%patch1 -p1}
 
 mv john-extra-*/*.chr run
 
@@ -107,6 +96,10 @@ mv john-extra-*/*.chr run
 %build
 cd src
 
+%if %{with jumbo}
+%configure
+%{__make}
+%else
 cat > defs.h <<'EOF'
 #define        JOHN_SYSTEMWIDE 1
 #define        JOHN_SYSTEMWIDE_EXEC "%{_libdir}/john"
@@ -166,6 +159,7 @@ TARG=generic
 %{__make} $TARG \
        CC="%{__cc}" \
        OPTFLAGS='%{rpmcflags} -include defs.h %{?optmmxfb}'
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
diff --git a/no-inline.patch b/no-inline.patch
deleted file mode 100644 (file)
index b327479..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
---- john-1.7.9/src/MD5_std.c~  2013-07-21 13:22:20.285649779 +0200
-+++ john-1.7.9/src/MD5_std.c   2013-07-21 13:22:44.392541796 +0200
-@@ -472,12 +472,14 @@
- /*
-  * x86-64 implies a fairly recent CPU, so presumably its L1 instruction cache
-  * is large enough.
-- */
- #ifdef __x86_64__
- #define MAYBE_INLINE_BODY MAYBE_INLINE
- #else
-+ */
- #define MAYBE_INLINE_BODY
-+/*
- #endif
-+ */
- #if !MD5_X2
---- john-1.7.9/src/lotus5_fmt_plug.c~  2013-07-21 13:25:04.637186087 +0200
-+++ john-1.7.9/src/lotus5_fmt_plug.c   2013-07-21 13:25:41.664198855 +0200
-@@ -155,7 +155,7 @@
- /*Beginning of private functions*/
- /* Takes the plaintext password and generates the second row of our
-  * working matrix for the final call to the mixing function*/
--void MAYBE_INLINE
-+void
- lotus_transform_password (unsigned char *i1, unsigned char *o1,
-     unsigned char *i2, unsigned char *o2)
- {
-@@ -173,7 +173,7 @@
- }
- /* The mixing function: perturbs the first three rows of the matrix*/
--void MAYBE_INLINE lotus_mix (unsigned char *m1, unsigned char *m2)
-+void lotus_mix (unsigned char *m1, unsigned char *m2)
- {
-   int i, j;
-   unsigned char p1, p2;
This page took 0.12428 seconds and 4 git commands to generate.