]> git.pld-linux.org Git - packages/john.git/commitdiff
- up to 1.8.0
authorElan Ruusamäe <glen@delfi.ee>
Sat, 12 Jul 2014 08:15:48 +0000 (11:15 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 12 Jul 2014 08:15:48 +0000 (11:15 +0300)
- no jumbo patch
- include extra charsets tarball

john.spec
optflags.patch

index 0974df2cb5dbd84a77b83fd0f2e1dc265eb3d8af..f64174773ee552b4ff7f0b9e6552c0e95dbd9a6e 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,45 +1,51 @@
+# TODO
+# no jumbo patch for 1.8.0, try making our own from github?
+# https://github.com/magnumripper/JohnTheRipper/archive/%{version}/%{name}-%{version}-jumbo.tar.gz
 #
 # Conditional build:
-%bcond_without jumbopatch      # This patch integrates lots of contributed
+%bcond_with    jumbopatch      # This patch integrates lots of contributed
                                # patches adding support for over 30
                                # of additional hash types, and more.
 %bcond_with    avx             # use x86 AVX instructions
 %bcond_with    xop             # use x86 XOP instructions
 %bcond_with    altivec         # use PPC Altivec instructions
-#
+
 %ifarch i586 i686 athlon pentium2 pentium3 pentium4
 %define do_mmx 1
 %else
-%define        do_mmx 0
+%define do_mmx 0
 %endif
-%ifarch        i686 athlon pentium4
-%define        do_sse2 1
+%ifarch i686 athlon pentium4
+%define do_sse2 1
 %else
-%define        do_sse2 0
+%define do_sse2 0
 %endif
 %ifarch i586 i686
 %define do_mmxfb 1
-%define        optmmxfb        -DCPU_FALLBACK=1
+%define optmmxfb -DCPU_FALLBACK=1
 %else
 %define do_mmxfb 0
 %undefine optmmxfb
 %endif
 %ifarch i686 athlon
-%define        do_ssefb 1
-%define        optssefb        -DCPU_FALLBACK=1
+%define do_ssefb 1
+%define optssefb -DCPU_FALLBACK=1
 %else
-%define        do_ssefb 0
-%define        optssefb
+%define do_ssefb 0
+%define optssefb %{nil}
 %endif
+
 Summary:       Password cracker
 Summary(pl.UTF-8):     Łamacz haseł
 Name:          john
-Version:       1.7.9
-Release:       3
+Version:       1.8.0
+Release:       0.1
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
-# Source0-md5: 45f54fc59386ecd67daaef9f19781d93
+Source0:       http://www.openwall.com/john/j/%{name}-%{version}.tar.xz
+# Source0-md5: a4086df68f51778782777e60407f1869
+Source1:       http://www.openwall.com/john/j/%{name}-extra-20130529.tar.xz
+# Source1-md5: bb191828e8cbfd5fe0779dff5d87d5f4
 Patch0:                %{name}-mailer.patch
 Patch1:                optflags.patch
 Patch2:                http://www.openwall.com/john/g/%{name}-1.7.9-jumbo-7.diff.gz
@@ -49,6 +55,8 @@ Patch4:               no-inline.patch
 URL:           http://www.openwall.com/john/
 %{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
 BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 Requires:      words
 %ifarch %{ix86} %{x8664}
 %if %{with xop}
@@ -83,15 +91,17 @@ na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 
 %prep
-%setup -q
+%setup -q -a1
 %patch0 -p1
 %{!?with_jumbopatch:%patch1 -p1}
 %{?with_jumbopatch:%patch2 -p1}
 %{?with_jumbopatch:%patch3 -p1}
 %ifarch %{x8664}
-%patch4 -p1
+%{?with_jumbopatch:%patch4 -p1}
 %endif
 
+mv john-extra-*/*.chr run
+
 %{__rm} doc/INSTALL
 
 %build
index ec7db270af31ff893d3bb7cd7d1a4b337a8ebbf0..9be23c71bfff73340bcd654c9c722c10cf592688 100644 (file)
@@ -1,11 +1,11 @@
---- john-1.7.9/src/Makefile.orig       2011-11-23 01:19:21.000000000 +0100
-+++ john-1.7.9/src/Makefile    2011-11-27 11:01:56.437966014 +0100
-@@ -20,7 +20,7 @@
- #OMPFLAGS = -fopenmp -msse2
+--- john-1.8.0/src/Makefile~   2014-07-12 11:00:44.000000000 +0300
++++ john-1.8.0/src/Makefile    2014-07-12 11:05:24.241585854 +0300
+@@ -28,7 +28,7 @@
+ #OMPFLAGS = -fopenmp -D_FORTIFY_SOURCE=0
  # Sun Studio with OpenMP (set the OMP_NUM_THREADS env var at runtime)
  #OMPFLAGS = -xopenmp
--CFLAGS = -c -Wall -O2 -fomit-frame-pointer $(OMPFLAGS)
-+CFLAGS = -c $(OPTFLAGS) -fomit-frame-pointer $(OMPFLAGS)
+-CFLAGS = -c -Wall -Wdeclaration-after-statement -O2 -fomit-frame-pointer $(OMPFLAGS)
++CFLAGS = -c $(OPTFLAGS) -Wdeclaration-after-statement -fomit-frame-pointer $(OMPFLAGS)
  # CFLAGS for use on the main john.c file only
  CFLAGS_MAIN = $(CFLAGS)
  ASFLAGS = -c $(OMPFLAGS)
This page took 1.732768 seconds and 4 git commands to generate.