]> git.pld-linux.org Git - packages/gtk-webkit4.git/commitdiff
- added timer-size-assert patch to fix 32-bit builds
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 5 Apr 2024 16:32:28 +0000 (18:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 5 Apr 2024 16:32:28 +0000 (18:32 +0200)
gtk-webkit4.spec
webkit-timer-size-assert.patch [new file with mode: 0644]

index 51be6d3b7acfe631412dffcd6bdfa65fa3cef62a..2796173dc4cafd86779cd2385830761f9cb8d0d4 100644 (file)
@@ -33,6 +33,7 @@ Patch0:               x32.patch
 Patch1:                %{name}-icu59.patch
 Patch2:                parallel-gir.patch
 Patch3:                %{name}-driver-version-suffix.patch
+Patch4:                webkit-timer-size-assert.patch
 URL:           https://webkitgtk.org/
 BuildRequires: /usr/bin/ld.gold
 BuildRequires: EGL-devel
@@ -317,6 +318,7 @@ Dokumentacja API portu WebKitu do GTK 4.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %if %{with lowmem}
diff --git a/webkit-timer-size-assert.patch b/webkit-timer-size-assert.patch
new file mode 100644 (file)
index 0000000..70975b3
--- /dev/null
@@ -0,0 +1,34 @@
+From 2922af379dc70b4b1a63b01d67179eb431f03ac4 Mon Sep 17 00:00:00 2001
+From: Michael Catanzaro <mcatanzaro@redhat.com>
+Date: Mon, 18 Mar 2024 11:14:54 -0700
+Subject: [PATCH] REGRESSION(274077@main): failure to build on i586 (and likely
+ other 32bit arches): static assertion failed: Timer should stay small
+ https://bugs.webkit.org/show_bug.cgi?id=271108
+
+Unreviewed build fix. This changes SameSizeOfTimer to ensure it matches
+the size of Timer on 32-bit platforms.
+
+* Source/WebCore/platform/Timer.cpp:
+
+Canonical link: https://commits.webkit.org/276282@main
+---
+ Source/WebCore/platform/Timer.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/Source/WebCore/platform/Timer.cpp b/Source/WebCore/platform/Timer.cpp
+index 4f7c0f5c39ca9..0f3734cca2474 100644
+--- a/Source/WebCore/platform/Timer.cpp
++++ b/Source/WebCore/platform/Timer.cpp
+@@ -263,7 +263,11 @@ struct SameSizeAsTimer {
+     WeakPtr<TimerAlignment> timerAlignment;
+     double times[2];
+-    void* pointers[3];
++    void* pointers[2];
++#if CPU(ADDRESS32)
++    uint8_t bitfields;
++#endif
++    void* pointer;
+ };
+ static_assert(sizeof(Timer) == sizeof(SameSizeAsTimer), "Timer should stay small");
This page took 0.069379 seconds and 4 git commands to generate.