]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
51be6d3b7acfe631412dffcd6bdfa65fa3cef62a
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (experimental; BR: openwebrtc)
4 # - SPEECH_SYNTHESIS? (experimental; BR: flite-devel >= 2.2)
5 # - THUNDER? (BR: Thunder + ThunderClientLibraries)
6 #
7 # Conditional build:
8 %bcond_without  introspection   # GObject introspection
9 %bcond_without  libsoup2        # webkit-4.0 (libsoup2 based) variant
10 %bcond_without  libsoup3        # webkit-4.1 (libsoup3 based) variant (HTTP/2 support)
11 %bcond_without  gtk3            # webkit-4.x (gtk3 based) variants
12 %bcond_without  gtk4            # webkit-6.0 (gtk4/libsoup3 based) variant
13 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
14 %bcond_with     lowmem          # try to reduce build memory usage by adjusting gcc gc
15 %bcond_with     lowmem2         # try to reduce build memory usage by disabling unified build (long)
16 #
17 # it's not possible to build this with debuginfo on 32bit archs due to
18 # memory constraints during linking
19 %ifarch %{ix86} x32
20 %define         _enable_debug_packages          0
21 %endif
22 Summary:        Port of WebKit embeddable web component to GTK+ 3
23 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
24 Name:           gtk-webkit4
25 # NOTE: 2.44.x is stable, 2.45.x devel
26 Version:        2.44.0
27 Release:        1
28 License:        BSD-like
29 Group:          X11/Libraries
30 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
31 # Source0-md5:  20fef6a9122fc46f66f2f8550d5f08c6
32 Patch0:         x32.patch
33 Patch1:         %{name}-icu59.patch
34 Patch2:         parallel-gir.patch
35 Patch3:         %{name}-driver-version-suffix.patch
36 URL:            https://webkitgtk.org/
37 BuildRequires:  /usr/bin/ld.gold
38 BuildRequires:  EGL-devel
39 BuildRequires:  Mesa-libgbm-devel
40 BuildRequires:  OpenGL-GLX-devel
41 BuildRequires:  OpenGLESv2-devel
42 BuildRequires:  at-spi2-core-devel >= 2.5.3
43 BuildRequires:  atk-devel >= 1:2.16.0
44 BuildRequires:  bubblewrap >= 0.3.1
45 BuildRequires:  cairo-devel >= 1.16.0
46 BuildRequires:  cmake >= 3.20
47 BuildRequires:  docbook-dtd412-xml
48 BuildRequires:  enchant2-devel >= 2
49 BuildRequires:  fontconfig-devel >= 2.13.0
50 BuildRequires:  freetype-devel >= 1:2.9.0
51 BuildRequires:  gettext-devel
52 BuildRequires:  gettext-tools
53 BuildRequires:  gi-docgen
54 BuildRequires:  glib2-devel >= 1:2.70.0
55 BuildRequires:  glibc-misc
56 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
57 BuildRequires:  gperf >= 3.0.1
58 BuildRequires:  gstreamer-devel >= 1.18.4
59 BuildRequires:  gstreamer-gl-devel >= 1.18.4
60 # codecparsers >= 1.18.4, mpegts >= 1.18.4, webrtc >= 1.20
61 BuildRequires:  gstreamer-plugins-bad-devel >= 1.20
62 # app,audio,fft,pbutils,tag,video
63 BuildRequires:  gstreamer-plugins-base-devel >= 1.18.4
64 BuildRequires:  gstreamer-transcoder-devel >= 1.20
65 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.22.0}
66 %{?with_gtk4:BuildRequires:     gtk4-devel >= 4.6.0}
67 BuildRequires:  harfbuzz-devel >= 1.4.2
68 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
69 BuildRequires:  hyphen-devel
70 BuildRequires:  lcms2-devel >= 2
71 %ifarch %arch64
72 %ifnarch %arch_with_atomics128
73 BuildRequires:  libatomic-devel
74 %endif
75 %endif
76 BuildRequires:  libavif-devel >= 0.9.0
77 BuildRequires:  libdrm-devel
78 BuildRequires:  libepoxy-devel >= 1.5.4
79 BuildRequires:  libgcrypt-devel >= 1.7.0
80 BuildRequires:  libicu-devel >= 61.2
81 BuildRequires:  libjpeg-devel
82 BuildRequires:  libjxl-devel >= 0.7.0
83 BuildRequires:  libmanette-devel >= 0.2.4
84 BuildRequires:  libnotify-devel
85 BuildRequires:  libpng-devel
86 BuildRequires:  libseccomp-devel
87 BuildRequires:  libsecret-devel
88 %{?with_libsoup2:BuildRequires: libsoup-devel >= 2.54}
89 %{?with_libsoup3:BuildRequires: libsoup3-devel >= 3.0}
90 # -std=c++2a; WebKitCommon.cmake says gcc 9.3.0 is minimum, but 9.5.0 fails to build
91 BuildRequires:  libstdc++-devel >= 6:10.2
92 BuildRequires:  libtasn1-devel
93 BuildRequires:  libwebp-devel
94 BuildRequires:  libwpe-devel >= 1.3.0
95 BuildRequires:  libxml2-devel >= 1:2.8.0
96 BuildRequires:  libxslt-devel >= 1.1.7
97 BuildRequires:  openjpeg2-devel >= 2.2.0
98 BuildRequires:  openssl-devel >= 3.0.0
99 BuildRequires:  pango-devel >= 1:1.32.0
100 BuildRequires:  perl-base >= 1:5.10.0
101 BuildRequires:  pkgconfig
102 BuildRequires:  python >= 1:2.7.0
103 BuildRequires:  rpm-build >= 4.6
104 BuildRequires:  rpmbuild(macros) >= 2.029
105 BuildRequires:  ruby >= 1:2.5
106 BuildRequires:  ruby-modules >= 1:2.5
107 BuildRequires:  sqlite3-devel >= 3
108 BuildRequires:  systemd-devel
109 BuildRequires:  tar >= 1:1.22
110 BuildRequires:  unifdef
111 %if %{with wayland}
112 BuildRequires:  wayland-devel >= 1.20
113 BuildRequires:  wayland-egl-devel
114 BuildRequires:  wayland-protocols >= 1.24
115 %endif
116 BuildRequires:  wpebackend-fdo-devel >= 1.9.0
117 BuildRequires:  woff2-devel >= 1.0.2
118 BuildRequires:  xdg-dbus-proxy
119 BuildRequires:  xorg-lib-libICE-devel
120 BuildRequires:  xorg-lib-libXcomposite-devel
121 BuildRequires:  xorg-lib-libXdamage-devel
122 BuildRequires:  xorg-lib-libXext-devel
123 BuildRequires:  xorg-lib-libXrender-devel
124 BuildRequires:  xorg-lib-libXt-devel
125 BuildRequires:  xz
126 BuildRequires:  zlib-devel
127 Requires:       at-spi2-core-libs >= 2.5.3
128 Requires:       atk >= 1:2.16.0
129 Requires:       cairo >= 1.16.0
130 Requires:       fontconfig-libs >= 2.13.0
131 Requires:       freetype >= 1:2.9.0
132 Requires:       glib2 >= 1:2.70.0
133 Requires:       gstreamer >= 1.2.3
134 Requires:       gstreamer-plugins-base >= 1.2.3
135 Requires:       gtk+3 >= 3.22.0
136 Requires:       harfbuzz >= 1.4.2
137 Requires:       libepoxy >= 1.5.4
138 Requires:       libgcrypt >= 1.7.0
139 Requires:       libjxl >= 0.7.0
140 Requires:       libsoup >= 2.54
141 Requires:       libwpe >= 1.3.0
142 Requires:       libxml2 >= 1:2.8.0
143 Requires:       libxslt >= 1.1.7
144 Requires:       openjpeg2 >= 2.2.0
145 Requires:       pango >= 1:1.32.0
146 Requires:       wayland >= 1.20
147 Requires:       woff2 >= 1.0.2
148 Requires:       wpebackend-fdo >= 1.9.0
149 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
150 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
151 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 # __once_call, __once_called non-function symbols from libstdc++
155 %define         skip_post_check_so      lib.*gtk-4.0.*
156
157 %description
158 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
159 3.
160
161 %description -l pl.UTF-8
162 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
163
164 %package devel
165 Summary:        Development files for WebKit for GTK+ 3
166 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
167 Group:          X11/Development/Libraries
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       glib2-devel >= 1:2.70.0
170 Requires:       gtk+3-devel >= 3.22.0
171 Requires:       libsoup-devel >= 2.54
172 Requires:       libstdc++-devel >= 6:10.2
173
174 %description devel
175 Development files for WebKit for GTK+ 3.
176
177 %description devel -l pl.UTF-8
178 Pliki programistyczne komponentu WebKit dla GTK+ 3.
179
180 %package apidocs
181 Summary:        API documentation for WebKit GTK+ 3 port
182 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3
183 Group:          Documentation
184 BuildArch:      noarch
185
186 %description apidocs
187 API documentation for WebKit GTK+ 3 port.
188
189 %description apidocs -l pl.UTF-8
190 Dokumentacja API portu WebKitu do GTK+ 3.
191
192 %package -n gtk-webkit4.1
193 Summary:        Port of WebKit embeddable web component to GTK+ 3 with HTTP/2 support
194 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3 z obsługą HTTP/2
195 Group:          X11/Libraries
196 Requires:       at-spi2-core-libs >= 2.5.3
197 Requires:       atk >= 1:2.16.0
198 Requires:       cairo >= 1.16.0
199 Requires:       fontconfig-libs >= 2.13.0
200 Requires:       freetype >= 1:2.9.0
201 Requires:       glib2 >= 1:2.70.0
202 Requires:       gstreamer >= 1.2.3
203 Requires:       gstreamer-plugins-base >= 1.2.3
204 Requires:       gtk+3 >= 3.22.0
205 Requires:       harfbuzz >= 1.4.2
206 Requires:       libgcrypt >= 1.7.0
207 Requires:       libjxl >= 0.7.0
208 Requires:       libsoup3 >= 3.0
209 Requires:       libwpe >= 1.3.0
210 Requires:       libxml2 >= 1:2.8.0
211 Requires:       libxslt >= 1.1.7
212 Requires:       openjpeg2 >= 2.2.0
213 Requires:       pango >= 1:1.32.0
214 Requires:       wayland >= 1.20
215 Requires:       woff2 >= 1.0.2
216 Requires:       wpebackend-fdo >= 1.9.0
217
218 %description -n gtk-webkit4.1
219 gtk-webkit4.1 is a port of the WebKit embeddable web component to GTK+
220 3 with HTTP/2 (libsoup 3) support.
221
222 %description -n gtk-webkit4.1 -l pl.UTF-8
223 gtk-webkit4.1 to port osadzalnego komponentu WWW WebKit do GTK+ 3 z
224 obsługą HTTP/2 (libsoup 3).
225
226 %package -n gtk-webkit4.1-devel
227 Summary:        Development files for WebKit for GTK+ 3 with HTTP/2 support
228 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2
229 Group:          X11/Development/Libraries
230 Requires:       gtk-webkit4.1 = %{version}-%{release}
231 Requires:       glib2-devel >= 1:2.70.0
232 Requires:       gtk+3-devel >= 3.22.0
233 Requires:       libsoup3-devel >= 3.0
234 Requires:       libstdc++-devel >= 6:10.2
235
236 %description -n gtk-webkit4.1-devel
237 Development files for WebKit for GTK+ 3 with HTTP/2 support.
238
239 %description -n gtk-webkit4.1-devel -l pl.UTF-8
240 Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2.
241
242 %package -n gtk-webkit4.1-apidocs
243 Summary:        API documentation for WebKit GTK+ 3 port with HTTP/2 support
244 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2
245 Group:          Documentation
246 BuildArch:      noarch
247
248 %description -n gtk-webkit4.1-apidocs
249 API documentation for WebKit GTK+ 3 port with HTTP/2 support.
250
251 %description -n gtk-webkit4.1-apidocs -l pl.UTF-8
252 Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2.
253
254 %package -n gtk-webkit6
255 Summary:        Port of WebKit embeddable web component to GTK 4
256 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK 4
257 Group:          X11/Libraries
258 Requires:       at-spi2-core-libs >= 2.5.3
259 Requires:       atk >= 1:2.16.0
260 Requires:       cairo >= 1.16.0
261 Requires:       fontconfig-libs >= 2.13.0
262 Requires:       freetype >= 1:2.9.0
263 Requires:       glib2 >= 1:2.70.0
264 Requires:       gstreamer >= 1.2.3
265 Requires:       gstreamer-plugins-base >= 1.2.3
266 Requires:       gtk4 >= 4.6.0
267 Requires:       harfbuzz >= 1.4.2
268 Requires:       libgcrypt >= 1.7.0
269 Requires:       libjxl >= 0.7.0
270 Requires:       libsoup3 >= 3.0
271 Requires:       libwpe >= 1.3.0
272 Requires:       libxml2 >= 1:2.8.0
273 Requires:       libxslt >= 1.1.7
274 Requires:       openjpeg2 >= 2.2.0
275 Requires:       pango >= 1:1.32.0
276 Requires:       wayland >= 1.20
277 Requires:       woff2 >= 1.0.2
278 Requires:       wpebackend-fdo >= 1.9.0
279
280 %description -n gtk-webkit6
281 gtk-webkit6 is a port of the WebKit embeddable web component to GTK 4.
282
283 %description -n gtk-webkit6 -l pl.UTF-8
284 gtk-webkit6 to port osadzalnego komponentu WWW WebKit do GTK+ 4.
285
286 %package -n gtk-webkit6-devel
287 Summary:        Development files for WebKit for GTK 4
288 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK 4
289 Group:          X11/Development/Libraries
290 Requires:       gtk-webkit6 = %{version}-%{release}
291 Requires:       glib2-devel >= 1:2.70.0
292 Requires:       gtk4-devel >= 4.6.0
293 Requires:       libsoup3-devel >= 3.0
294 Requires:       libstdc++-devel >= 6:10.2
295
296 %description -n gtk-webkit6-devel
297 Development files for WebKit for GTK 4.
298
299 %description -n gtk-webkit6-devel -l pl.UTF-8
300 Pliki programistyczne komponentu WebKit dla GTK 4.
301
302 %package -n gtk-webkit6-apidocs
303 Summary:        API documentation for WebKit GTK 4 port
304 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK 4
305 Group:          Documentation
306 BuildArch:      noarch
307
308 %description -n gtk-webkit6-apidocs
309 API documentation for WebKit GTK 4 port.
310
311 %description -n gtk-webkit6-apidocs -l pl.UTF-8
312 Dokumentacja API portu WebKitu do GTK 4.
313
314 %prep
315 %setup -q -n webkitgtk-%{version}
316 %patch0 -p1
317 %patch1 -p1
318 %patch2 -p1
319 %patch3 -p1
320
321 %build
322 %if %{with lowmem}
323 CXXFLAGS="%{rpmcxxflags} --param ggc-min-expand=20 --param ggc-min-heapsize=65536"
324 %endif
325 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
326 %cmake -B build-${kind} \
327         -DENABLE_GEOLOCATION=ON \
328         -DENABLE_GTKDOC=ON \
329         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
330         %{?with_lowmem2:-DENABLE_UNIFIED_BUILDS=OFF} \
331         -DENABLE_VIDEO=ON \
332         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
333         -DENABLE_WEB_AUDIO=ON \
334         -DENABLE_WEBGL=ON \
335 %ifarch x32
336         -DENABLE_C_LOOP=ON \
337         -DENABLE_JIT=OFF \
338         -DENABLE_SAMPLING_PROFILER=OFF \
339 %endif
340 %ifarch %{ix86} %{x8664} x32
341         -DHAVE_SSE2_EXTENSIONS=ON \
342 %endif
343         -DPORT=GTK \
344         -DSHOULD_INSTALL_JS_SHELL=ON \
345         $([ "$kind" != "gtk4" ] && echo -DUSE_GTK4=OFF) \
346         -DUSE_LIBBACKTRACE=OFF \
347         $([ "$kind" = "soup2" ] && echo -DUSE_SOUP2=ON)
348
349 %{__make} -C build-${kind}
350 done
351
352 %install
353 rm -rf $RPM_BUILD_ROOT
354
355 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
356 %{__make} -C build-${kind} install \
357         DESTDIR=$RPM_BUILD_ROOT
358 done
359
360 install -d $RPM_BUILD_ROOT%{_gidocdir}
361 %{__mv} $RPM_BUILD_ROOT%{_docdir}/{javascriptcoregtk,webkit*gtk}-* $RPM_BUILD_ROOT%{_gidocdir}
362
363 %{?with_gtk3:%{?with_libsoup2:%find_lang WebKitGTK-4.0}}
364 %{?with_gtk3:%{?with_libsoup3:%find_lang WebKitGTK-4.1}}
365 %{?with_gtk4:%find_lang WebKitGTK-6.0}
366
367 %clean
368 rm -rf $RPM_BUILD_ROOT
369
370 %post   -p /sbin/ldconfig
371 %postun -p /sbin/ldconfig
372
373 %post   -n gtk-webkit4.1 -p /sbin/ldconfig
374 %postun -n gtk-webkit4.1 -p /sbin/ldconfig
375
376 %post   -n gtk-webkit6 -p /sbin/ldconfig
377 %postun -n gtk-webkit6 -p /sbin/ldconfig
378
379 %if %{with gtk3} && %{with libsoup2}
380 %files -f WebKitGTK-4.0.lang
381 %defattr(644,root,root,755)
382 %doc NEWS
383 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.0
384 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
385 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
386 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
388 %if %{with introspection}
389 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
390 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
391 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
392 %endif
393 %if "%{_libexecdir}" != "%{_libdir}"
394 %dir %{_libexecdir}/webkit2gtk-4.0
395 %endif
396 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/MiniBrowser
397 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
398 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
399 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
400 %dir %{_libdir}/webkit2gtk-4.0
401 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
402 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
403
404 %files devel
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
407 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
408 %if %{with introspection}
409 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
410 %{_datadir}/gir-1.0/WebKit2-4.0.gir
411 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
412 %endif
413 %{_includedir}/webkitgtk-4.0
414 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
415 %{_pkgconfigdir}/webkit2gtk-4.0.pc
416 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
417
418 %files apidocs
419 %defattr(644,root,root,755)
420 %{_gidocdir}/javascriptcoregtk-4.0
421 %{_gidocdir}/webkit2gtk-4.0
422 %{_gidocdir}/webkit2gtk-web-extension-4.0
423 %endif
424
425 %if %{with gtk3} && %{with libsoup3}
426 %files -n gtk-webkit4.1 -f WebKitGTK-4.1.lang
427 %defattr(644,root,root,755)
428 %doc NEWS
429 %attr(755,root,root) %{_bindir}/WebKitWebDriver-4.1
430 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.1.so.0
432 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.1.so.0
434 %if %{with introspection}
435 %{_libdir}/girepository-1.0/JavaScriptCore-4.1.typelib
436 %{_libdir}/girepository-1.0/WebKit2-4.1.typelib
437 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.1.typelib
438 %endif
439 %if "%{_libexecdir}" != "%{_libdir}"
440 %dir %{_libexecdir}/webkit2gtk-4.1
441 %endif
442 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/MiniBrowser
443 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitNetworkProcess
444 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitWebProcess
445 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/jsc
446 %dir %{_libdir}/webkit2gtk-4.1
447 %dir %{_libdir}/webkit2gtk-4.1/injected-bundle
448 %attr(755,root,root) %{_libdir}/webkit2gtk-4.1/injected-bundle/libwebkit2gtkinjectedbundle.so
449
450 %files -n gtk-webkit4.1-devel
451 %defattr(644,root,root,755)
452 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so
453 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so
454 %if %{with introspection}
455 %{_datadir}/gir-1.0/JavaScriptCore-4.1.gir
456 %{_datadir}/gir-1.0/WebKit2-4.1.gir
457 %{_datadir}/gir-1.0/WebKit2WebExtension-4.1.gir
458 %endif
459 %{_includedir}/webkitgtk-4.1
460 %{_pkgconfigdir}/javascriptcoregtk-4.1.pc
461 %{_pkgconfigdir}/webkit2gtk-4.1.pc
462 %{_pkgconfigdir}/webkit2gtk-web-extension-4.1.pc
463
464 %files -n gtk-webkit4.1-apidocs
465 %defattr(644,root,root,755)
466 %{_gidocdir}/javascriptcoregtk-4.1
467 %{_gidocdir}/webkit2gtk-4.1
468 %{_gidocdir}/webkit2gtk-web-extension-4.1
469 %endif
470
471 %if %{with gtk4}
472 %files -n gtk-webkit6 -f WebKitGTK-6.0.lang
473 %defattr(644,root,root,755)
474 %doc NEWS
475 %attr(755,root,root) %{_bindir}/WebKitWebDriver-6.0
476 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-6.0.so.1
478 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-6.0.so.4
480 %if %{with introspection}
481 %{_libdir}/girepository-1.0/JavaScriptCore-6.0.typelib
482 %{_libdir}/girepository-1.0/WebKit-6.0.typelib
483 %{_libdir}/girepository-1.0/WebKitWebProcessExtension-6.0.typelib
484 %endif
485 %if "%{_libexecdir}" != "%{_libdir}"
486 %dir %{_libexecdir}/webkitgtk-6.0
487 %endif
488 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/MiniBrowser
489 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitNetworkProcess
490 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/WebKitWebProcess
491 %attr(755,root,root) %{_libexecdir}/webkitgtk-6.0/jsc
492 %dir %{_libdir}/webkitgtk-6.0
493 %dir %{_libdir}/webkitgtk-6.0/injected-bundle
494 %attr(755,root,root) %{_libdir}/webkitgtk-6.0/injected-bundle/libwebkitgtkinjectedbundle.so
495
496 %files -n gtk-webkit6-devel
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_libdir}/libwebkitgtk-6.0.so
499 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-6.0.so
500 %if %{with introspection}
501 %{_datadir}/gir-1.0/JavaScriptCore-6.0.gir
502 %{_datadir}/gir-1.0/WebKit-6.0.gir
503 %{_datadir}/gir-1.0/WebKitWebProcessExtension-6.0.gir
504 %endif
505 %{_includedir}/webkitgtk-6.0
506 %{_pkgconfigdir}/javascriptcoregtk-6.0.pc
507 %{_pkgconfigdir}/webkitgtk-6.0.pc
508 %{_pkgconfigdir}/webkitgtk-web-process-extension-6.0.pc
509
510 %files -n gtk-webkit6-apidocs
511 %defattr(644,root,root,755)
512 %{_gidocdir}/javascriptcoregtk-6.0
513 %{_gidocdir}/webkitgtk-6.0
514 %{_gidocdir}/webkitgtk-web-process-extension-6.0
515 %endif
This page took 0.114618 seconds and 2 git commands to generate.