]> git.pld-linux.org Git - packages/grub2.git/commitdiff
- rel 5; fix 'grub-mkimage: error: relocation 0x4 is not implemented yet.' with newer... auto/th/grub2-2.02-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 16 Nov 2018 13:00:12 +0000 (14:00 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 16 Nov 2018 13:00:12 +0000 (14:00 +0100)
grub2-binutils.patch [new file with mode: 0644]
grub2.spec

diff --git a/grub2-binutils.patch b/grub2-binutils.patch
new file mode 100644 (file)
index 0000000..1aeae68
--- /dev/null
@@ -0,0 +1,65 @@
+commit 842c390469e2c2e10b5aa36700324cd3bde25875
+Author: H.J. Lu <hjl.tools@gmail.com>
+Date:   Sat Feb 17 06:47:28 2018 -0800
+
+    x86-64: Treat R_X86_64_PLT32 as R_X86_64_PC32
+    
+    Starting from binutils commit bd7ab16b4537788ad53521c45469a1bdae84ad4a:
+    
+    https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=bd7ab16b4537788ad53521c45469a1bdae84ad4a
+    
+    x86-64 assembler generates R_X86_64_PLT32, instead of R_X86_64_PC32, for
+    32-bit PC-relative branches.  Grub2 should treat R_X86_64_PLT32 as
+    R_X86_64_PC32.
+    
+    Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
+    Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
+
+diff --git a/grub-core/efiemu/i386/loadcore64.c b/grub-core/efiemu/i386/loadcore64.c
+index e49d0b6ff..18facf47f 100644
+--- a/grub-core/efiemu/i386/loadcore64.c
++++ b/grub-core/efiemu/i386/loadcore64.c
+@@ -98,6 +98,7 @@ grub_arch_efiemu_relocate_symbols64 (grub_efiemu_segment_t segs,
+                   break;
+                 case R_X86_64_PC32:
++                case R_X86_64_PLT32:
+                   err = grub_efiemu_write_value (addr,
+                                                  *addr32 + rel->r_addend
+                                                  + sym.off
+diff --git a/grub-core/kern/x86_64/dl.c b/grub-core/kern/x86_64/dl.c
+index 440690673..3a73e6e6c 100644
+--- a/grub-core/kern/x86_64/dl.c
++++ b/grub-core/kern/x86_64/dl.c
+@@ -70,6 +70,7 @@ grub_arch_dl_relocate_symbols (grub_dl_t mod, void *ehdr,
+         break;
+       case R_X86_64_PC32:
++      case R_X86_64_PLT32:
+         {
+           grub_int64_t value;
+           value = ((grub_int32_t) *addr32) + rel->r_addend + sym->st_value -
+diff --git a/util/grub-mkimagexx.c b/util/grub-mkimagexx.c
+index a2bb05439..39d7efb91 100644
+--- a/util/grub-mkimagexx.c
++++ b/util/grub-mkimagexx.c
+@@ -841,6 +841,7 @@ SUFFIX (relocate_addresses) (Elf_Ehdr *e, Elf_Shdr *sections,
+                 break;
+               case R_X86_64_PC32:
++              case R_X86_64_PLT32:
+                 {
+                   grub_uint32_t *t32 = (grub_uint32_t *) target;
+                   *t32 = grub_host_to_target64 (grub_target_to_host32 (*t32)
+diff --git a/util/grub-module-verifier.c b/util/grub-module-verifier.c
+index 9179285a5..a79271f66 100644
+--- a/util/grub-module-verifier.c
++++ b/util/grub-module-verifier.c
+@@ -19,6 +19,7 @@ struct grub_module_verifier_arch archs[] = {
+       -1
+     }, (int[]){
+       R_X86_64_PC32,
++      R_X86_64_PLT32,
+       -1
+     }
+   },
index 7bd9eb73e9648fa31dd61de121463272c408fdab..a121d1025629552fdc8bec5b76dca5c837664607 100644 (file)
@@ -47,7 +47,7 @@ Summary(pl.UTF-8):    GRUB2 - bootloader dla x86 i ppc
 Summary(pt_BR.UTF-8):  Gerenciador de inicialização GRUB2
 Name:          grub2
 Version:       2.02
 Summary(pt_BR.UTF-8):  Gerenciador de inicialização GRUB2
 Name:          grub2
 Version:       2.02
-Release:       4
+Release:       5
 License:       GPL v2
 Group:         Base
 Source0:       ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
 License:       GPL v2
 Group:         Base
 Source0:       ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
@@ -74,6 +74,7 @@ Patch14:      blscfg.patch
 Patch15:       intel-ucode.patch
 Patch16:       xfs.patch
 Patch17:       gcc8.patch
 Patch15:       intel-ucode.patch
 Patch16:       xfs.patch
 Patch17:       gcc8.patch
+Patch18:       grub2-binutils.patch
 URL:           http://www.gnu.org/software/grub/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.11.1-1
 URL:           http://www.gnu.org/software/grub/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.11.1-1
@@ -305,6 +306,7 @@ Motyw starfield dla GRUB-a.
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
+%patch18 -p1
 
 # we don't have C.utf-8 and need an UTF-8 locale for build
 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
 
 # we don't have C.utf-8 and need an UTF-8 locale for build
 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
This page took 0.183877 seconds and 4 git commands to generate.