]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
7bd9eb73e9648fa31dd61de121463272c408fdab
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     1
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 Name:           grub2
49 Version:        2.02
50 Release:        4
51 License:        GPL v2
52 Group:          Base
53 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
55 Source1:        update-grub
56 Source2:        update-grub.8
57 Source3:        grub.sysconfig
58 Source4:        grub-custom.cfg
59 Patch1:         pld-sysconfdir.patch
60 Patch2:         grub-garbage.patch
61 Patch3:         grub-lvmdevice.patch
62 Patch4:         pld-mkconfigdir.patch
63 Patch5:         grub-mkconfig-diagnostics.patch
64 Patch6:         posix.patch
65 Patch7:         %{name}-fonts_path.patch
66 Patch8:         add-vlan-tag-support.patch
67 Patch9:         just-say-linux.patch
68 Patch10:        ignore-kernel-symlinks.patch
69 Patch11:        choose-preferred-initrd.patch
70 Patch12:        %{name}-cfg.patch
71 Patch13:        efi-net-fix.patch
72 Patch14:        blscfg.patch
73 # https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74 Patch15:        intel-ucode.patch
75 Patch16:        xfs.patch
76 Patch17:        gcc8.patch
77 URL:            http://www.gnu.org/software/grub/
78 BuildRequires:  autoconf >= 2.53
79 BuildRequires:  automake >= 1:1.11.1-1
80 BuildRequires:  bison
81 BuildRequires:  device-mapper-devel
82 BuildRequires:  flex >= 2.5.35
83 BuildRequires:  fonts-TTF-DejaVu
84 BuildRequires:  freetype-devel >= 2
85 BuildRequires:  gawk
86 BuildRequires:  gcc >= 5:3.4
87 BuildRequires:  gettext-tools
88 BuildRequires:  glibc-localedb-all
89 BuildRequires:  glibc-static
90 BuildRequires:  help2man
91 BuildRequires:  libfuse-devel
92 BuildRequires:  libtool
93 BuildRequires:  ncurses-devel
94 BuildRequires:  python
95 BuildRequires:  python-modules
96 BuildRequires:  rpm >= 4.4.9-56
97 BuildRequires:  rpmbuild(macros) >= 1.213
98 BuildRequires:  sed >= 4.0
99 BuildRequires:  tar >= 1:1.22
100 BuildRequires:  texinfo
101 BuildRequires:  xz
102 BuildRequires:  xz-devel
103 %ifarch %{x8664}
104 BuildRequires:  /usr/lib/libc.so
105 %if "%{pld_release}" == "ac"
106 BuildRequires:  libgcc32
107 %else
108 BuildRequires:  gcc-multilib-32
109 %endif
110 %endif
111 Requires:       %{name}-platform = %{version}-%{release}
112 Requires:       pld-release
113 Requires:       which
114 %ifarch %{ix86} %{x8664}
115 Suggests:       %{name}-platform-pc
116 %endif
117 Suggests:       cdrkit-mkisofs
118 Suggests:       os-prober
119 Provides:       bootloader
120 Conflicts:      grub
121 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define         _sbindir        /sbin
125 %define         _bindir         %{_sbindir}
126 %define         _libdir         /lib
127 %define         _datadir        %{_libdir}
128 %define         _libexecdir     %{_libdir}/grub
129 %define         _grubdir        /boot/grub
130 %define         _localedir      /usr/share/locale
131
132 # part of grub code is not relocable (these are not Linux libs)
133 # stack protector also breaks non-Linux binaries
134 # any kind of forced optimizations makes grub2 unreliable (random
135 # reboots and hangs on boot menu screen)
136 %define         filterout_c     -fPIC -O.
137 %undefine       _ssp_cflags
138 %undefine       _fortify_cflags
139
140 %description
141 GRUB is a GPLed bootloader intended to unify bootloading across x86
142 operating systems. In addition to loading the Linux and *BSD kernels,
143 it implements the Multiboot standard, which allows for flexible
144 loading of multiple boot images (needed for modular kernels such as
145 the GNU Hurd).
146
147 GRUB 2 is derived from PUPA which was a research project to
148 investigate the next generation of GRUB. GRUB 2 has been rewritten
149 from scratch to clean up everything for modularity and portability.
150
151 GRUB 2 targets at the following goals:
152 - Scripting support, such as conditionals, loops, variables and
153   functions.
154 - Graphical interface.
155 - Dynamic loading of modules in order to extend itself at the run time
156   rather than at the build time.
157 - Portability for various architectures.
158 - Internationalization. This includes support for non-ASCII character
159   code, message catalogs like gettext, fonts, graphics console, and so
160   on.
161 - Real memory management, to make GNU GRUB more extensible.
162 - Modular, hierarchical, object-oriented framework for file systems,
163   files, devices, drives, terminals, commands, partition tables and OS
164   loaders.
165 - Cross-platform installation which allows for installing GRUB from a
166   different architecture.
167 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
168 - Fix design mistakes in GRUB Legacy, which could not be solved for
169   backward-compatibility, such as the way of numbering partitions.
170
171 %description -l de.UTF-8
172 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
173 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
174 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
175
176 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
177 und wird unter der GPL vertrieben. Aufgrund seiner höheren
178 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
179 traditionellen Boot-Loader LILO.
180
181 %description -l hu.UTF-8
182 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
183 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
184 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
185 GNU Hurd).
186
187 GRUB2 céljai a következők:
188 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
189   függvények.
190 - grafikus felület
191 - modulok dinamikus betöltése futási időben
192 - hordozhatóság több architektúrára
193 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
194   mint gettext, betűtípusok, grafikus konzolon, és így tovább
195 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
196 - moduláris, hierarchikus, objektum-orientált keretrendszer
197   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
198   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
199
200 %description -l es.UTF-8
201 Éste es GRUB - Grand Unified Boot Loader - un administrador de
202 inicialización capaz de entrar en la mayoría de los sistemas
203 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
204 también en la mayoría de los sistemas operacionales comerciales para
205 PC.
206
207 El administrador GRUB puede ser una buena alternativa a LILO, para
208 usuarios conmás experiencia y que deseen obtener más recursos de su
209 cargador de inicialización (boot loader).
210
211 %description -l pl.UTF-8
212 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
213 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
214 Linuksa i *BSD: posiada również implementację standardu Multiboot,
215 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
216 (czego wymagają modułowe jądra, takie jak GNU Hurd).
217
218 %description -l pt_BR.UTF-8
219 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
220 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
221 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
222 operacionais comerciais para PC.
223
224 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
225 avançados e que querem mais recursos de seu boot loader.
226
227 %package -n bash-completion-%{name}
228 Summary:        bash-completion for GRUB
229 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
230 Group:          Applications/Shells
231 Requires:       bash-completion
232 %if "%{_rpmversion}" >= "5"
233 BuildArch:      noarch
234 %endif
235
236 %description -n bash-completion-%{name}
237 This package provides bash-completion for GRUB.
238
239 %description -n bash-completion-%{name} -l pl.UTF-8
240 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
241
242 %package platform-pc
243 Summary:        PC BIOS platform support for GRUB
244 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
245 Group:          Base
246 Provides:       %{name}-platform = %{version}-%{release}
247
248 %description platform-pc
249 PC BIOS platform support for GRUB.
250
251 %description platform-pc -l pl.UTF-8
252 Obsługa platformy PC BIOS dla GRUB-a.
253
254 %package platform-efi
255 Summary:        (U)EFI platform support for GRUB
256 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
257 Group:          Base
258 Suggests:       efibootmgr
259 Provides:       %{name}-platform = %{version}-%{release}
260
261 %description platform-efi
262 (U)EFI platform support for GRUB.
263
264 %description platform-efi -l pl.UTF-8
265 Obsługa platformy (U)EFI dla GRUB-a.
266
267 %package mkfont
268 Summary:        GRUB font files converter
269 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
270 Group:          Base
271
272 %description mkfont
273 Converts common font file formats into PF2.
274
275 %description mkfont -l pl.UTF-8
276 Program do konwersji popularnych formatów plików fontów do PF2.
277
278 %package theme-starfield
279 Summary:        starfield theme for GRUB
280 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
281 Group:          Base
282
283 %description theme-starfield
284 starfield theme for GRUB.
285
286 %description theme-starfield -l pl.UTF-8
287 Motyw starfield dla GRUB-a.
288
289 %prep
290 %setup -q -n grub-%{version}
291 %patch1 -p1
292 %patch2 -p1
293 %patch3 -p1
294 %patch4 -p1
295 %patch5 -p1
296 %patch6 -p1
297 %patch7 -p1
298 %patch8 -p1
299 %patch9 -p1
300 %patch10 -p1
301 %patch11 -p1
302 %patch12 -p0
303 %patch13 -p1
304 %patch14 -p1
305 %patch15 -p1
306 %patch16 -p1
307 %patch17 -p1
308
309 # we don't have C.utf-8 and need an UTF-8 locale for build
310 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
311
312 %build
313 # if gold is used then grub doesn't even boot
314 # https://savannah.gnu.org/bugs/?34539
315 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
316 install -d our-ld
317 ln -f -s /usr/bin/ld.bfd our-ld/ld
318 export PATH=$(pwd)/our-ld:$PATH
319
320 ## not only the typicall autotools stuff
321 #./autogen.sh
322
323 #{__gettextize}
324 %{__aclocal} -I m4
325 %{__autoconf}
326 %{__autoheader}
327 %{__automake}
328
329 for platform in %{platforms} ; do
330         install -d build-${platform}
331         cd build-${platform}
332
333         if [ "$platform" != "efi" ] ; then
334                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
335         else
336                 platform_opts=""
337         fi
338
339         ln -f -s ../configure .
340         # mawk stalls at ./genmoddep.awk, so force gawk
341         AWK=gawk \
342         %configure \
343                 --with-platform=${platform} \
344                 --disable-werror \
345                 --enable-grub-themes \
346         %if %{with grubemu}
347                 --enable-grub-emu-usb \
348                 --enable-grub-emu-sdl \
349                 --enable-grub-emu-pci \
350         %endif
351                 $platform_opts \
352                 TARGET_LDFLAGS=-static
353
354         %{__make} -j1 -C po update-gmo
355         %{__make}
356         cd ..
357 done
358
359 %install
360 rm -rf $RPM_BUILD_ROOT
361
362 for platform in %{platforms} ; do
363         cd build-${platform}
364         %{__make} install \
365                 pkgdatadir=%{_libexecdir} \
366                 pkglibdir=%{_libexecdir} \
367                 DESTDIR=$RPM_BUILD_ROOT
368         cd ..
369 done
370
371 # not in Th (?)
372 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
373 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
374
375 %find_lang grub
376
377 # this must be after 'make install'
378 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
379
380 install -d $RPM_BUILD_ROOT%{_grubdir}
381 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
382
383 # grub.d/41_custom
384 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
385 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
386
387 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
388 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
389
390 install -d $RPM_BUILD_ROOT/etc/sysconfig
391 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
392
393 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
394 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
395
396 # platform specific, unnecessarily always installed
397 %ifnarch %{ix86} %{x8664} x32
398 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
399 %endif
400 %ifnarch sparc64
401 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
402 %endif
403
404 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
405 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
406 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
407
408 # needs to be exactly 1KiB
409 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
410 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
411
412 %clean
413 rm -rf $RPM_BUILD_ROOT
414
415 %post -p %{_sbindir}/postshell
416 -/usr/sbin/fix-info-dir -c %{_infodir}
417
418 %postun -p %{_sbindir}/postshell
419 -/usr/sbin/fix-info-dir -c %{_infodir}
420
421 %triggerpostun -- %{name} < 2.00-2
422 # Note this trigger on version upgrade needed only for upgrade from
423 # old grub2 packages which contained modules in /boot/grub
424 # or were built with optimizations enabled
425 # don't do anything on --downgrade
426 if [ $1 -le 1 ]; then
427         exit 0
428 fi
429 echo "Grub was upgraded, trying to setup it to boot sector"
430 /sbin/grub-install '(hd0)' || :
431
432 %triggerpostun -- %{name} < 1.99-7.3
433 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
434 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
435         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
436         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
437 fi
438
439 %files -f grub.lang
440 %defattr(644,root,root,755)
441 %doc AUTHORS ChangeLog NEWS README THANKS TODO
442 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
443 %attr(755,root,root) %{_sbindir}/grub-editenv
444 %attr(755,root,root) %{_sbindir}/grub-fstest
445 %attr(755,root,root) %{_sbindir}/grub-file
446 %attr(755,root,root) %{_sbindir}/grub-glue-efi
447 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
448 %attr(755,root,root) %{_sbindir}/grub-install
449 %attr(755,root,root) %{_sbindir}/grub-macbless
450 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
451 %attr(755,root,root) %{_sbindir}/grub-mkconfig
452 %attr(755,root,root) %{_sbindir}/grub-mklayout
453 %attr(755,root,root) %{_sbindir}/grub-mknetdir
454 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
455 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
456 %attr(755,root,root) %{_sbindir}/grub-mkrescue
457 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
458 %attr(755,root,root) %{_sbindir}/grub-mount
459 %attr(755,root,root) %{_sbindir}/grub-ofpathname
460 %attr(755,root,root) %{_sbindir}/grub-reboot
461 %attr(755,root,root) %{_sbindir}/grub-render-label
462 %attr(755,root,root) %{_sbindir}/grub-script-check
463 %attr(755,root,root) %{_sbindir}/grub-set-default
464 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
465 %attr(755,root,root) %{_sbindir}/update-grub
466 %ifarch %{ix86} %{x8664} x32
467 %attr(755,root,root) %{_sbindir}/grub-bios-setup
468 %{_mandir}/man8/grub-bios-setup.8*
469 %endif
470 %ifarch %{ix86} %{x8664} x32
471 %attr(755,root,root) %{_sbindir}/grub-mkimage
472 %{_mandir}/man1/grub-mkimage.1*
473 %else
474 %attr(755,root,root) %{_sbindir}/grub-probe
475 %{_mandir}/man8/grub-probe.8*
476 %endif
477 %ifarch sparc64
478 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
479 %{_mandir}/man8/grub-sparc64-setup.8*
480 %endif
481 %{_mandir}/man1/grub-editenv.1*
482 %{_mandir}/man1/grub-file.1*
483 %{_mandir}/man1/grub-fstest.1*
484 %{_mandir}/man1/grub-glue-efi.1*
485 %{_mandir}/man1/grub-kbdcomp.1*
486 %{_mandir}/man1/grub-menulst2cfg.1*
487 %{_mandir}/man1/grub-mklayout.1*
488 %{_mandir}/man1/grub-mknetdir.1*
489 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
490 %{_mandir}/man1/grub-mkrelpath.1*
491 %{_mandir}/man1/grub-mkrescue.1*
492 %{_mandir}/man1/grub-mkstandalone.1*
493 %{_mandir}/man1/grub-mount.1*
494 %{_mandir}/man1/grub-render-label.1*
495 %{_mandir}/man1/grub-script-check.1*
496 %{_mandir}/man1/grub-syslinux2cfg.1*
497 %{_mandir}/man8/grub-install.8*
498 %{_mandir}/man8/grub-macbless.8*
499 %{_mandir}/man8/grub-mkconfig.8*
500 %{_mandir}/man8/grub-ofpathname.8*
501 %{_mandir}/man8/grub-reboot.8*
502 %{_mandir}/man8/grub-set-default.8*
503 %{_mandir}/man8/update-grub.8*
504 %if %{with grubemu}
505 %attr(755,root,root) %{_sbindir}/grub-emu
506 %{_mandir}/man8/grub-emu.8*
507 %endif
508 %{_libexecdir}/grub-mkconfig_lib
509
510 %dir %{_grubdir}
511 %dir %{_libexecdir}
512 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
513
514 %dir %{_libexecdir}/locale
515 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
516 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
517
518 # generated by grub at runtime
519 %ghost %{_grubdir}/device.map
520 %ghost %{_grubdir}/core.img
521 %ghost %{_grubdir}/grubenv
522
523 %dir /lib/grub.d
524 %doc /lib/grub.d/README
525 %attr(755,root,root) /lib/grub.d/00_header
526 %attr(755,root,root) /lib/grub.d/10_linux
527 %attr(755,root,root) /lib/grub.d/20_linux_xen
528 %attr(755,root,root) /lib/grub.d/30_os-prober
529 %attr(755,root,root) /lib/grub.d/41_custom
530
531 # these are now installed only on matching hosts
532 #%attr(755,root,root) /lib/grub.d/10_hurd
533 #%attr(755,root,root) /lib/grub.d/10_illumos
534 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
535 #%attr(755,root,root) /lib/grub.d/10_netbsd
536 #%attr(755,root,root) /lib/grub.d/10_xnu
537
538 %ifarch %{ix86} %{x8664} x32
539 %attr(755,root,root) %{_sbindir}/grub-probe
540 %{_mandir}/man8/grub-probe.8*
541 %endif
542
543 %{_infodir}/grub*.info*
544
545 %dir %{_datadir}/grub/themes
546
547 %if %{with pc}
548 %files platform-pc
549 %defattr(644,root,root,755)
550 %dir %{_libexecdir}/*-pc
551 %{_libexecdir}/*-pc/modinfo.sh
552 %{_libexecdir}/*-pc/*.exec
553 %{_libexecdir}/*-pc/*.image
554 %{_libexecdir}/*-pc/*.lst
555 %{_libexecdir}/*-pc/*.mod
556 %{_libexecdir}/*-pc/*.module
557 %{_libexecdir}/*-pc/lzma_decompress.img
558 %{_libexecdir}/*-pc/config.h
559 %{_libexecdir}/*-pc/gdb_grub
560 %{_libexecdir}/*-pc/gmodule.pl
561 %if %{with efiemu}
562 %{_libexecdir}/*-pc/efiemu*.o
563 %endif
564 %{_libexecdir}/*-pc/kernel.img
565 %ifarch %{ix86} %{x8664} x32 sparc sparc64
566 %{_libexecdir}/*-pc/boot.img
567 %{_libexecdir}/*-pc/boot_hybrid.img
568 %{_libexecdir}/*-pc/cdboot.img
569 %{_libexecdir}/*-pc/diskboot.img
570 %{_libexecdir}/*-pc/lnxboot.img
571 %{_libexecdir}/*-pc/pxeboot.img
572 %endif
573 %endif
574
575 %if %{with efi}
576 %files platform-efi
577 %defattr(644,root,root,755)
578 %dir %{_libexecdir}/*-efi
579 %{_libexecdir}/*-efi/modinfo.sh
580 %{_libexecdir}/*-efi/*.exec
581 %{_libexecdir}/*-efi/*.lst
582 %{_libexecdir}/*-efi/*.mod
583 %{_libexecdir}/*-efi/*.module
584 %{_libexecdir}/*-efi/config.h
585 %{_libexecdir}/*-efi/gdb_grub
586 %{_libexecdir}/*-efi/gmodule.pl
587 %{_libexecdir}/*-efi/kernel.img
588 %endif
589
590 %files mkfont
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_sbindir}/grub-mkfont
593 %{_mandir}/man1/grub-mkfont.1*
594
595 %files theme-starfield
596 %defattr(644,root,root,755)
597 %{_datadir}/grub/themes/starfield
598
599 %files -n bash-completion-%{name}
600 %defattr(644,root,root,755)
601 /etc/bash_completion.d/grub
This page took 0.184891 seconds and 2 git commands to generate.