]> git.pld-linux.org Git - packages/grive2.git/blob - grive.spec
- added json-c-0.14 patch; rel 31
[packages/grive2.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # bash: %%(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 %define         rel             31
6 Summary:        An open source Linux client for Google Drive
7 Summary(pl.UTF-8):      Linuksowy, mające otwarte źródła klient Google Drive
8 Name:           grive
9 Version:        0.3.0
10 Release:        0.%{cdate}git%{shortcommit}.%{rel}
11 License:        GPL v2
12 Group:          Applications/Networking
13 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
14 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
15 # https://github.com/Grive/grive/issues/187
16 Patch0:         json-c.patch
17 Patch1:         %{name}-bgrive_cmake_fix.patch
18 Patch2:         build.patch
19 Patch3:         binutils-2.34.patch
20 Patch4:         %{name}-json-c-0.14.patch
21 URL:            https://github.com/Grive/grive
22 BuildRequires:  QtCore-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  binutils-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  cmake
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  json-c-devel >= 0.11
30 BuildRequires:  libgcrypt-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  yajl-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The purpose of this project is to provide an independent
38 implementation of Google Drive client. It uses the Google Document
39 List API to talk to the servers in Google.
40
41 %description -l pl.UTF-8
42 Celem tego projektu jest zapewnienie niezależnej implementacji klienta
43 Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
44 Google Document List.
45
46 %package -n bgrive
47 Summary:        Qt frontend for Grive
48 Summary(pl.UTF-8):      Interfejs Qt do Grive
49 Group:          Applications/Networking
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n bgrive
53 GUI frontend for Grive.
54
55 %description -n bgrive -l pl.UTF-8
56 Graficzny interfejs użytkownika do Grive.
57
58 %prep
59 %setup -q -n %{name}-%{commit}
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63 %patch3 -p1
64 %patch4 -p1
65
66 %build
67 install -d build
68 cd build
69 %cmake ..
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README
84 %attr(755,root,root) %{_bindir}/grive
85 %{_mandir}/man1/grive.1*
86
87 %files -n bgrive
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.125479 seconds and 3 git commands to generate.