]> git.pld-linux.org Git - packages/grive2.git/commitdiff
- added json-c-0.14 patch; rel 31
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 May 2020 07:51:35 +0000 (09:51 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 May 2020 07:51:35 +0000 (09:51 +0200)
grive-json-c-0.14.patch [new file with mode: 0644]
grive.spec

diff --git a/grive-json-c-0.14.patch b/grive-json-c-0.14.patch
new file mode 100644 (file)
index 0000000..344b4bd
--- /dev/null
@@ -0,0 +1,64 @@
+--- grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc.orig  2020-05-02 09:07:09.733415940 +0200
++++ grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc       2020-05-02 09:11:48.378573057 +0200
+@@ -254,7 +254,7 @@
+ bool Json::Has( const std::string& key ) const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_object_get_ex( m_json, key.c_str(), 0 ) == TRUE ;
++      return ::json_object_object_get_ex( m_json, key.c_str(), 0 ) == 1 ;
+ }
+ bool Json::Get( const std::string& key, Json& json ) const
+@@ -294,14 +294,14 @@
+ bool Json::Bool() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_get_boolean( m_json ) == TRUE ;
++      return ::json_object_get_boolean( m_json ) == 1 ;
+ }
+ template <>
+ bool Json::Is<bool>() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_is_type( m_json, json_type_boolean ) == TRUE ;
++      return ::json_object_is_type( m_json, json_type_boolean ) == 1 ;
+ }
+ template <>
+@@ -320,7 +320,7 @@
+ bool Json::Is<std::string>() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_is_type( m_json, json_type_string ) == TRUE ;
++      return ::json_object_is_type( m_json, json_type_string ) == 1 ;
+ }
+ template <>
+@@ -339,7 +339,7 @@
+ bool Json::Is<int>() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_is_type( m_json, json_type_int ) == TRUE ;
++      return ::json_object_is_type( m_json, json_type_int ) == 1 ;
+ }
+ template <>
+@@ -402,7 +402,7 @@
+ bool Json::Is<Json::Object>() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_is_type( m_json, json_type_object ) == TRUE ;
++      return ::json_object_is_type( m_json, json_type_object ) == 1 ;
+ }
+ template <>
+@@ -426,7 +426,7 @@
+ bool Json::Is<Json::Array>() const
+ {
+       assert( m_json != 0 ) ;
+-      return ::json_object_is_type( m_json, json_type_array ) == TRUE ;
++      return ::json_object_is_type( m_json, json_type_array ) == 1 ;
+ }
+ template <>
index 1eb9b637465129d0792f30e18ae2bf68e719333f..c931472c80fa0ae76c074298249a08bd96573ddc 100644 (file)
@@ -2,7 +2,7 @@
 # bash: %%(c=%{commit}; echo ${c:0:7})
 %define                shortcommit     27817e8
 %define                cdate           20130702
-%define                rel             30
+%define                rel             31
 Summary:       An open source Linux client for Google Drive
 Summary(pl.UTF-8):     Linuksowy, mające otwarte źródła klient Google Drive
 Name:          grive
@@ -17,7 +17,8 @@ Patch0:               json-c.patch
 Patch1:                %{name}-bgrive_cmake_fix.patch
 Patch2:                build.patch
 Patch3:                binutils-2.34.patch
-URL:           http://www.lbreda.com/grive/
+Patch4:                %{name}-json-c-0.14.patch
+URL:           https://github.com/Grive/grive
 BuildRequires: QtCore-devel
 BuildRequires: QtGui-devel
 BuildRequires: binutils-devel
@@ -60,6 +61,7 @@ Graficzny interfejs użytkownika do Grive.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 install -d build
@@ -69,6 +71,7 @@ cd build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -78,8 +81,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README
-%attr(755,root,root) %{_bindir}/%{name}
-%{_mandir}/man1/%{name}.1*
+%attr(755,root,root) %{_bindir}/grive
+%{_mandir}/man1/grive.1*
 
 %files -n bgrive
 %defattr(644,root,root,755)
This page took 0.204829 seconds and 4 git commands to generate.