]> git.pld-linux.org Git - packages/glibc.git/commitdiff
Up to 2.37.
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Feb 2023 07:59:53 +0000 (08:59 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 2 Feb 2023 07:59:53 +0000 (08:59 +0100)
branch.sh
glibc-locale_fixes.patch
glibc-no-bash-nls.patch
glibc.spec

index 26833991c3ac37144d02cf9091643cc9a00920bb..213fda0a2643632048b4889614491857b2fff916 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://sourceware.org/git/glibc.git
 package=glibc
-tag=glibc-2.36
-branch=release/2.36/master
+tag=glibc-2.37
+branch=release/2.37/master
 out=$package-git.patch
 repo=$package.git
 
index 5b14b6c361d48bb74d0cff9e9a4e5c86023ba3c8..0dd447bc7e3510cc7ece875e9c92df9213ba3ac1 100644 (file)
@@ -1291,7 +1291,7 @@ diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_BE glibc-2.33/locale
 +country_post "B"
 +% (French language)
 +country_isbn "2"
- lang_name "fran<U00E7>ais"
+ lang_name "français"
  lang_ab      "fr"
  lang_term    "fra"
 diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_CA glibc-2.33/localedata/locales/fr_CA
@@ -1305,7 +1305,7 @@ diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_CA glibc-2.33/locale
 +country_car  "CDN"
 +% (French language)
 +country_isbn "2"
- lang_name "fran<U00E7>ais"
+ lang_name "français"
  lang_ab      "fr"
  lang_term    "fra"
 diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_CH glibc-2.33/localedata/locales/fr_CH
@@ -1316,7 +1316,7 @@ diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_CH glibc-2.33/locale
  country_num 756
  country_car "CH"
 +country_isbn "2"
- lang_name "fran<U00E7>ais"
+ lang_name "français"
  lang_ab      "fr"
  lang_term    "fra"
 diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_LU glibc-2.33/localedata/locales/fr_LU
@@ -1327,7 +1327,7 @@ diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fr_LU glibc-2.33/locale
  country_num 442
  country_car "L"
 +country_isbn "99959"
- lang_name "fran<U00E7>ais"
+ lang_name "français"
  lang_ab      "fr"
  lang_term    "fra"
 diff -urNp -x '*.orig' glibc-2.33.org/localedata/locales/fur_IT glibc-2.33/localedata/locales/fur_IT
index 40ecb7e5276bb9228643ff56480a3872df66d1f6..35c6c583446cb12c1acbaf97b8e119320e717ec2 100644 (file)
@@ -3,7 +3,7 @@
 @@ -1,4 +1,4 @@
 -#!/bin/bash
 +#!/bin/sh
- # Copyright (C) 1996-2022 Free Software Foundation, Inc.
+ # Copyright (C) 1996-2023 Free Software Foundation, Inc.
  # This file is part of the GNU C Library.
  
 @@ -35,16 +35,16 @@
@@ -14,7 +14,7 @@
 +    printf "Copyright (C) %s Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- " "2022"
+ " "2023"
 -    printf $"Written by %s and %s.
 +    printf "Written by %s and %s.
  " "Roland McGrath" "Ulrich Drepper"
 @@ -1,4 +1,4 @@
 -#!/bin/bash
 +#!/bin/sh
- # Copyright (C) 2011-2022 Free Software Foundation, Inc.
+ # Copyright (C) 2011-2023 Free Software Foundation, Inc.
  # This file is part of the GNU C Library.
  
 @@ -29,7 +29,7 @@
 +    printf "Copyright (C) %s Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- " "2022"
+ " "2023"
 -    printf $"Written by %s.\n" "Ulrich Drepper"
 +    printf "Written by %s.\n" "Ulrich Drepper"
      exit 0
index d12f00e4d95395e1cb040eed4cf066dd10ebe962..923337c9271b55232a853862b3e027c6c7fc39dd 100644 (file)
@@ -43,7 +43,7 @@
 %define                with_static_pie         1
 %endif
 
-%define                core_version    2.36
+%define                core_version    2.37
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -57,12 +57,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       7
+Release:       1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 00e9b89e043340f688bc93ec03239b57
+# Source0-md5: e89cf3dcb64939d29f04b4ceead5cc4e
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -73,8 +73,8 @@ Source6:      %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
-Patch0:                glibc-git.patch
-# Patch0-md5:  5cb264ee1f74fd0dfd09aff653c82cba
+#Patch0:               glibc-git.patch
+# Patch0-md5:  d41d8cd98f00b204e9800998ecf8427e
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -952,7 +952,7 @@ echo "Minimal supported kernel is 3.2.0" >&2
 exit 1
 %endif
 
-%patch0 -p1
+#%patch0 -p1
 
 %patch2 -p1
 %patch3 -p1
This page took 0.107765 seconds and 4 git commands to generate.