]> git.pld-linux.org Git - packages/glibc.git/commitdiff
on %{arm} disable GLIBC_ABI_DT_RELR enforcement when DT_RELR is used
authorJan Palus <atler@pld-linux.org>
Wed, 4 Jan 2023 23:29:14 +0000 (00:29 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 4 Jan 2023 23:29:14 +0000 (00:29 +0100)
temporary fix to get widevine working. avoids error:

DT_RELR without GLIBC_ABI_DT_RELR dependency

arm-widevine-compat.patch [new file with mode: 0644]
glibc.spec

diff --git a/arm-widevine-compat.patch b/arm-widevine-compat.patch
new file mode 100644 (file)
index 0000000..4d4c8c7
--- /dev/null
@@ -0,0 +1,11 @@
+--- glibc-2.36/elf/dl-version.c.orig   2022-07-30 00:03:09.000000000 +0200
++++ glibc-2.36/elf/dl-version.c        2023-01-05 00:26:06.757658528 +0100
+@@ -362,7 +362,7 @@
+   /* When there is a DT_VERNEED entry with libc.so on DT_NEEDED, issue
+      an error if there is a DT_RELR entry without GLIBC_ABI_DT_RELR
+      dependency.  */
+-  if (dyn != NULL
++  if (0 && dyn != NULL
+       && map->l_info[DT_NEEDED] != NULL
+       && map->l_info[DT_RELR] != NULL
+       && __glibc_unlikely (!map->l_dt_relr_ref))
index 09a440235101d80a3edcb70f9ec2f36880b6a134..d12f00e4d95395e1cb040eed4cf066dd10ebe962 100644 (file)
@@ -97,6 +97,7 @@ Patch19:      %{name}-ZA_collate.patch
 Patch23:       %{name}-pt_pax.patch
 
 Patch30:       glibc-rh1124987.patch
+Patch31:       arm-widevine-compat.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf >= 2.69
@@ -972,6 +973,9 @@ exit 1
 %patch23 -p0
 
 %patch30 -p1
+%ifarch %{arm}
+%patch31 -p1
+%endif
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 0.063955 seconds and 4 git commands to generate.