]> git.pld-linux.org Git - packages/gitlab-runner.git/blob - gitlab-ci-multi-runner.spec
fix of missing Asset
[packages/gitlab-runner.git] / gitlab-ci-multi-runner.spec
1 Summary:        The official GitLab CI runner written in Go
2 Name:           gitlab-ci-multi-runner
3 Version:        1.1.0
4 Release:        1
5 License:        GPL v3
6 Group:          Development/Building
7 Source0:        https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/repository/archive.tar.gz?ref=v%{version}&/%{name}-%{version}.tar.gz
8 # Source0-md5:  4145931bc59d40e32df6ee24e15a19d3
9 Source1:        https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt.tar.gz
10 # Source1-md5:  d616dcc457a6ce69bed4af2ca08dfe0a
11 URL:            https://gitlab.com/gitlab-org/gitlab-ci-multi-runner
12 BuildRequires:  git-core
13 BuildRequires:  go-bindata >= 3.0.7-1.a0ff2567
14 BuildRequires:  golang
15 Requires:       ca-certificates
16 Requires:       curl
17 Requires:       git-core
18 Requires:       tar
19 ExclusiveArch:  %{ix86} %{x8664} %{arm}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # go stuff
23 %define _enable_debug_packages 0
24 %define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
25
26 %description
27 This is the official GitLab Runner written in Go. It runs tests and
28 sends the results to GitLab. GitLab CI is the open-source continuous
29 integration service included with GitLab that coordinates the testing.
30
31 %prep
32 %setup -qc
33 mv gitlab-ci-multi-runner-*/{.??*,*} .
34
35 install -d Godeps/_workspace/src/gitlab.com/gitlab-org
36 ln -s ../../../../.. Godeps/_workspace/src/gitlab.com/gitlab-org/gitlab-ci-multi-runner
37
38 mkdir -p out/docker
39 ln -s %{SOURCE1} out/docker/prebuilt.tar.gz
40
41 %build
42 export GOPATH=$(pwd):$(pwd)/Godeps/_workspace
43
44 %{__make} docker
45 %gobuild
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_bindir}
50 install -p %{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README.md CHANGELOG.md
58 %attr(755,root,root) %{_bindir}/gitlab-ci-multi-runner
This page took 0.068485 seconds and 3 git commands to generate.