]> git.pld-linux.org Git - packages/gitlab-runner.git/commitdiff
fix of missing Asset
authorElan Ruusamäe <glen@delfi.ee>
Thu, 31 Mar 2016 19:20:12 +0000 (22:20 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 31 Mar 2016 19:20:12 +0000 (22:20 +0300)
by embedding docker prebuilt images

executor_docker.go missing Asset symbol:
https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/blob/master/docs/development/README.md#troubleshooting

gitlab-ci-multi-runner.spec

index a3d403bddaf0fc4db03d56e84019a3ca89ac095b..9d6714818dfe615e864ff745680431c28abd15e8 100644 (file)
@@ -1,20 +1,28 @@
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-ci-multi-runner
 Version:       1.1.0
-Release:       0.1
+Release:       1
 License:       GPL v3
 Group:         Development/Building
 Source0:       https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/repository/archive.tar.gz?ref=v%{version}&/%{name}-%{version}.tar.gz
 # Source0-md5: 4145931bc59d40e32df6ee24e15a19d3
+Source1:       https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt.tar.gz
+# Source1-md5: d616dcc457a6ce69bed4af2ca08dfe0a
 URL:           https://gitlab.com/gitlab-org/gitlab-ci-multi-runner
 BuildRequires: git-core
+BuildRequires: go-bindata >= 3.0.7-1.a0ff2567
 BuildRequires: golang
 Requires:      ca-certificates
 Requires:      curl
 Requires:      git-core
 Requires:      tar
+ExclusiveArch: %{ix86} %{x8664} %{arm}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# go stuff
+%define _enable_debug_packages 0
+%define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
+
 %description
 This is the official GitLab Runner written in Go. It runs tests and
 sends the results to GitLab. GitLab CI is the open-source continuous
@@ -27,13 +35,19 @@ mv gitlab-ci-multi-runner-*/{.??*,*} .
 install -d Godeps/_workspace/src/gitlab.com/gitlab-org
 ln -s ../../../../.. Godeps/_workspace/src/gitlab.com/gitlab-org/gitlab-ci-multi-runner
 
+mkdir -p out/docker
+ln -s %{SOURCE1} out/docker/prebuilt.tar.gz
+
 %build
 export GOPATH=$(pwd):$(pwd)/Godeps/_workspace
 
-go build
+%{__make} docker
+%gobuild
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -p %{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -41,3 +55,4 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md CHANGELOG.md
+%attr(755,root,root) %{_bindir}/gitlab-ci-multi-runner
This page took 0.051071 seconds and 4 git commands to generate.