]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- verbose make
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.3.2
12 Release:        2
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  902f7f07a789fedc0d2ac03656b85969
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}-gitweb-lighttpd.conf
20 Source4:        %{name}.sysconfig
21 Source5:        %{name}.inet
22 Source6:        %{name}.init
23 Patch0:         %{name}-tests.patch
24 Patch1:         %{name}-libcrypto.patch
25 URL:            http://git-scm.com/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  curl-devel
29 BuildRequires:  expat-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  perl-Error > 0.15
33 BuildRequires:  perl-base
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.264
38 BuildRequires:  zlib-devel
39 %if %{with doc}
40 BuildRequires:  asciidoc >= 7.1.2-3
41 BuildRequires:  docbook-dtd45-xml
42 BuildRequires:  xmlto
43 %endif
44 %if %{with tests}
45 %if %{with tests_cvs}
46 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
47 BuildRequires:  cvs-gnu-client < 1.13
48 BuildRequires:  cvs-gnu-client >= 1.12
49 %endif
50 BuildRequires:  pdksh >= 5.2.14-46
51 %endif
52 Requires:       coreutils
53 Requires:       diffutils
54 Requires:       findutils
55 Requires:       grep
56 Requires:       openssh-clients
57 Requires:       perl-Error
58 Requires:       sed
59 Suggests:       git-core-cvs
60 Suggests:       git-core-svn
61 Suggests:       less
62 Suggests:       rsync
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # html docs have links to txt files
66 %define         _noautocompressdoc      *.txt
67
68 %define         webapp          gitweb
69 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
70 %define         appdir          %{_datadir}/%{webapp}
71 %define         cgibindir       %{_prefix}/lib/cgi-bin
72
73 %description
74 "git" can mean anything, depending on your mood.
75
76 - random three-letter combination that is pronounceable, and not
77   actually used by any common UNIX command. The fact that it is a
78   mispronunciation of "get" may or may not be relevant.
79 - stupid. contemptible and despicable. simple. Take your pick from the
80   dictionary of slang.
81 - "global information tracker": you're in a good mood, and it actually
82   works for you. Angels sing, and a light suddenly fills the room.
83 - "goddamn idiotic truckload of sh*t": when it breaks
84
85 This is a stupid (but extremely fast) directory content manager. It
86 doesn't do a whole lot, but what it 'does' do is track directory
87 contents efficiently.
88
89 %description -l pl.UTF-8
90 "git" może oznaczać cokolwiek, w zależności od nastroju.
91
92 - losową kombinację trzech liter, która jest wymawialna i właściwie
93   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
94   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
95 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
96 - "global information tracker" (narzędzie do globalnego śledzenia
97   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
98   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
99 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
100   g*) - kiedy się zepsuje.
101
102 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
103 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
104 katalogu.
105
106 %package doc
107 Summary:        Documentation for git-core
108 Summary(pl.UTF-8):      Dokumentacja do git-core
109 Group:          Documentation
110
111 %description doc
112 Documentation for git-core.
113
114 %description doc -l pl.UTF-8
115 Dokumentacja do git-core.
116
117 %description doc -l fr.UTF-8
118 Javadoc pour git-core.
119
120 %package daemon-inetd
121 Summary:        Files necessary to run git-daemon as an inetd service
122 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
123 Group:          Networking/Daemons
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       setup >= 2.4.11-1
126 Provides:       git-core-daemon
127 Obsoletes:      git-core-daemon
128 Obsoletes:      git-core-daemon-standalone
129
130 %description daemon-inetd
131 Git-daemon is a really simple TCP git daemon that can serve git
132 repositories. This package provides all necessarry files to run
133 git-daemon as an inetd service.
134
135 %description daemon-inetd -l pl.UTF-8
136 Git-daemon to prosty demon git korzystający z protokołu TCP do
137 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
138 do uruchomienia git-demona w trybie usługi inetd.
139
140 %package daemon-standalone
141 Summary:        Files necessary to run git-daemon as a standalone service
142 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
143 Group:          Networking/Daemons
144 Requires:       %{name} = %{version}-%{release}
145 Provides:       git-core-daemon
146 Obsoletes:      git-core-daemon
147 Obsoletes:      git-core-daemon-inetd
148
149 %description daemon-standalone
150 Git-daemon is a really simple TCP git daemon that can serve git
151 repositories. This package provides all necessarry files to run
152 git-daemon as an standalone service.
153
154 %description daemon-standalone -l pl.UTF-8
155 Git-daemon to prosty demon git korzystający z protokołu TCP do
156 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
157 do uruchomienia git-daemona w trybie usługi samodzielnej.
158
159 %package devel
160 Summary:        Header files for git-core
161 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
162 Group:          Development/Libraries
163 Requires:       zlib-devel
164
165 %description devel
166 Header files for git-core.
167
168 %description devel -l pl.UTF-8
169 Pliki nagłówkowe dla git-core.
170
171 %package gitk
172 Summary:        Tcl/Tk interface to the Git version control system
173 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
174 Group:          Development/Tools
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       tk
177
178 %description gitk
179 gitk displays changes in a repository or a selected set of commits.
180 This includes visualizing the commit graph, showing information
181 related to each commit, and the files in the trees of each revision.
182
183 Historically, gitk was the first repository browser. It's written in
184 Tcl/Tk and started off in a separate repository but was later merged
185 into the main git repository.
186
187 %description gitk -l pl.UTF-8
188 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
189 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
190 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
191
192 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
193 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
194 osobnym repozytorium, ale z czasem został włączony do głównego
195 repozytorium gita.
196
197 %package gitweb
198 Summary:        Web frontend to git
199 Summary(pl.UTF-8):      Webowy frontend do git
200 Group:          Development/Tools
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       webapps
203 Requires:       webserver(alias)
204 Requires:       webserver(cgi)
205
206 %description gitweb
207 This package provides a web interface for browsing git repositories.
208
209 %description gitweb -l pl.UTF-8
210 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
211
212 %package gitview
213 Summary:        A GTK+ based repository browser for git
214 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       python >= 1:2.4
218 Requires:       python-pycairo >= 1.0
219 Requires:       python-pygobject
220 Requires:       python-pygtk-gtk >= 2:2.8
221 Suggests:       python-gnome-desktop-gtksourceview
222
223 %description gitview
224 A GTK+ based repository browser for git.
225
226 %description gitview -l pl.UTF-8
227 Oparta na GTK+ przeglądarka repozytorium gita.
228
229 %package gui
230 Summary:        Tcl/Tk interface to the Git version control system
231 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       tk
235 Requires:       xdg-utils
236 Suggests:       meld
237
238 %description gui
239 Displays changes in a repository or a selected set of commits. This
240 includes visualizing the commit graph, showing information related to
241 each commit, and the files in the trees of each revision.
242
243 Historically, gitk was the first repository browser. It's written in
244 Tcl/Tk and started off in a separate repository but was later merged
245 into the main git repository.
246
247 %description gui -l pl.UTF-8
248 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
249 to wizualizację grafu commitów, wyświetlanie informacji związanych z
250 każdym z commitów oraz listę plików dla każdej rewizji.
251
252 Z punktu widzenia historii, gitk był pierwszą przeglądarką
253 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
254 osobnym repozytorium, ale z czasem został włączony do głównego
255 repozytorium gita.
256
257 %package svn
258 Summary:        Subversion support for Git
259 Summary(pl.UTF-8):      Obsługa Subversion dla Git
260 Group:          Development/Tools
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       perl-Term-ReadKey
263
264 %description svn
265 Subversion support for Git.
266
267 %description svn -l pl.UTF-8
268 Obsługa Subversion dla Git.
269
270 %package cvs
271 Summary:        CVS support for Git
272 Summary(pl.UTF-8):      Obsługa CVS dla Git
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       cvsps >= 2.1-2
276 Requires:       rcs
277
278 %description cvs
279 CVS support for Git.
280
281 %description cvs -l pl.UTF-8
282 Obsługa CVS dla Git.
283
284 %package arch
285 Summary:        Git tools for importing Arch repositories
286 Group:          Development/Tools
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       tla
289
290 %description arch
291 Git tools for importing Arch repositories.
292
293 %package email
294 Summary:        Git tools for sending email
295 Group:          Development/Tools
296 Requires:       %{name} = %{version}-%{release}
297
298 %description email
299 Git tools for sending email.
300
301 %package -n bash-completion-git
302 Summary:        bash-completion for git
303 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
304 Group:          Applications/Shells
305 Requires:       bash-completion
306
307 %description -n bash-completion-git
308 This package provides bash-completion for git.
309
310 %description -n bash-completion-git -l pl.UTF-8
311 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
312
313 %package -n perl-Git
314 Summary:        Perl interface to the Git version control system
315 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
316 Group:          Development/Languages/Perl
317 Obsoletes:      perl-git-core
318
319 %description -n perl-Git
320 This module provides Perl scripts easy way to interface the Git
321 version control system. The modules have an easy and well-tested way
322 to call arbitrary Git commands; in the future, the interface will also
323 provide specialized methods for doing easily operations which are not
324 totally trivial to do over the generic command interface.
325
326 %description -n perl-Git -l pl.UTF-8
327 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
328 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
329 dowolne polecenia Gita; w przyszłości interfejs udostępni także
330 specjalne metody do łatwego wykonywania operacji nietrywialnych do
331 wykonania przy użyciu ogólnego interfejsu poleceń.
332
333 %package -n python-Git
334 Summary:        Python interface to the Git version control system
335 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
336 Group:          Development/Languages/Python
337
338 %description -n python-Git
339 This module provides Python scripts easy way to interface the Git
340 version control system.
341
342 %description -n python-Git -l pl.UTF-8
343 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
344 wersji Git.
345
346 %package -n vim-syntax-gitcommit
347 Summary:        Vim syntax: gitcommit
348 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
349 Group:          Applications/Editors/Vim
350 # for _vimdatadir existence
351 Requires:       vim-rt >= 4:6.3.058-3
352
353 %description -n vim-syntax-gitcommit
354 This plugin provides syntax highlighting for git's commit messages.
355
356 %description -n vim-syntax-gitcommit -l pl.UTF-8
357 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
358
359 %prep
360 %setup -q -n git-%{version}
361 %patch0 -p1
362 %patch1 -p0
363
364 %build
365 %{__aclocal}
366 %{__autoconf}
367 %configure \
368         --with-openssl
369
370 echo "BLK_SHA1=1" >> config.mak
371
372 %{__make} \
373         INSTALLDIRS=vendor \
374         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
375         GITWEB_PROJECTROOT="/var/lib/git" \
376         GITWEB_CSS="/gitweb/gitweb.css" \
377         GITWEB_LOGO="/gitweb/git-logo.png" \
378         GITWEB_FAVICON="/gitweb/git-favicon.png" \
379         V=1
380
381 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
382 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
383
384 %if %{with tests}
385 %if %{without tests_cvs}
386 rm t/t*cvs*.sh || :
387 %endif
388 %{__make} test
389 %endif
390
391 %install
392 rm -rf $RPM_BUILD_ROOT
393 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
394 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
395 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
396
397 %{__make} install \
398         INSTALLDIRS=vendor \
399         DESTDIR=$RPM_BUILD_ROOT
400
401 %if %{with doc}
402 %{__make} -C Documentation install \
403         DESTDIR=$RPM_BUILD_ROOT
404 %endif
405
406 # header files and lib
407 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
408 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
409 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
410 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
411 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
412
413 # bash completion
414 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
415 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
416
417 # vim syntax
418 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
419 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
420 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
421 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
422 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
423 autocmd BufNewFile,BufRead .msg.[0-9]*
424         \ if getline(1) =~ '^From.*# This line is ignored.$' |
425         \   setf gitsendemail |
426         \ endif
427 autocmd BufNewFile,BufRead *.git/**
428         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
429         \   setf git |
430         \ endif
431 EOF
432
433 # gitweb
434 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
435 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
436 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
437 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
438 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
439
440 # gitview
441 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
442
443 # git-daemon related files
444 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
445 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
446 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
447
448 # paths cleanup
449 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
450 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
451
452 # hardlink
453 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
454 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
455 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
456 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
457
458 # remove unneeded files
459 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
460 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
461 %py_postclean
462
463 %clean
464 rm -rf $RPM_BUILD_ROOT
465
466 %post daemon-inetd
467 %service -q rc-inetd reload
468
469 %postun daemon-inetd
470 if [ "$1" = "0" ]; then
471         %service -q rc-inetd reload
472 fi
473
474 %post daemon-standalone
475 /sbin/chkconfig --add git-daemon
476 %service git-daemon restart "git-daemon"
477
478 %preun daemon-standalone
479 if [ "$1" = "0" ]; then
480         %service git-daemon stop
481         /sbin/chkconfig --del git-daemon
482 fi
483
484 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
485 %webapp_register apache %{webapp}
486
487 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
488 %webapp_unregister apache %{webapp}
489
490 %triggerin gitweb -- apache < 2.2.0, apache-base
491 %webapp_register httpd %{webapp}
492
493 %triggerun gitweb -- apache < 2.2.0, apache-base
494 %webapp_unregister httpd %{webapp}
495
496 %triggerin gitweb -- lighttpd
497 %webapp_register lighttpd %{webapp}
498
499 %triggerun gitweb -- lighttpd
500 %webapp_unregister lighttpd %{webapp}
501
502 %files
503 %defattr(644,root,root,755)
504 %doc README contrib
505 %attr(755,root,root) %{_bindir}/git
506 %attr(755,root,root) %{_bindir}/git-receive-pack
507 %attr(755,root,root) %{_bindir}/git-shell
508 %attr(755,root,root) %{_bindir}/git-upload-archive
509 %attr(755,root,root) %{_bindir}/git-upload-pack
510
511 %if %{with doc}
512 %{_mandir}/man1/git-*.1*
513 %exclude %{_mandir}/man1/git-svn.1*
514 %exclude %{_mandir}/man1/git-cvs*.1*
515 %{_mandir}/man1/git.1*
516 %{_mandir}/man5/gitattributes.5*
517 %{_mandir}/man5/githooks.5*
518 %{_mandir}/man5/gitignore.5*
519 %{_mandir}/man5/gitmodules.5*
520 %{_mandir}/man5/gitrepository-layout.5*
521 %{_mandir}/man7/gitcli.7*
522 %{_mandir}/man7/gitcore-tutorial.7*
523 %{_mandir}/man7/gitdiffcore.7*
524 %{_mandir}/man7/gitglossary.7*
525 %{_mandir}/man7/gitrevisions.7*
526 %{_mandir}/man7/gittutorial-2.7*
527 %{_mandir}/man7/gittutorial.7*
528 %{_mandir}/man7/gitworkflows.7*
529 %endif
530
531 %dir %{_libdir}/%{name}
532 %attr(755,root,root) %{_libdir}/%{name}/*-*
533 %attr(755,root,root) %{_libdir}/%{name}/git
534
535 %exclude %{_libdir}/%{name}/git-gui
536 %exclude %{_libdir}/%{name}/git-svn
537 %exclude %{_libdir}/%{name}/git-archimport
538 %exclude %{_libdir}/%{name}/git-cvs*
539 %exclude %{_libdir}/%{name}/*email*
540
541 %{_datadir}/%{name}
542
543 %{_localstatedir}/lib/git
544
545 %if %{with doc}
546 %files doc
547 %defattr(644,root,root,755)
548 %doc Documentation/RelNotes*
549 %doc Documentation/*.html Documentation/howto Documentation/technical
550 %endif
551
552 %files daemon-inetd
553 %defattr(644,root,root,755)
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
555
556 %files daemon-standalone
557 %defattr(644,root,root,755)
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
559 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
560
561 %files devel
562 %defattr(644,root,root,755)
563 %{_includedir}/git-core
564 %{_libdir}/libgit.a
565 %{_libdir}/libgit_xdiff.a
566
567 %files gitk
568 %defattr(644,root,root,755)
569 %if %{with doc}
570 %{_mandir}/man1/gitk.1*
571 %endif
572 %attr(755,root,root) %{_bindir}/gitk
573 %dir %{_datadir}/gitk
574 %dir %{_datadir}/gitk/lib
575 %dir %{_datadir}/gitk/lib/msgs
576 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
577 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
578 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
579 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
580 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
581 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
582 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
583 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
584
585 %files gitweb
586 %defattr(644,root,root,755)
587 %doc gitweb/{README,INSTALL}
588 %dir %{webappdir}
589 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
590 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
591 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
592 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
593 %attr(755,root,root) %{cgibindir}/gitweb.cgi
594 %{appdir}
595
596 %files gitview
597 %defattr(644,root,root,755)
598 %doc contrib/gitview/gitview.txt
599 %attr(755,root,root) %{_bindir}/gitview
600
601 %files gui
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/%{name}/git-gui
604 %dir %{_datadir}/git-gui
605 %dir %{_datadir}/git-gui/lib
606 %dir %{_datadir}/git-gui/lib/msgs
607 %{_datadir}/git-gui/lib/git-gui.ico
608 %{_datadir}/git-gui/lib/tclIndex
609 %{_datadir}/git-gui/lib/*.js
610 %{_datadir}/git-gui/lib/*.tcl
611 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
612 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
613 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
614 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
615 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
616 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
617 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
618 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
619 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
620 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
621
622 %files svn
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/%{name}/git-svn
625 %if %{with doc}
626 %{_mandir}/man1/git-svn.1*
627 %endif
628
629 %files cvs
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/git-cvsserver
632 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
633 %if %{with doc}
634 %{_mandir}/man1/git-cvs*.1*
635 %{_mandir}/man7/gitcvs-migration.7*
636 %endif
637
638 %files arch
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
641 %if %{with doc}
642 %{_mandir}/man1/git-archimport.1*
643 %endif
644
645 %files email
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/%{name}/*email*
648 %if %{with doc}
649 %{_mandir}/man1/*email*.1*
650 %endif
651
652 %files -n bash-completion-git
653 %defattr(644,root,root,755)
654 %{_sysconfdir}/bash_completion.d/*
655
656 %files -n perl-Git
657 %defattr(644,root,root,755)
658 %{perl_vendorlib}/Git.pm
659 %{_mandir}/man3/Git.3pm*
660
661 %files -n python-Git
662 %defattr(644,root,root,755)
663 %dir %{py_sitescriptdir}/git_remote_helpers
664 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
665 %dir %{py_sitescriptdir}/git_remote_helpers/git
666 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
667 %if "%{py_ver}" > "2.4"
668 %{py_sitescriptdir}/git_remote_helpers*.egg-info
669 %endif
670
671 %files -n vim-syntax-gitcommit
672 %defattr(644,root,root,755)
673 %doc contrib/vim/README
674 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.108438 seconds and 4 git commands to generate.