]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- bcond header
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 #
5 # Conditional build:
6 %bcond_without  tests   # don't perform make test
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        The stupid content tracker
10 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
11 Name:           git-core
12 Version:        1.5.2.1
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
17 # Source0-md5:  0a39e786a12974cbe7b14f2fe92dc163
18 URL:            http://git.or.cz/
19 BuildRequires:  asciidoc
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  expat-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  perl-Error
26 BuildRequires:  perl-base
27 BuildRequires:  python
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  xmlto
30 BuildRequires:  zlib-devel
31 Requires:       coreutils
32 Requires:       curl
33 Requires:       diffutils
34 Requires:       findutils
35 Requires:       grep
36 Requires:       openssh-clients
37 Requires:       perl-Error
38 Requires:       rcs
39 Requires:       sed
40 Requires:       tk
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 "git" can mean anything, depending on your mood.
45
46  - random three-letter combination that is pronounceable, and not
47    actually used by any common UNIX command. The fact that it is a
48    mispronunciation of "get" may or may not be relevant.
49  - stupid. contemptible and despicable. simple. Take your pick from the
50    dictionary of slang.
51  - "global information tracker": you're in a good mood, and it actually
52    works for you. Angels sing, and a light suddenly fills the room.
53  - "goddamn idiotic truckload of sh*t": when it breaks
54
55 This is a stupid (but extremely fast) directory content manager. It
56 doesn't do a whole lot, but what it 'does' do is track directory
57 contents efficiently.
58
59 %description -l pl.UTF-8
60 "git" może oznaczać cokolwiek, w zależności od nastroju.
61
62 - losową kombinację trzech liter, która jest wymawialna i właściwie
63   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
64   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
65 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
66 - "global information tracker" (narzędzie do globalnego śledzenia
67   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
68   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
69 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
70   g*) - kiedy się zepsuje.
71
72 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
73 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
74 katalogu.
75
76 %package devel
77 Summary:        Header files for git-core
78 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
79 Group:          Development/Libraries
80
81 %description devel
82 Header files for git-core.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe dla git-core.
86
87 %package -n perl-Git
88 Summary:        Perl interface to the Git version control system
89 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
90 Group:          Development/Languages/Perl
91 Requires:       %{name} = %{version}-%{release}
92 Obsoletes:      perl-git-core
93
94 %description -n perl-Git
95 This module provides Perl scripts easy way to interface the Git
96 version control system. The modules have an easy and well-tested way
97 to call arbitrary Git commands; in the future, the interface will also
98 provide specialized methods for doing easily operations which are not
99 totally trivial to do over the generic command interface.
100
101 %description -n perl-Git -l pl.UTF-8
102 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
103 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
104 dowolne polecenia Gita; w przyszłości interfejs udostępni także
105 specjalne metody do łatwego wykonywania operacji nietrywialnych do
106 wykonania przy użyciu ogólnego interfejsu poleceń.
107
108 %prep
109 %setup -q -n git-%{version}
110
111 %build
112 %{__aclocal}
113 %{__autoconf}
114 %configure \
115         --with-openssl
116
117 %{__make} \
118         INSTALLDIRS=vendor
119
120 %{__make} -C Documentation
121
122 %{?with_tests:%{__make} test}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
127
128 %{__make} install \
129         INSTALLDIRS=vendor \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__make} -C Documentation install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
136 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
137
138 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
139 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc README Documentation/*.html Documentation/howto Documentation/technical
147 %attr(755,root,root) %{_bindir}/*
148 %{_mandir}/man*/*
149 %{_datadir}/%{name}
150 %{_datadir}/git-gui
151
152 %files devel
153 %defattr(644,root,root,755)
154 %{_includedir}/*
155
156 %files -n perl-Git
157 %defattr(644,root,root,755)
158 %{perl_vendorlib}/Git.pm
159 %{_mandir}/man3/*
This page took 0.045336 seconds and 4 git commands to generate.