]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
gnome-keyring, add url and help how to configure
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        1.9.2
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  609ec9be5251860fd6d10f1c41078890
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-devel
40 %if %{with gnome_keyring}
41 BuildRequires:  libgnome-keyring-devel
42 BuildRequires:  pkgconfig
43 %endif
44 BuildRequires:  openssl-devel
45 %{?with_pcre:BuildRequires:     pcre-devel}
46 BuildRequires:  perl-Error > 0.15
47 BuildRequires:  perl-base
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tcl
53 BuildRequires:  zlib-devel
54 %if %{with doc}
55 BuildRequires:  asciidoc >= 7.1.2-3
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  xmlto
58 %endif
59 %if %{with tests}
60 %if %{with tests_cvs}
61 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62 BuildRequires:  cvs-gnu-client < 1.13
63 BuildRequires:  cvs-gnu-client >= 1.12
64 %endif
65 %{?with_tests_svn:BuildRequires:  subversion}
66 Conflicts:      pdksh < 5.2.14-46
67 %endif
68 # git-sh-setup: sane_grep
69 Requires:       grep
70 # git-pull: printf
71 Requires:       coreutils
72 Requires:       openssh-clients
73 Requires:       perl-Error
74 Requires:       perl-Git = %{version}-%{release}
75 Requires:       sed
76 Suggests:       git-core-bzr
77 Suggests:       git-core-cvs
78 Suggests:       git-core-hg
79 Suggests:       git-core-p4
80 Suggests:       git-core-svn
81 Suggests:       less
82 Suggests:       rsync
83 Obsoletes:      python-Git
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 # html docs have links to txt files
87 %define         _noautocompressdoc      *.txt
88
89 %define         webapp          gitweb
90 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
91 %define         appdir          %{_datadir}/%{webapp}
92 %define         cgibindir       %{_prefix}/lib/cgi-bin
93
94 %description
95 "git" can mean anything, depending on your mood.
96
97 - random three-letter combination that is pronounceable, and not
98   actually used by any common UNIX command. The fact that it is a
99   mispronunciation of "get" may or may not be relevant.
100 - stupid. contemptible and despicable. simple. Take your pick from the
101   dictionary of slang.
102 - "global information tracker": you're in a good mood, and it actually
103   works for you. Angels sing, and a light suddenly fills the room.
104 - "goddamn idiotic truckload of sh*t": when it breaks
105
106 This is a stupid (but extremely fast) directory content manager. It
107 doesn't do a whole lot, but what it 'does' do is track directory
108 contents efficiently.
109
110 %description -l pl.UTF-8
111 "git" może oznaczać cokolwiek, w zależności od nastroju.
112
113 - losową kombinację trzech liter, która jest wymawialna i właściwie
114   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
115   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
116 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
117 - "global information tracker" (narzędzie do globalnego śledzenia
118   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
119   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
120 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
121   g*) - kiedy się zepsuje.
122
123 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
124 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
125 katalogu.
126
127 %package doc
128 Summary:        Documentation for git-core
129 Summary(pl.UTF-8):      Dokumentacja do git-core
130 Group:          Documentation
131
132 %description doc
133 Documentation for git-core.
134
135 %description doc -l pl.UTF-8
136 Dokumentacja do git-core.
137
138 %description doc -l fr.UTF-8
139 Javadoc pour git-core.
140
141 %package daemon-inetd
142 Summary:        Files necessary to run git-daemon as an inetd service
143 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
144 Group:          Networking/Daemons
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       setup >= 2.4.11-1
147 Provides:       git-core-daemon
148 Obsoletes:      git-core-daemon
149 Obsoletes:      git-core-daemon-standalone
150
151 %description daemon-inetd
152 Git-daemon is a really simple TCP git daemon that can serve git
153 repositories. This package provides all necessarry files to run
154 git-daemon as an inetd service.
155
156 %description daemon-inetd -l pl.UTF-8
157 Git-daemon to prosty demon git korzystający z protokołu TCP do
158 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
159 do uruchomienia git-demona w trybie usługi inetd.
160
161 %package daemon-standalone
162 Summary:        Files necessary to run git-daemon as a standalone service
163 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
164 Group:          Networking/Daemons
165 Requires:       %{name} = %{version}-%{release}
166 Provides:       git-core-daemon
167 Obsoletes:      git-core-daemon
168 Obsoletes:      git-core-daemon-inetd
169
170 %description daemon-standalone
171 Git-daemon is a really simple TCP git daemon that can serve git
172 repositories. This package provides all necessarry files to run
173 git-daemon as an standalone service.
174
175 %description daemon-standalone -l pl.UTF-8
176 Git-daemon to prosty demon git korzystający z protokołu TCP do
177 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
178 do uruchomienia git-daemona w trybie usługi samodzielnej.
179
180 %package devel
181 Summary:        Git library with header files
182 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
183 Group:          Development/Libraries
184 Requires:       zlib-devel
185
186 %description devel
187 Git library with header files.
188
189 %description devel -l pl.UTF-8
190 Biblioteka Gita oraz pliki nagłówkowe.
191
192 %package gitk
193 Summary:        Tcl/Tk interface to the Git version control system
194 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
195 Group:          Development/Tools
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       tk
198
199 %description gitk
200 gitk displays changes in a repository or a selected set of commits.
201 This includes visualizing the commit graph, showing information
202 related to each commit, and the files in the trees of each revision.
203
204 Historically, gitk was the first repository browser. It's written in
205 Tcl/Tk and started off in a separate repository but was later merged
206 into the main git repository.
207
208 %description gitk -l pl.UTF-8
209 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
210 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
211 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
212
213 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
214 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
215 osobnym repozytorium, ale z czasem został włączony do głównego
216 repozytorium gita.
217
218 %package gitweb
219 Summary:        Web frontend to git
220 Summary(pl.UTF-8):      Frontend WWW do gita
221 Group:          Development/Tools
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       webapps
224 Requires:       webserver(access)
225 Requires:       webserver(alias)
226 Requires:       webserver(cgi)
227 Suggests:       webserver(setenv)
228
229 %description gitweb
230 This package provides a web interface for browsing git repositories.
231
232 %description gitweb -l pl.UTF-8
233 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
234
235 %package gitview
236 Summary:        A GTK+ based repository browser for git
237 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
238 Group:          Development/Tools
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       python >= 1:2.4
241 Requires:       python-pycairo >= 1.0
242 Requires:       python-pygobject
243 Requires:       python-pygtk-gtk >= 2:2.8
244 Suggests:       python-gnome-desktop-gtksourceview
245
246 %description gitview
247 A GTK+ based repository browser for git.
248
249 %description gitview -l pl.UTF-8
250 Oparta na GTK+ przeglądarka repozytorium gita.
251
252 %package gui
253 Summary:        Tcl/Tk interface to the Git version control system
254 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
255 Group:          Development/Tools
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       tk
258 Requires:       xdg-utils
259 Suggests:       meld
260
261 %description gui
262 Displays changes in a repository or a selected set of commits. This
263 includes visualizing the commit graph, showing information related to
264 each commit, and the files in the trees of each revision.
265
266 Historically, gitk was the first repository browser. It's written in
267 Tcl/Tk and started off in a separate repository but was later merged
268 into the main git repository.
269
270 %description gui -l pl.UTF-8
271 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
272 to wizualizację grafu commitów, wyświetlanie informacji związanych z
273 każdym z commitów oraz listę plików dla każdej rewizji.
274
275 Z punktu widzenia historii, gitk był pierwszą przeglądarką
276 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
277 osobnym repozytorium, ale z czasem został włączony do głównego
278 repozytorium gita.
279
280 %package arch
281 Summary:        Git tools for importing Arch repositories
282 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
283 Group:          Development/Tools
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       tla
286
287 %description arch
288 Git tools for importing Arch repositories.
289
290 %description arch -l pl.UTF-8
291 Narzędzia Gita do importowania repozytoriów Archa.
292
293 %package bzr
294 Summary:        Git tools for working with bzr repositories
295 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
296 Group:          Development/Tools
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       bzr
299
300 %description bzr
301 Git tools for working with bzr repositories.
302
303 %description bzr -l pl.UTF-8
304 Narzędzia Gita do pracy z repozytoriami bzr.
305
306 %package cvs
307 Summary:        CVS support for Git
308 Summary(pl.UTF-8):      Obsługa CVS dla Gita
309 Group:          Development/Tools
310 Requires:       %{name} = %{version}-%{release}
311 Requires:       cvsps >= 2.1-2
312 Requires:       rcs
313
314 %description cvs
315 CVS support for Git.
316
317 %description cvs -l pl.UTF-8
318 Obsługa CVS dla Gita.
319
320 %package hg
321 Summary:        Git tools for working with mercurial repositories
322 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
323 Group:          Development/Tools
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       mercurial >= 1.8
326
327 %description hg
328 Git tools for working with mercurial repositories.
329
330 %description hg -l pl.UTF-8
331 Narzędzia Gita do pracy z repozytoriami mercuriala.
332
333 %package p4
334 Summary:        Git tools for working with Perforce depots
335 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
336 Group:          Development/Tools
337 Requires:       %{name} = %{version}-%{release}
338
339 %description p4
340 Git tools for working with Perforce depots.
341
342 %description p4 -l pl.UTF-8
343 Narzędzia Gita do pracy z magazynami Perforce'a.
344
345 %package svn
346 Summary:        Subversion support for Git
347 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
348 Group:          Development/Tools
349 Requires:       %{name} = %{version}-%{release}
350 Requires:       perl-Encode
351 Requires:       perl-Term-ReadKey
352
353 %description svn
354 Subversion support for Git.
355
356 %description svn -l pl.UTF-8
357 Obsługa Subversion dla Gita.
358
359 %package email
360 Summary:        Git tools for sending email
361 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
362 Group:          Development/Tools
363 Requires:       %{name} = %{version}-%{release}
364
365 %description email
366 Git tools for sending email.
367
368 %description email -l pl.UTF-8
369 Narzędzia Gita do wysyłania poczty.
370
371 %package -n bash-completion-git
372 Summary:        bash-completion for git
373 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
374 Group:          Applications/Shells
375 Requires:       %{name} = %{version}-%{release}
376 Requires:       bash-completion >= 2.0
377 %if "%{_rpmversion}" >= "5"
378 BuildArch:      noarch
379 %endif
380
381 %description -n bash-completion-git
382 This package provides bash-completion for git.
383
384 %description -n bash-completion-git -l pl.UTF-8
385 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
386
387 %package -n perl-Git
388 Summary:        Perl interface to the Git version control system
389 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
390 Group:          Development/Languages/Perl
391 Obsoletes:      perl-git-core
392
393 %description -n perl-Git
394 This module provides Perl scripts easy way to interface the Git
395 version control system. The modules have an easy and well-tested way
396 to call arbitrary Git commands; in the future, the interface will also
397 provide specialized methods for doing easily operations which are not
398 totally trivial to do over the generic command interface.
399
400 %description -n perl-Git -l pl.UTF-8
401 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
402 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
403 dowolne polecenia Gita; w przyszłości interfejs udostępni także
404 specjalne metody do łatwego wykonywania operacji nietrywialnych do
405 wykonania przy użyciu ogólnego interfejsu poleceń.
406
407 %package -n gnome-keyring-git-core
408 Summary:        GNOME Keyring authentication provider for Git
409 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
410 Group:          X11/Applications
411 URL:            http://git-scm.com/docs/gitcredentials.html
412 Requires:       %{name} = %{version}-%{release}
413
414 %description -n gnome-keyring-git-core
415 Authentication provider module for Git which allows git client to
416 authenticate using GNOME Keyring.
417
418 You need to register it with:
419 git config --global credential.helper %{_libdir}/%{name}/git-credential-gnome-keyring
420
421 %description -n gnome-keyring-git-core -l pl.UTF-8
422 Moduł uwierzytelniający dla Subversion pozwalający klientom git
423 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
424
425 %prep
426 %setup -q -n git-%{version}
427 %patch0 -p1
428 %patch1 -p0
429 %patch2 -p1
430 %patch3 -p1
431 %patch4 -p1
432
433 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
434
435 %build
436 %{__aclocal}
437 %{__autoconf}
438 %configure \
439         --sysconfdir=%{_sysconfdir}/git-core \
440         %{?with_pcre:--with-libpcre} \
441         --with-openssl
442
443 echo "BLK_SHA1=1" >> config.mak
444
445 %{__make} \
446         INSTALLDIRS=vendor \
447         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
448         GITWEB_PROJECTROOT="/var/lib/git" \
449         GITWEB_CSS="/gitweb/gitweb.css" \
450         GITWEB_LOGO="/gitweb/git-logo.png" \
451         GITWEB_FAVICON="/gitweb/git-favicon.png" \
452         V=1
453
454 %{__make} -C contrib/subtree
455
456 %if %{with gnome_keyring}
457 %{__make} -C contrib/credential/gnome-keyring
458 %endif
459
460 %if %{with doc}
461 %{__make} -C Documentation \
462         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
463         V=1
464 %endif
465
466 %if %{with tests}
467 %if %{without tests_cvs}
468 %{__rm} t/t*cvs*.sh || :
469 %endif
470 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
471 %endif
472
473 %install
474 rm -rf $RPM_BUILD_ROOT
475 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
476 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
477 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
478 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
479 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
480 [init]
481         templatedir = %{_sysconfdir}/%{name}/templates
482 EOF
483
484 %{__make} install \
485         INSTALLDIRS=vendor \
486         DESTDIR=$RPM_BUILD_ROOT
487
488 %if %{with doc}
489 %{__make} -C Documentation install \
490         DESTDIR=$RPM_BUILD_ROOT
491 %endif
492
493 # copy templates except sample hooks
494 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
495 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
496
497 # header files and lib
498 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
499 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
500 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
501 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
502 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
503 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
504 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
505 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
506
507 %{__make} -C contrib/subtree install \
508         libexecdir=%{_libdir}/%{name} \
509         DESTDIR=$RPM_BUILD_ROOT
510
511 %if %{with doc}
512 %{__make} -C contrib/subtree install-doc \
513         DESTDIR=$RPM_BUILD_ROOT
514 %endif
515
516 %if %{with gnome_keyring}
517 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libdir}/%{name}
518 # Remove built binary files, otherwise they will be installed in doc
519 %{__make} -C contrib/credential/gnome-keyring clean
520 %endif
521
522 # bash completion
523 install -d $RPM_BUILD_ROOT%{bash_compdir}
524 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
525
526 # Install git-prompt.sh
527 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
528 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
529
530 # Install bzr and hg remote helpers from contrib
531 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
532
533 # gitweb
534 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
535 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
536 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
537 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
538 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
539 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
540 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
541
542 # gitview
543 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
544
545 # git-daemon related files
546 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
547 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
548 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
549
550 # paths cleanup
551 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
552 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
553
554 # hardlink
555 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
556 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
557 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
558 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
559
560 # remove unneeded files
561 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
562 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
563 %py_postclean
564
565 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
566 %find_lang git
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %post daemon-inetd
572 %service -q rc-inetd reload
573
574 %postun daemon-inetd
575 if [ "$1" = "0" ]; then
576         %service -q rc-inetd reload
577 fi
578
579 %post daemon-standalone
580 /sbin/chkconfig --add git-daemon
581 %service git-daemon restart "git-daemon"
582
583 %preun daemon-standalone
584 if [ "$1" = "0" ]; then
585         %service git-daemon stop
586         /sbin/chkconfig --del git-daemon
587 fi
588
589 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
590 %webapp_register apache %{webapp}
591
592 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
593 %webapp_unregister apache %{webapp}
594
595 %triggerin gitweb -- apache < 2.2.0, apache-base
596 %webapp_register httpd %{webapp}
597
598 %triggerun gitweb -- apache < 2.2.0, apache-base
599 %webapp_unregister httpd %{webapp}
600
601 %triggerin gitweb -- lighttpd
602 %webapp_register lighttpd %{webapp}
603
604 %triggerun gitweb -- lighttpd
605 %webapp_unregister lighttpd %{webapp}
606
607 %files -f git.lang
608 %defattr(644,root,root,755)
609 %doc README contrib
610 %attr(755,root,root) %{_bindir}/git
611 %attr(755,root,root) %{_bindir}/git-receive-pack
612 %attr(755,root,root) %{_bindir}/git-shell
613 %attr(755,root,root) %{_bindir}/git-upload-archive
614 %attr(755,root,root) %{_bindir}/git-upload-pack
615 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
616
617 %if %{with doc}
618 %{_mandir}/man1/git-*.1*
619 %exclude %{_mandir}/man1/git-archimport.1*
620 %exclude %{_mandir}/man1/git-svn.1*
621 %exclude %{_mandir}/man1/git-cvs*.1*
622 %exclude %{_mandir}/man1/git-imap-send*.1*
623 %exclude %{_mandir}/man1/*email*.1*
624 %{_mandir}/man1/git.1*
625 %{_mandir}/man1/gitremote-helpers.1*
626 %{_mandir}/man5/gitattributes.5*
627 %{_mandir}/man5/githooks.5*
628 %{_mandir}/man5/gitignore.5*
629 %{_mandir}/man5/gitmodules.5*
630 %{_mandir}/man5/gitrepository-layout.5*
631 %{_mandir}/man7/gitcli.7*
632 %{_mandir}/man7/gitcore-tutorial.7*
633 %{_mandir}/man7/gitcredentials.7*
634 %{_mandir}/man7/gitdiffcore.7*
635 %{_mandir}/man7/gitglossary.7*
636 %{_mandir}/man7/gitnamespaces.7*
637 %{_mandir}/man7/gitrevisions.7*
638 %{_mandir}/man7/gittutorial-2.7*
639 %{_mandir}/man7/gittutorial.7*
640 %{_mandir}/man7/gitworkflows.7*
641 %endif
642
643 %dir %{_libdir}/%{name}
644 %attr(755,root,root) %{_libdir}/%{name}/*-*
645 %attr(755,root,root) %{_libdir}/%{name}/git
646 %dir %{_libdir}/%{name}/mergetools
647 %{_libdir}/%{name}/mergetools/*
648
649 %{_datadir}/%{name}
650 %{_localstatedir}/lib/git
651
652 # subpackages
653 %exclude %{_libdir}/%{name}/*email*
654 %exclude %{_libdir}/%{name}/*p4*
655 %exclude %{_libdir}/%{name}/git-archimport
656 %exclude %{_libdir}/%{name}/git-cvs*
657 %exclude %{_libdir}/%{name}/git-gui
658 %exclude %{_libdir}/%{name}/git-imap-send
659 %exclude %{_libdir}/%{name}/git-instaweb
660 %exclude %{_libdir}/%{name}/git-remote-bzr
661 %exclude %{_libdir}/%{name}/git-remote-hg
662 %exclude %{_libdir}/%{name}/git-remote-testsvn
663 %exclude %{_libdir}/%{name}/git-svn
664 %exclude %{_libdir}/%{name}/mergetools/p4merge
665 %if %{with gnome_keyring}
666 %exclude %{_libdir}/%{name}/git-credential-gnome-keyring
667 %endif
668
669 %if %{with doc}
670 %files doc
671 %defattr(644,root,root,755)
672 %doc Documentation/RelNotes*
673 %doc Documentation/*.html Documentation/howto Documentation/technical
674 %endif
675
676 %files daemon-inetd
677 %defattr(644,root,root,755)
678 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
679
680 %files daemon-standalone
681 %defattr(644,root,root,755)
682 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
683 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
684
685 %files devel
686 %defattr(644,root,root,755)
687 %{_includedir}/%{name}
688 %{_libdir}/libgit.a
689 %{_libdir}/libgit_xdiff.a
690
691 %files gitk
692 %defattr(644,root,root,755)
693 %if %{with doc}
694 %{_mandir}/man1/gitk.1*
695 %endif
696 %attr(755,root,root) %{_bindir}/gitk
697 %dir %{_datadir}/gitk
698 %dir %{_datadir}/gitk/lib
699 %dir %{_datadir}/gitk/lib/msgs
700 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
701 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
702 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
703 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
704 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
705 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
706 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
707 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
708 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
709 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
710
711 %files gitweb
712 %defattr(644,root,root,755)
713 %doc gitweb/{README,INSTALL}
714 %dir %{webappdir}
715 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
716 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
717 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
718 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
719 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
720 %attr(755,root,root) %{cgibindir}/gitweb.cgi
721 %{appdir}
722 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
723 %if %{with doc}
724 %{_mandir}/man1/gitweb.1*
725 %{_mandir}/man5/gitweb.conf.5*
726 %endif
727
728 %files gitview
729 %defattr(644,root,root,755)
730 %doc contrib/gitview/gitview.txt
731 %attr(755,root,root) %{_bindir}/gitview
732
733 %files gui
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/%{name}/git-gui
736 %dir %{_datadir}/git-gui
737 %dir %{_datadir}/git-gui/lib
738 %dir %{_datadir}/git-gui/lib/msgs
739 %{_datadir}/git-gui/lib/git-gui.ico
740 %{_datadir}/git-gui/lib/tclIndex
741 %{_datadir}/git-gui/lib/*.js
742 %{_datadir}/git-gui/lib/*.tcl
743 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
744 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
745 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
746 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
747 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
748 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
749 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
750 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
751 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
752 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
753 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
754 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
755
756 %files arch
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
759 %if %{with doc}
760 %{_mandir}/man1/git-archimport.1*
761 %endif
762
763 %files bzr
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
766
767 %files cvs
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_bindir}/git-cvsserver
770 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
771 %if %{with doc}
772 %{_mandir}/man1/git-cvs*.1*
773 %{_mandir}/man7/gitcvs-migration.7*
774 %endif
775
776 %files hg
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
779
780 %files p4
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/%{name}/git-p4
783 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
784
785 %files svn
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/%{name}/git-svn
788 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
789 %{perl_vendorlib}/Git/SVN
790 %{perl_vendorlib}/Git/SVN.pm
791 %if %{with doc}
792 %{_mandir}/man1/git-svn.1*
793 %endif
794
795 %files email
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
798 %attr(755,root,root) %{_libdir}/%{name}/*email*
799 %if %{with doc}
800 %{_mandir}/man1/*email*.1*
801 %{_mandir}/man1/*imap-send*.1*
802 %endif
803
804 %files -n bash-completion-git
805 %defattr(644,root,root,755)
806 %{bash_compdir}/git
807
808 %files -n perl-Git
809 %defattr(644,root,root,755)
810 %{perl_vendorlib}/Git.pm
811 %dir %{perl_vendorlib}/Git
812 %{perl_vendorlib}/Git/I18N.pm
813 %{perl_vendorlib}/Git/IndexInfo.pm
814 %{_mandir}/man3/Git*.3pm*
815
816 %if %{with gnome_keyring}
817 %files -n gnome-keyring-git-core
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/%{name}/git-credential-gnome-keyring
820 %endif
This page took 0.097897 seconds and 4 git commands to generate.