]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- sanitized main file list
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.2.2
10 Release:        3
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  846940654b703ec5c8de4ee388cb4d08
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  xmlto
30 BuildRequires:  zlib-devel
31 Requires:       coreutils
32 Requires:       curl
33 Requires:       diffutils
34 Requires:       findutils
35 Requires:       grep
36 Requires:       openssh-clients
37 Requires:       perl-Error
38 Requires:       rcs
39 Requires:       sed
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         webapp          gitweb
43 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
44 %define         appdir          %{_datadir}/%{webapp}
45 %define         cgibindir       %{_prefix}/lib/cgi-bin
46
47 %description
48 "git" can mean anything, depending on your mood.
49
50  - random three-letter combination that is pronounceable, and not
51    actually used by any common UNIX command. The fact that it is a
52    mispronunciation of "get" may or may not be relevant.
53  - stupid. contemptible and despicable. simple. Take your pick from the
54    dictionary of slang.
55  - "global information tracker": you're in a good mood, and it actually
56    works for you. Angels sing, and a light suddenly fills the room.
57  - "goddamn idiotic truckload of sh*t": when it breaks
58
59 This is a stupid (but extremely fast) directory content manager. It
60 doesn't do a whole lot, but what it 'does' do is track directory
61 contents efficiently.
62
63 %description -l pl.UTF-8
64 "git" może oznaczać cokolwiek, w zależności od nastroju.
65
66 - losową kombinację trzech liter, która jest wymawialna i
67   właściwie nie używana przez żadne popularne polecenie uniksowe.
68   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
69   mieć znaczenia.
70 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
71 - "global information tracker" (narzędzie do globalnego śledzenia
72   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
73   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
74 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
75   g*) - kiedy się zepsuje.
76
77 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
78 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
79 katalogu.
80
81 %package devel
82 Summary:        Header files for git-core
83 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
84 Group:          Development/Libraries
85
86 %description devel
87 Header files for git-core.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe dla git-core.
91
92 %package gitk
93 Summary:        Tcl/Tk interface to the Git version control system
94 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
95 Group:          Development/Tools
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       tk
98
99 %description gitk
100 Displays changes in a repository or a selected set of commits. This
101 includes visualizing the commit graph, showing information related to
102 each commit, and the files in the trees of each revision.
103
104 Historically, gitk was the first repository browser. It's written in
105 Tcl/Tk and started off in a separate repository but was later merged
106 into the main git repository.
107
108 %description gitk -l pl.UTF-8
109 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
110 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
111 związanych z każdym z commitów oraz listę plików dla każdej
112 rewizji.
113
114 Z punktu widzenia historii, gitk był pierwszą przeglądarką
115 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
116 w osobnym repozytorium, ale z czasem został włączony do głównego
117 repozytorium git.
118
119 %package gitweb
120 Summary:        Web frontend to git
121 Summary(pl.UTF-8):      Webowy frontend do git
122 Group:          Development/Tools
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       webapps
125
126 %description gitweb
127 This package provides a web interface for browsing git repositories.
128
129 %description gitweb -l pl.UTF-8
130 Pakiet ten dostarcza interfejs WWW do przegl?dania repozytoriów git.
131
132 %package -n perl-Git
133 Summary:        Perl interface to the Git version control system
134 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
135 Group:          Development/Languages/Perl
136 Requires:       %{name} = %{version}-%{release}
137 Obsoletes:      perl-git-core
138
139 %description -n perl-Git
140 This module provides Perl scripts easy way to interface the Git
141 version control system. The modules have an easy and well-tested way
142 to call arbitrary Git commands; in the future, the interface will also
143 provide specialized methods for doing easily operations which are not
144 totally trivial to do over the generic command interface.
145
146 %description -n perl-Git -l pl.UTF-8
147 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
148 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
149 wywoływać dowolne polecenia Gita; w przyszłości interfejs
150 udostępni także specjalne metody do łatwego wykonywania operacji
151 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
152 poleceń.
153
154 %prep
155 %setup -q -n git-%{version}
156
157 %build
158 %{__aclocal}
159 %{__autoconf}
160 %configure \
161         --with-openssl
162
163 %{__make} \
164         INSTALLDIRS=vendor \
165         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
166         GITWEB_PROJECTROOT="/var/lib/git" \
167         GITWEB_CSS="/gitweb/gitweb.css" \
168         GITWEB_LOGO="/gitweb/git-logo.png" \
169         GITWEB_FAVICON="/gitweb/git-favicon.png"
170
171 %{__make} -C Documentation
172
173 %{?with_tests:%{__make} test}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
178 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
179
180 %{__make} install \
181         INSTALLDIRS=vendor \
182         DESTDIR=$RPM_BUILD_ROOT
183
184 %{__make} -C Documentation install \
185         DESTDIR=$RPM_BUILD_ROOT
186
187 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
188 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
189
190 # gitweb
191 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
192 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
193 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
194 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
195 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
196
197 # remove unneeded files
198 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
199 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
205 %webapp_register apache %{webapp}
206
207 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
208 %webapp_unregister apache %{webapp}
209
210 %triggerin gitweb -- apache < 2.2.0, apache-base
211 %webapp_register httpd %{webapp}
212
213 %triggerun gitweb -- apache < 2.2.0, apache-base
214 %webapp_unregister httpd %{webapp}
215
216 %files
217 %defattr(644,root,root,755)
218 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
219 %attr(755,root,root) %{_bindir}/git
220 %attr(755,root,root) %{_bindir}/git-*
221 %{_mandir}/man1/git-*.1*
222 %{_mandir}/man5/gitattributes.5*
223 %{_mandir}/man5/gitignore.5*
224 %{_mandir}/man7/git.7*
225 %{_datadir}/%{name}
226 %{_datadir}/git-gui
227 %{_sharedstatedir}/git
228
229 %files devel
230 %defattr(644,root,root,755)
231 %{_includedir}/*
232
233 %files gitk
234 %defattr(644,root,root,755)
235 %doc Documentation/gitk.html
236 %attr(755,root,root) %{_bindir}/gitk
237 %{_mandir}/man1/gitk.1*
238
239 %files gitweb
240 %defattr(644,root,root,755)
241 %doc gitweb/{README,INSTALL}
242 %dir %{webappdir}
243 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
244 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
245 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
246 %attr(755,root,root) %{cgibindir}/gitweb.cgi
247 %{appdir}
248
249 %files -n perl-Git
250 %defattr(644,root,root,755)
251 %{perl_vendorlib}/Git.pm
252 %{_mandir}/man3/Git.3pm*
This page took 0.061248 seconds and 4 git commands to generate.